aboutsummaryrefslogtreecommitdiff
path: root/lang/solidity/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2019-01-18 15:53:16 +0000
committerAlex Dupre <ale@FreeBSD.org>2019-01-18 15:53:16 +0000
commite20178f31024b4071b03de0964e9df54d075af5d (patch)
tree6c6d901a31a293ce3c30b1e078d373203d0baf93 /lang/solidity/Makefile
parent3f497d4050b9a73dc48eac505660b7134afe7c45 (diff)
downloadports-e20178f31024b4071b03de0964e9df54d075af5d.tar.gz
ports-e20178f31024b4071b03de0964e9df54d075af5d.zip
Notes
Diffstat (limited to 'lang/solidity/Makefile')
-rw-r--r--lang/solidity/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/lang/solidity/Makefile b/lang/solidity/Makefile
index 6a664b7e46e1..7722cafb8620 100644
--- a/lang/solidity/Makefile
+++ b/lang/solidity/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= solidity
-PORTVERSION= 0.4.25
-PORTREVISION= 2
+PORTVERSION= 0.5.2
CATEGORIES= lang
MASTER_SITES= https://github.com/ethereum/solidity/releases/download/v${PORTVERSION}/
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -16,12 +15,17 @@ LICENSE= GPLv3
BUILD_DEPENDS= boost-libs>=0:devel/boost-libs
LIB_DEPENDS= libjsoncpp.so:devel/jsoncpp
-OPTIONS_DEFINE= SMT
-SMT_DESC= SMT Checker
-SMT_LIB_DEPENDS=libz3.so:math/z3
-
USES= cmake compiler:c++14-lang
+OPTIONS_DEFINE= Z3 CVC4
+OPTIONS_DEFAULT= Z3 CVC4
+Z3_DESC= SMT Checker via Z3
+CVC4_DESC= SMT Checker via CVC4
+Z3_LIB_DEPENDS= libz3.so:math/z3
+CVC4_LIB_DEPENDS= libcvc4.so:math/cvc4
+Z3_CMAKE_OFF= USE_Z3
+CVC4_CMAKE_OFF= USE_CVC4
+
CMAKE_ARGS+= -DUSE_LD_GOLD=OFF -DTESTS=OFF \
-DJSONCPP_INCLUDE_DIR:STRING="${LOCALBASE}/include/jsoncpp" \
-DJSONCPP_LIB_DIR:STRING="${LOCALBASE}/lib"