aboutsummaryrefslogtreecommitdiff
path: root/lang/spidermonkey24
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-01-18 16:33:30 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-01-18 16:33:30 +0000
commitd1e3affcf1a0ce42d8e67f893a34a69cfb7eaf37 (patch)
tree1e5fd3948905f575dcf2d07b736cf5ddfa962c76 /lang/spidermonkey24
parentf9762d70f62f5b7da3de495bb4b510e229261f9b (diff)
downloadports-d1e3affcf1a0ce42d8e67f893a34a69cfb7eaf37.tar.gz
ports-d1e3affcf1a0ce42d8e67f893a34a69cfb7eaf37.zip
lang/spidermonkey24: prefer pre-C++11 decltype from libc++
libc++ 4.0 started to use it within <string> in a way incompatible with __typeof__ which broke build but upstream switched to C++11 long ago to notice -Wmacro-redefined. PR: 216010 MFH: 2017Q1
Notes
Notes: svn path=/head/; revision=431816
Diffstat (limited to 'lang/spidermonkey24')
-rw-r--r--lang/spidermonkey24/Makefile2
-rw-r--r--lang/spidermonkey24/files/patch-mfbt_Types.h12
2 files changed, 13 insertions, 1 deletions
diff --git a/lang/spidermonkey24/Makefile b/lang/spidermonkey24/Makefile
index c78bd755e38b..a0d16dbb9905 100644
--- a/lang/spidermonkey24/Makefile
+++ b/lang/spidermonkey24/Makefile
@@ -3,7 +3,7 @@
PORTNAME= spidermonkey24
PORTVERSION= 24.2.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang
MASTER_SITES= MOZILLA/js
#http://people.mozilla.org/~sstangl/
diff --git a/lang/spidermonkey24/files/patch-mfbt_Types.h b/lang/spidermonkey24/files/patch-mfbt_Types.h
new file mode 100644
index 000000000000..7cfdf5e60b67
--- /dev/null
+++ b/lang/spidermonkey24/files/patch-mfbt_Types.h
@@ -0,0 +1,12 @@
+--- ../../mfbt/Types.h.orig 2013-10-29 20:40:19 UTC
++++ ../../mfbt/Types.h
+@@ -138,7 +138,9 @@
+ */
+ #if defined(__GNUC__) && defined(__cplusplus) && \
+ !defined(__GXX_EXPERIMENTAL_CXX0X__) && __cplusplus < 201103L
++# ifndef decltype
+ # define decltype __typeof__
++# endif
+ #endif
+
+ #endif /* mozilla_Types_h_ */