aboutsummaryrefslogtreecommitdiff
path: root/lang/spidermonkey24
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-12-17 00:17:45 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-12-17 00:17:45 +0000
commitde9d0003013d7f10b1c8d9fef9359b34ff82cfae (patch)
tree982829e953d28b3acf9e961102a8cee5bf4a1c59 /lang/spidermonkey24
parentfe44fcdc878be7356bfdb66df05a970975d52e89 (diff)
downloadports-de9d0003013d7f10b1c8d9fef9359b34ff82cfae.tar.gz
ports-de9d0003013d7f10b1c8d9fef9359b34ff82cfae.zip
Notes
Diffstat (limited to 'lang/spidermonkey24')
-rw-r--r--lang/spidermonkey24/Makefile123
-rw-r--r--lang/spidermonkey24/distinfo2
-rw-r--r--lang/spidermonkey24/pkg-descr3
-rw-r--r--lang/spidermonkey24/pkg-plist81
4 files changed, 209 insertions, 0 deletions
diff --git a/lang/spidermonkey24/Makefile b/lang/spidermonkey24/Makefile
new file mode 100644
index 000000000000..c0e54013997b
--- /dev/null
+++ b/lang/spidermonkey24/Makefile
@@ -0,0 +1,123 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= spidermonkey24
+PORTVERSION= 24.2.0
+CATEGORIES= lang
+MASTER_SITES= ${MASTER_SITE_MOZILLA}
+#http://people.mozilla.org/~sstangl/
+MASTER_SITE_SUBDIR= js
+DISTNAME= mozjs-${PORTVERSION}
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= Standalone JavaScript based from Mozilla 24-esr
+
+BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
+LIB_DEPENDS= libnspr4.so:${PORTSDIR}/devel/nspr
+
+CONFLICTS= njs-[0-9]*
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USES= gmake pathfix perl5
+USE_PERL5= build
+USE_LDCONFIG= yes
+USE_PYTHON_BUILD= -2.7
+
+WRKSRC= ${WRKDIR}/mozjs-${PORTVERSION}/js/src
+
+CONFIGURE_ARGS= --with-pthreads \
+ --with-system-nspr
+
+OPTIONS_DEFINE= DEBUG GCZEAL JEMALLOC METHODJIT OPTIMIZE READLINE \
+ THREADSAFE TRACEJIT UTF8 \
+
+OPTIONS_DEFAULT= METHODJIT OPTIMIZE READLINE THREADSAFE TRACEJIT
+
+DEBUG_DESC= Enable Debug build
+GCZEAL_DESC= Enable Zealous garbage collecting
+JEMALLOC_DESC= Use jemalloc as memory allocator
+METHODJIT_DESC= Enable method JIT support
+OPTIMIZE_DESC= Enable compiler optimizations
+READLINE_DESC= Link js shell to system readline library
+THREADSAFE_DESC= Enable multiple thread support
+TRACEJIT_DESC= Enable tracing JIT support
+UTF8_DESC= Treat strings as UTF8 instead of ISO-8859-1
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDEBUG}
+CONFIGURE_ARGS+= --enable-debug \
+ --enable-debug-symbols
+.else
+CONFIGURE_ARGS+= --disable-debug
+.endif
+
+.if ${PORT_OPTIONS:MGCZEAL}
+CONFIGURE_ARGS+= --enable-gczeal
+.else
+CONFIGURE_ARGS+= --disable-gczeal
+.endif
+
+.if ${PORT_OPTIONS:MJEMALLOC}
+CONFIGURE_ARGS+= --enable-jemalloc
+.else
+CONFIGURE_ARGS+= --disable-jemalloc
+.endif
+
+.if ${PORT_OPTIONS:MMETHODJIT}
+CONFIGURE_ARGS+= --enable-methodjit
+.else
+CONFIGURE_ARGS+= --disable-methodjit
+.endif
+
+.if ${PORT_OPTIONS:MOPTIMIZE}
+CONFIGURE_ARGS+= --enable-optimize
+.else
+CONFIGURE_ARGS+= --disable-optimize
+.endif
+
+.if ${PORT_OPTIONS:MREADLINE}
+CONFIGURE_ARGS+= --enable-readline
+.else
+CONFIGURE_ARGS+= --disable-readline
+.endif
+
+.if ${PORT_OPTIONS:MTHREADSAFE}
+CONFIGURE_ARGS+= --enable-threadsafe
+.else
+CONFIGURE_ARGS+= --disable-threadsafe
+.endif
+
+.if ${PORT_OPTIONS:MTRACEJIT}
+CONFIGURE_ARGS+= --enable-tracejit
+.else
+CONFIGURE_ARGS+= --disable-tracejit
+.endif
+
+.if ${PORT_OPTIONS:MUTF8}
+CFLAGS+= -DJS_C_STRINGS_ARE_UTF8
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == amd64
+CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
+.endif
+
+regression-test: build
+ @${ECHO_MSG} -n "===> Running jstests.py: "
+ @cd ${WRKSRC} && ${SETENV} TZ=PST8PDT ${PYTHON_CMD} tests/jstests.py \
+ --no-progress ./js24
+.if ${PORT_OPTIONS:MMETHODJIT} || ${PORT_OPTIONS:MTRACEJIT}
+ @${ECHO_MSG} -n "===> Running jit_test.py: "
+ @cd ${WRKSRC} && ${SETENV} TZ=PST8PDT ${PYTHON_CMD} jit-test/jit_test.py \
+ --no-progress --jitflags=,m,j,mj,mjp,am,amj,amjp,amd ./js24
+.endif
+
+post-install:
+ ${LN} -s libmozjs-24.so ${STAGEDIR}${PREFIX}/lib/libmozjs-24.so.1
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/js24
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libmozjs-24.*
+
+.include <bsd.port.post.mk>
diff --git a/lang/spidermonkey24/distinfo b/lang/spidermonkey24/distinfo
new file mode 100644
index 000000000000..c60b5a9174b7
--- /dev/null
+++ b/lang/spidermonkey24/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mozjs-24.2.0.tar.bz2) = e62f3f331ddd90df1e238c09d61a505c516fe9fd8c5c95336611d191d18437d8
+SIZE (mozjs-24.2.0.tar.bz2) = 15624530
diff --git a/lang/spidermonkey24/pkg-descr b/lang/spidermonkey24/pkg-descr
new file mode 100644
index 000000000000..db4318240eed
--- /dev/null
+++ b/lang/spidermonkey24/pkg-descr
@@ -0,0 +1,3 @@
+Spidermonkey is the JavaScript interpreter from the Mozilla project.
+
+WWW: http://www.mozilla.org/js/spidermonkey/
diff --git a/lang/spidermonkey24/pkg-plist b/lang/spidermonkey24/pkg-plist
new file mode 100644
index 000000000000..24543396fdef
--- /dev/null
+++ b/lang/spidermonkey24/pkg-plist
@@ -0,0 +1,81 @@
+bin/js24
+bin/js24-config
+include/mozjs-24/js-config.h
+include/mozjs-24/js.msg
+include/mozjs-24/js/Anchor.h
+include/mozjs-24/js/CallArgs.h
+include/mozjs-24/js/CharacterEncoding.h
+include/mozjs-24/js/Date.h
+include/mozjs-24/js/GCAPI.h
+include/mozjs-24/js/HashTable.h
+include/mozjs-24/js/HeapAPI.h
+include/mozjs-24/js/LegacyIntTypes.h
+include/mozjs-24/js/MemoryMetrics.h
+include/mozjs-24/js/PropertyKey.h
+include/mozjs-24/js/RequiredDefines.h
+include/mozjs-24/js/RootingAPI.h
+include/mozjs-24/js/TemplateLib.h
+include/mozjs-24/js/Utility.h
+include/mozjs-24/js/Value.h
+include/mozjs-24/js/Vector.h
+include/mozjs-24/jsalloc.h
+include/mozjs-24/jsapi.h
+include/mozjs-24/jsclass.h
+include/mozjs-24/jsclist.h
+include/mozjs-24/jscpucfg.h
+include/mozjs-24/jsdbgapi.h
+include/mozjs-24/jsfriendapi.h
+include/mozjs-24/jslock.h
+include/mozjs-24/jsperf.h
+include/mozjs-24/jsprf.h
+include/mozjs-24/jsprototypes.h
+include/mozjs-24/jsproxy.h
+include/mozjs-24/jsprvtd.h
+include/mozjs-24/jspubtd.h
+include/mozjs-24/jstypes.h
+include/mozjs-24/jsutil.h
+include/mozjs-24/jsversion.h
+include/mozjs-24/jswrapper.h
+include/mozjs-24/mozilla/Assertions.h
+include/mozjs-24/mozilla/Atomics.h
+include/mozjs-24/mozilla/Attributes.h
+include/mozjs-24/mozilla/BloomFilter.h
+include/mozjs-24/mozilla/Casting.h
+include/mozjs-24/mozilla/Char16.h
+include/mozjs-24/mozilla/CheckedInt.h
+include/mozjs-24/mozilla/Compiler.h
+include/mozjs-24/mozilla/Constants.h
+include/mozjs-24/mozilla/DebugOnly.h
+include/mozjs-24/mozilla/Decimal.h
+include/mozjs-24/mozilla/Endian.h
+include/mozjs-24/mozilla/EnumSet.h
+include/mozjs-24/mozilla/FloatingPoint.h
+include/mozjs-24/mozilla/GuardObjects.h
+include/mozjs-24/mozilla/HashFunctions.h
+include/mozjs-24/mozilla/Likely.h
+include/mozjs-24/mozilla/LinkedList.h
+include/mozjs-24/mozilla/MSStdInt.h
+include/mozjs-24/mozilla/MathAlgorithms.h
+include/mozjs-24/mozilla/MemoryChecking.h
+include/mozjs-24/mozilla/NullPtr.h
+include/mozjs-24/mozilla/PodOperations.h
+include/mozjs-24/mozilla/Poison.h
+include/mozjs-24/mozilla/Range.h
+include/mozjs-24/mozilla/RangedPtr.h
+include/mozjs-24/mozilla/RefPtr.h
+include/mozjs-24/mozilla/SHA1.h
+include/mozjs-24/mozilla/Scoped.h
+include/mozjs-24/mozilla/SplayTree.h
+include/mozjs-24/mozilla/StandardInteger.h
+include/mozjs-24/mozilla/ThreadLocal.h
+include/mozjs-24/mozilla/TypeTraits.h
+include/mozjs-24/mozilla/TypedEnum.h
+include/mozjs-24/mozilla/Types.h
+include/mozjs-24/mozilla/Util.h
+include/mozjs-24/mozilla/WeakPtr.h
+lib/libmozjs-24.so
+lib/libmozjs-24.so.1
+libdata/pkgconfig/mozjs-24.pc
+@dirrm include/mozjs-24/mozilla
+@dirrm include/mozjs-24/js
+@dirrm include/mozjs-24