aboutsummaryrefslogtreecommitdiff
path: root/lang/spidermonkey
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-08-05 18:19:38 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-08-05 18:19:38 +0000
commita0dc8a9e4468a04ad1f086c043dfee8eb066a44a (patch)
tree45df729343b41953c1c79a8e5b0e746e03740b74 /lang/spidermonkey
parent0155a9055850b8efdd26d3b1e582f193e88397f3 (diff)
downloadports-a0dc8a9e4468a04ad1f086c043dfee8eb066a44a.tar.gz
ports-a0dc8a9e4468a04ad1f086c043dfee8eb066a44a.zip
Notes
Diffstat (limited to 'lang/spidermonkey')
-rw-r--r--lang/spidermonkey/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/spidermonkey/Makefile b/lang/spidermonkey/Makefile
index 320866b6d32b..55e5075746b1 100644
--- a/lang/spidermonkey/Makefile
+++ b/lang/spidermonkey/Makefile
@@ -55,7 +55,7 @@ INSTALLS_SHLIB= YES
SRC_DIR= js/src
JSH= jsapi.h jsautocfg.h jscompat.h jslong.h jsosdep.h jsotypes.h jspubtd.h jstypes.h \
jsstr.h jshash.h jsprvtd.h
-PLIST_FILES= bin/js lib/libjs.so ${JSH:S,^,include/,}
+PLIST_FILES= bin/js lib/libjs.so lib/libjs.so.1 ${JSH:S,^,include/,}
WRKSRC= ${WRKDIR}/${SRC_DIR}
EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
--exclude js/jsd \
@@ -86,6 +86,7 @@ do-install:
${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/${OPSYS}`${UNAME} -r`_DBG.OBJ/libjs.so \
${PREFIX}/lib
+ ${LN} -sf ${PREFIX}/lib/libjs.so ${PREFIX}/lib/libjs.so.1
${CP} ${WRKSRC}/${OPSYS}`${UNAME} -r`_DBG.OBJ/jsautocfg.h ${WRKSRC}
@${INSTALL_DATA} ${JSH:S,^,${WRKSRC}/,} ${PREFIX}/include/