aboutsummaryrefslogtreecommitdiff
path: root/lang/spidermonkey
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-05-21 15:29:40 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-05-21 15:29:40 +0000
commit73dc414a41bcd294503894fce6422606a018c6ba (patch)
tree9d1aeadcd5aac25c442079a50944cd630bbc3dbe /lang/spidermonkey
parent83b01dcaf6472bac551c751aef05a0676ed03db8 (diff)
Notes
Diffstat (limited to 'lang/spidermonkey')
-rw-r--r--lang/spidermonkey/Makefile7
-rw-r--r--lang/spidermonkey/pkg-plist10
2 files changed, 4 insertions, 13 deletions
diff --git a/lang/spidermonkey/Makefile b/lang/spidermonkey/Makefile
index b2954d44697d..320866b6d32b 100644
--- a/lang/spidermonkey/Makefile
+++ b/lang/spidermonkey/Makefile
@@ -53,6 +53,9 @@ ALL_TARGET= ${OPSYS}`${UNAME} -r`_DBG.OBJ/js
MAKE_ENV+= CC="${CC}" CCC="${CXX}"
INSTALLS_SHLIB= YES
SRC_DIR= js/src
+JSH= jsapi.h jsautocfg.h jscompat.h jslong.h jsosdep.h jsotypes.h jspubtd.h jstypes.h \
+ jsstr.h jshash.h jsprvtd.h
+PLIST_FILES= bin/js lib/libjs.so ${JSH:S,^,include/,}
WRKSRC= ${WRKDIR}/${SRC_DIR}
EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
--exclude js/jsd \
@@ -84,8 +87,6 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${OPSYS}`${UNAME} -r`_DBG.OBJ/libjs.so \
${PREFIX}/lib
${CP} ${WRKSRC}/${OPSYS}`${UNAME} -r`_DBG.OBJ/jsautocfg.h ${WRKSRC}
-.for jsh in jsapi.h jsautocfg.h jscompat.h jslong.h jsosdep.h jsotypes.h jspubtd.h jstypes.h
- @${INSTALL_DATA} ${WRKSRC}/${jsh} ${PREFIX}/include/
-.endfor
+ @${INSTALL_DATA} ${JSH:S,^,${WRKSRC}/,} ${PREFIX}/include/
.include <bsd.port.post.mk>
diff --git a/lang/spidermonkey/pkg-plist b/lang/spidermonkey/pkg-plist
deleted file mode 100644
index 20ab0fd5e126..000000000000
--- a/lang/spidermonkey/pkg-plist
+++ /dev/null
@@ -1,10 +0,0 @@
-bin/js
-lib/libjs.so
-include/jsapi.h
-include/jsautocfg.h
-include/jscompat.h
-include/jslong.h
-include/jsosdep.h
-include/jsotypes.h
-include/jspubtd.h
-include/jstypes.h