aboutsummaryrefslogtreecommitdiff
path: root/lang/spidermonkey
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-06-23 19:47:12 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-06-23 19:47:12 +0000
commit2cbd3442fb5a0feaec0b3a9ed249c278692dade5 (patch)
tree691e9791caab9681ae3f3d762cfb931d922c5e88 /lang/spidermonkey
parent5cfedfc103e44097a79ca3d766d28169460a6633 (diff)
downloadports-2cbd3442fb5a0feaec0b3a9ed249c278692dade5.tar.gz
ports-2cbd3442fb5a0feaec0b3a9ed249c278692dade5.zip
Notes
Diffstat (limited to 'lang/spidermonkey')
-rw-r--r--lang/spidermonkey/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/lang/spidermonkey/Makefile b/lang/spidermonkey/Makefile
index af963aefcd3b..d1ecbf6a6b12 100644
--- a/lang/spidermonkey/Makefile
+++ b/lang/spidermonkey/Makefile
@@ -7,11 +7,8 @@
PORTNAME= spidermonkey
DISTVERSION= 1.7.0
CATEGORIES= lang
-MASTER_SITES= http://ftp.mozilla.org/pub/mozilla.org/js/ \
- http://ftp.belnet.be/mirrors/ftp.mozilla.org/js/ \
- http://gentoo.netnitco.net/distfiles/ \
- http://gd.tuwien.ac.at/opsys/linux/gentoo/distfiles/ \
- ftp://ftp.mozilla.org/pub/mozilla.org/js/
+MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
+MASTER_SITE_SUBDIR= js
DISTNAME= js-${DISTVERSION}
MAINTAINER= citric@cubicone.tmetic.com
@@ -32,9 +29,16 @@ ALL_TARGET= ${OPSYS}`${UNAME} -r`_DBG.OBJ/js
MAKE_ENV+= CCC="${CXX}"
USE_LDCONFIG= yes
SRC_DIR= js/src
-JSH= jsapi.h jsautocfg.h jsconfig.h jscompat.h jslong.h jsosdep.h \
- jsotypes.h jspubtd.h jstypes.h jsstr.h jshash.h jsprvtd.h \
+
+JSH= jsapi.h jsarena.h jsarray.h jsatom.h jsautocfg.h jsbool.h \
+ jsclist.h jscntxt.h jscompat.h jsconfig.h jsdate.h jsdhash.h \
+ jsdtoa.h jsemit.h jsexn.h jsfun.h jsgc.h jshash.h jsinterp.h \
+ jsiter.h jslibmath.h jslock.h jslong.h jsmath.h jsnum.h jsobj.h \
+ jsopcode.h jsosdep.h jsotypes.h jsparse.h jsprvtd.h jspubtd.h \
+ jsregexp.h jsscan.h jsscope.h jsscript.h jsstr.h jstypes.h \
+ jsxdrapi.h jsxml.h \
jsproto.tbl
+
PLIST_FILES= bin/js lib/libjs.so lib/libjs.so.1 ${JSH:S,^,include/,}
WRKSRC= ${WRKDIR}/${SRC_DIR}
EXTRACT_AFTER_ARGS=| ${TAR} -xf - \