aboutsummaryrefslogtreecommitdiff
path: root/lang/squeak3/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-12-25 01:54:08 +0000
committerSteve Price <steve@FreeBSD.org>1999-12-25 01:54:08 +0000
commitb3b478f4db79db61f9d55748ffe60066161d17bc (patch)
tree2f36daf88e2d0db10be30b5fc16f395590fdb065 /lang/squeak3/Makefile
parent01eaefc950bc676b0cbdf1d0a093e8f898af9a28 (diff)
downloadports-b3b478f4db79db61f9d55748ffe60066161d17bc.tar.gz
ports-b3b478f4db79db61f9d55748ffe60066161d17bc.zip
Notes
Diffstat (limited to 'lang/squeak3/Makefile')
-rw-r--r--lang/squeak3/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/lang/squeak3/Makefile b/lang/squeak3/Makefile
index ce8f460187ad..c800079fb64a 100644
--- a/lang/squeak3/Makefile
+++ b/lang/squeak3/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= lang
MASTER_SITES= ftp://ftp.cs.uni-magdeburg.de/pub/Smalltalk/Smalltalk/Squeak/unix/ \
ftp://ftp.cs.uni-magdeburg.de/pub/Smalltalk/Smalltalk/Squeak/unix/image/ \
http://www.nectar.com/distfiles/squeak/
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} image/${SQUEAK_SRC}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${SQUEAK_SRC}
MAINTAINER= jesse@cs.uni-magdeburg.de
@@ -25,7 +25,13 @@ SQUEAK_SRC= SqueakV2.sources
MAKEFILE= GNUmakefile
VMBUILD= freebsd
MAKE_ARGS= VMBUILD=${VMBUILD}
-PORTMAKE= ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
+.ifdef (CC)
+MAKE_ARGS+= CC=${CC}
+.endif
+.ifdef (CFLAGS)
+MAKE_ARGS+= CCFLAGS="${CFLAGS}"
+.endif
+PORTMAKE= ${SETENV} ${MAKE_ENV} ${GMAKE} -e ${MAKE_FLAGS} \
${MAKEFILE} ${MAKE_ARGS}
do-build:
@@ -39,7 +45,7 @@ do-install:
.for f in Squeak2.4.changes Squeak2.4.image
(cd ${WRKSRC}/image && ${INSTALL_DATA} $f ${PREFIX}/share/squeak/$f)
.endfor
- ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/image/${SQUEAK_SRC} \
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${SQUEAK_SRC} \
${PREFIX}/share/squeak/${SQUEAK_SRC}
.include <bsd.port.mk>