aboutsummaryrefslogtreecommitdiff
path: root/lang/stackless_python
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-03-29 13:18:53 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-03-29 13:18:53 +0000
commit1d4237a84fd6bce2688519e17028687101e531fc (patch)
tree4331eef1708320fce58695ffb1489acccfa2a528 /lang/stackless_python
parenta27752ff632e88dd47fd423535cd9c708fdda51e (diff)
downloadports-1d4237a84fd6bce2688519e17028687101e531fc.tar.gz
ports-1d4237a84fd6bce2688519e17028687101e531fc.zip
Notes
Diffstat (limited to 'lang/stackless_python')
-rw-r--r--lang/stackless_python/Makefile32
-rw-r--r--lang/stackless_python/distinfo2
-rw-r--r--lang/stackless_python/files/Setup.stackless4
-rw-r--r--lang/stackless_python/pkg-comment1
-rw-r--r--lang/stackless_python/pkg-descr9
-rw-r--r--lang/stackless_python/pkg-plist.add1
6 files changed, 49 insertions, 0 deletions
diff --git a/lang/stackless_python/Makefile b/lang/stackless_python/Makefile
new file mode 100644
index 000000000000..0d09747935fc
--- /dev/null
+++ b/lang/stackless_python/Makefile
@@ -0,0 +1,32 @@
+# Ports collection makefile for: stackless_python
+# Date created: 29 March 2001
+# Whom: Hye-Shik Chang <perky@python.or.kr>
+#
+# $FreeBSD$
+#
+
+PORTNAME= python
+PORTVERSION= 2.0
+CATEGORIES= lang python
+MASTER_SITES= "" # python port will override this, but it's for portlint
+PKGNAMEPREFIX= stackless_
+
+PATCH_SITES= http://www3.kr.freebsd.org/~perky/distfiles/ \
+ http://www2.freebsd-kr.org/~perky/distfiles/ \
+ ftp://ftp2.python.or.kr/pub/FreeBSD/ports/distfiles/
+PATCHFILES= stackless-010223.diff.gz
+PATCH_DIST_STRIP= -p1
+
+MAINTAINER= perky@python.or.kr
+
+MASTERDIR= ${.CURDIR}/../../lang/python
+
+# stackless python port infoes
+COMMENT= ${.CURDIR}/pkg-comment
+DESCR= ${.CURDIR}/pkg-descr
+MD5_FILE= ${.CURDIR}/distinfo
+PLIST_SLAVE= ${.CURDIR}/pkg-plist.add
+
+SETUP_LOCAL+= ../../../lang/${PKGNAMEPREFIX}${PORTNAME}/files/Setup.stackless # relative from python port
+
+.include "${MASTERDIR}/Makefile"
diff --git a/lang/stackless_python/distinfo b/lang/stackless_python/distinfo
new file mode 100644
index 000000000000..ac3b459a8ffe
--- /dev/null
+++ b/lang/stackless_python/distinfo
@@ -0,0 +1,2 @@
+MD5 (python/BeOpen-Python-2.0.tar.gz) = 8c4a64891d3dc6422df2514c603f0c98
+MD5 (python/stackless-010223.diff.gz) = 2aac9dd230afcd1ced77e881565920c0
diff --git a/lang/stackless_python/files/Setup.stackless b/lang/stackless_python/files/Setup.stackless
new file mode 100644
index 000000000000..d53ac607fb4f
--- /dev/null
+++ b/lang/stackless_python/files/Setup.stackless
@@ -0,0 +1,4 @@
+*static*
+
+# Christian Tismer's continuation module (part of Stackless Python)
+continuation continuationmodule.c
diff --git a/lang/stackless_python/pkg-comment b/lang/stackless_python/pkg-comment
new file mode 100644
index 000000000000..a697cb271442
--- /dev/null
+++ b/lang/stackless_python/pkg-comment
@@ -0,0 +1 @@
+A Python implementation that does not use the C stack
diff --git a/lang/stackless_python/pkg-descr b/lang/stackless_python/pkg-descr
new file mode 100644
index 000000000000..e7a7ff0d8cf5
--- /dev/null
+++ b/lang/stackless_python/pkg-descr
@@ -0,0 +1,9 @@
+Stackless Python is an alternative implementation of Python
+created by independent developer Christian Tismer.
+It can make Python faster, smaller, more flexible, safer.
+and supports continuation, microthread, and so many fascinative
+features.
+
+WWW: http://www.stackless.com/
+
+- Hye-Shik Chang, a.k.a, "Perky"
diff --git a/lang/stackless_python/pkg-plist.add b/lang/stackless_python/pkg-plist.add
new file mode 100644
index 000000000000..e3e1000d35b3
--- /dev/null
+++ b/lang/stackless_python/pkg-plist.add
@@ -0,0 +1 @@
+include/%%PYTHON_VERSION%%/python.h