aboutsummaryrefslogtreecommitdiff
path: root/lang/tcl82
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2001-11-14 08:44:08 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2001-11-14 08:44:08 +0000
commit3b37e7ae6b65c313bdcf0bb4343fb2f1dd3277b5 (patch)
tree4800156433f53a39d84d618bcc4a50854449e8ea /lang/tcl82
parent0b7d463834a064b34dd1d2641249da26c082f92e (diff)
downloadports-3b37e7ae6b65c313bdcf0bb4343fb2f1dd3277b5.tar.gz
ports-3b37e7ae6b65c313bdcf0bb4343fb2f1dd3277b5.zip
Notes
Diffstat (limited to 'lang/tcl82')
-rw-r--r--lang/tcl82/Makefile3
-rw-r--r--lang/tcl82/files/patch-tclUnixPipe.c13
-rw-r--r--lang/tcl82/files/patch-tclUnixSock.c11
3 files changed, 26 insertions, 1 deletions
diff --git a/lang/tcl82/Makefile b/lang/tcl82/Makefile
index be5a061e3e60..5cc15f933ab1 100644
--- a/lang/tcl82/Makefile
+++ b/lang/tcl82/Makefile
@@ -7,11 +7,12 @@
PORTNAME= tcl
PORTVERSION= 8.2.3
+PORTREVISION= 1
CATEGORIES= lang tcl82
MASTER_SITES= ftp://ftp.scriptics.com/pub/tcl/tcl8_2/
DISTNAME= tcl8.2.3
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= dinoex@FreeBSD.org
NO_LATEST_LINK= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
diff --git a/lang/tcl82/files/patch-tclUnixPipe.c b/lang/tcl82/files/patch-tclUnixPipe.c
new file mode 100644
index 000000000000..1d9c0be1e0fa
--- /dev/null
+++ b/lang/tcl82/files/patch-tclUnixPipe.c
@@ -0,0 +1,13 @@
+--- tclUnixPipe.c.orig Tue Nov 30 09:43:03 1999
++++ tclUnixPipe.c Wed Nov 14 09:09:20 2001
+@@ -185,8 +185,8 @@
+ char fileName[L_tmpnam];
+ int fd;
+
+- tmpnam(fileName); /* INTL: Native. */
+- fd = open(fileName, O_RDWR|O_CREAT|O_TRUNC, 0666); /* INTL: Native. */
++ strlcpy(fileName, "/var/tmp/tcltmp.XXXXXX", L_tmpnam);
++ fd = mkstemp(fileName); /* INTL: Native. */
+ if (fd == -1) {
+ return NULL;
+ }
diff --git a/lang/tcl82/files/patch-tclUnixSock.c b/lang/tcl82/files/patch-tclUnixSock.c
new file mode 100644
index 000000000000..44f7e59d6789
--- /dev/null
+++ b/lang/tcl82/files/patch-tclUnixSock.c
@@ -0,0 +1,11 @@
+--- tclUnixSock.c.orig Fri Apr 16 02:48:05 1999
++++ tclUnixSock.c Wed Nov 14 09:25:20 2001
+@@ -80,7 +80,7 @@
+ }
+
+ native = NULL;
+-#ifndef NO_UNAME
++#if 0
+ (VOID *) memset((VOID *) &u, (int) 0, sizeof(struct utsname));
+ if (uname(&u) > -1) { /* INTL: Native. */
+ hp = gethostbyname(u.nodename); /* INTL: Native. */