aboutsummaryrefslogtreecommitdiff
path: root/lang/tcl83
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-11 04:05:52 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-11 04:05:52 +0000
commit7f21765ca53eaf3a1fccb48ff2e8cf4fb959975a (patch)
treeef31276220c2032907672c60ee08bf4e79aac6b6 /lang/tcl83
parent08d0acafb8c32cf74a736721334ebebb0fbc1b19 (diff)
downloadports-7f21765ca53eaf3a1fccb48ff2e8cf4fb959975a.tar.gz
ports-7f21765ca53eaf3a1fccb48ff2e8cf4fb959975a.zip
Notes
Diffstat (limited to 'lang/tcl83')
-rw-r--r--lang/tcl83/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/lang/tcl83/Makefile b/lang/tcl83/Makefile
index a337243db424..8edb3dccb5a6 100644
--- a/lang/tcl83/Makefile
+++ b/lang/tcl83/Makefile
@@ -29,11 +29,12 @@ TCL_VER= 8.3
NOPRECIOUSMAKEVARS= yes # Otherwise 'make readmes' is broken
PLIST_SUB= TCL_VER=${TCL_VER} SHORT_TCL_VER=83
-OPTIONS= TCL83_MAN "Install tcl 8.3 manpages" off
+OPTIONS_DEFINE= TCL83_MAN
+TCL83_MAN_DESC= Install tcl 8.3 manpages
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(NO_INSTALL_MANPAGES) && defined(WITH_TCL83_MAN)
+.if !defined(NO_INSTALL_MANPAGES) && ${PORT_OPTIONS:MTCL83_MAN}
MAN1= tclsh.1
@@ -437,11 +438,11 @@ post-configure:
post-install:
${INSTALL_DATA} ${FILESDIR}/koi8-u.enc \
${PREFIX}/lib/tcl${TCL_VER}/encoding/
-.if !defined(NO_INSTALL_MANPAGES) && defined(WITH_TCL83_MAN)
+.if !defined(NO_INSTALL_MANPAGES) && ${PORT_OPTIONS:MTCL83_MAN}
@cd ${WRKSRC} && ${MAKE} -f Makefile install-doc
.endif
test:
cd ${WRKSRC} && ${MAKE} test
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>