aboutsummaryrefslogtreecommitdiff
path: root/lang/tcl84/Makefile
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2006-07-05 20:04:24 +0000
committerMikhail Teterin <mi@FreeBSD.org>2006-07-05 20:04:24 +0000
commitd331ea0a395a7348d53ab2be39812bafb509e394 (patch)
tree2ae1717da9542ecaea02cfa9a2dbd5e5ce58a98a /lang/tcl84/Makefile
parent6728fa2af2a7ecb3ec784490c7246233ab6c5040 (diff)
downloadports-d331ea0a395a7348d53ab2be39812bafb509e394.tar.gz
ports-d331ea0a395a7348d53ab2be39812bafb509e394.zip
Notes
Diffstat (limited to 'lang/tcl84/Makefile')
-rw-r--r--lang/tcl84/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/lang/tcl84/Makefile b/lang/tcl84/Makefile
index d1981fef50a0..e83c440ee99d 100644
--- a/lang/tcl84/Makefile
+++ b/lang/tcl84/Makefile
@@ -612,6 +612,9 @@ pre-configure:
.endif
+# Where the below command fails, there is no need for concern:
+BLACKHOLE!= sysctl -n net.inet.tcp.blackhole
+
post-configure:
${REINPLACE_CMD} \
-e 's|${WRKDIRPREFIX}${.CURDIR}|$${WRKDIRPREFIX}${TCLBASE}|' \
@@ -627,6 +630,14 @@ post-configure:
${WRKSRC}/../doc/${mp}
. endfor
.endif
+.if ${BLACKHOLE} != '' && ${BLACKHOLE} != 0
+ # ====================================================
+ # net.inet.tcp.blackhole is non-zero. Some http-tests
+ # will appear to hang and then fail. Do not be alarmed.
+ # The socket.test would hang, so it is disabled:
+ ${MV} ${WRKSRC:H}/tests/socket.test ${WRKSRC:H}/tests/socket.test.dis;
+ # ====================================================
+.endif
post-install:
.if exists(${PKGINSTALL})