aboutsummaryrefslogtreecommitdiff
path: root/lang/tcl84
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2007-06-05 13:26:58 +0000
committerMartin Matuska <mm@FreeBSD.org>2007-06-05 13:26:58 +0000
commita5861b89dfd0ec35aa273902120726af21e3e5a3 (patch)
treea773b404fb002792e73a52e5a3189a5f21745315 /lang/tcl84
parent9e2e41c927e52f4e17fb1fa915d1c12ef99c6b4d (diff)
downloadports-a5861b89dfd0ec35aa273902120726af21e3e5a3.tar.gz
ports-a5861b89dfd0ec35aa273902120726af21e3e5a3.zip
Notes
Diffstat (limited to 'lang/tcl84')
-rw-r--r--lang/tcl84/Makefile10
-rw-r--r--lang/tcl84/files/patch-configure2
2 files changed, 7 insertions, 5 deletions
diff --git a/lang/tcl84/Makefile b/lang/tcl84/Makefile
index ff70ef95c854..272c3e9a1c61 100644
--- a/lang/tcl84/Makefile
+++ b/lang/tcl84/Makefile
@@ -7,9 +7,11 @@
PORTNAME= tcl
PORTVERSION= 8.4.15
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= lang tcl84
-MASTER_SITES= SF
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= tcl
PKGNAMESUFFIX?= ${THREADS_SUFFIX}${PKGNAMESUFFIX2}
DISTNAME= ${PORTNAME}${PORTVERSION}-src
@@ -619,9 +621,9 @@ post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
-e 's|$${TCL_TRIM_DOTS}|$${TCL_TRIM_DOTS}${THREADS_SUFFIX}|g' \
-e 's|-ltcl$${TCL_VERSION}|-ltcl$${TCL_VERSION}${THREADS_SUFFIX}|g' \
- -e 's/-ltcl`echo $${TCL_VERSION} | tr -d .`/-ltcl`echo $${TCL_VERSION} | tr -d .`${THREADS_SUFFIX}/g' \
+ -e 's/-ltcl`echo $${TCL_VERSION} | ${TR} -d .`/-ltcl`echo $${TCL_VERSION} | ${TR} -d .`${THREADS_SUFFIX}/g' \
-e 's|-ltclstub$${TCL_VERSION}|-ltclstub$${TCL_VERSION}${THREADS_SUFFIX}|g' \
- -e 's/-ltclstub`echo $${TCL_VERSION} | tr -d .`/-ltclstub`echo $${TCL_VERSION} | tr -d .`${THREADS_SUFFIX}/g' \
+ -e 's/-ltclstub`echo $${TCL_VERSION} | ${TR} -d .`/-ltclstub`echo $${TCL_VERSION} | ${TR} -d .`${THREADS_SUFFIX}/g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|libtcl$${SHORT_TCL_VER}|libtcl$${SHORT_TCL_VER}${THREADS_SUFFIX}|g' \
-e 's|$$(BIN_INSTALL_DIR)/tclsh$$(VERSION)|$$(BIN_INSTALL_DIR)/tclsh$$(VERSION)${THREADS_SUFFIX}|g' \
@@ -630,7 +632,7 @@ post-patch:
.endif
# Where the below command fails, there is no need for concern:
-BLACKHOLE!= /sbin/sysctl -n net.inet.tcp.blackhole || ${TRUE}
+BLACKHOLE!= ${SYSCTL} -n net.inet.tcp.blackhole || ${TRUE}
post-configure:
${REINPLACE_CMD} \
diff --git a/lang/tcl84/files/patch-configure b/lang/tcl84/files/patch-configure
index 0272fb1ea667..1ccf4b3a685f 100644
--- a/lang/tcl84/files/patch-configure
+++ b/lang/tcl84/files/patch-configure
@@ -14,7 +14,7 @@
# FreeBSD 3.* and greater have ELF.
SHLIB_CFLAGS="-fPIC"
- SHLIB_LD="ld -Bshareable -x"
-+ SHLIB_LD="ld -shared -x"
++ SHLIB_LD="${CC} -shared"
+ TCL_SHLIB_LD_EXTRAS="-soname \$@"
SHLIB_LD_LIBS='${LIBS}'
SHLIB_SUFFIX=".so"