aboutsummaryrefslogtreecommitdiff
path: root/lang/tcl84
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2005-06-29 13:44:01 +0000
committerMikhail Teterin <mi@FreeBSD.org>2005-06-29 13:44:01 +0000
commita70709d9cf1f3f0ad12ec462f9868134cdd5f30c (patch)
treea8be47165138b0529d42b1a59228e35bb18d762e /lang/tcl84
parent19613e4e6737cbc016deb308893dcfd92767e23a (diff)
downloadports-a70709d9cf1f3f0ad12ec462f9868134cdd5f30c.tar.gz
ports-a70709d9cf1f3f0ad12ec462f9868134cdd5f30c.zip
Notes
Diffstat (limited to 'lang/tcl84')
-rw-r--r--lang/tcl84/Makefile3
-rw-r--r--lang/tcl84/distinfo4
-rw-r--r--lang/tcl84/files/patch-aa41
-rw-r--r--lang/tcl84/pkg-plist4
4 files changed, 32 insertions, 20 deletions
diff --git a/lang/tcl84/Makefile b/lang/tcl84/Makefile
index 69aed54e1c97..20008789e12f 100644
--- a/lang/tcl84/Makefile
+++ b/lang/tcl84/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= tcl
-PORTVERSION= 8.4.7
-PORTREVISION= 0
+PORTVERSION= 8.4.10
PORTEPOCH= 1
CATEGORIES= lang tcl84
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
diff --git a/lang/tcl84/distinfo b/lang/tcl84/distinfo
index 1f2bc4ba2517..6661f3ba2ca6 100644
--- a/lang/tcl84/distinfo
+++ b/lang/tcl84/distinfo
@@ -1,2 +1,2 @@
-MD5 (tcl8.4.7-src.tar.gz) = 07e256e21bd0d05887770318b540c36f
-SIZE (tcl8.4.7-src.tar.gz) = 3472974
+MD5 (tcl8.4.10-src.tar.gz) = 409488e199a51803199d72b5dc534bb0
+SIZE (tcl8.4.10-src.tar.gz) = 3525737
diff --git a/lang/tcl84/files/patch-aa b/lang/tcl84/files/patch-aa
index 409bcd91ee10..5fe9572adedd 100644
--- a/lang/tcl84/files/patch-aa
+++ b/lang/tcl84/files/patch-aa
@@ -1,5 +1,5 @@
---- Makefile.in.orig Mon Jul 26 14:40:46 2004
-+++ Makefile.in Thu Oct 28 10:51:40 2004
+--- Makefile.in Sat Jun 4 16:39:25 2005
++++ Makefile.in Thu Jun 9 07:12:23 2005
@@ -59,2 +59,4 @@
INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(includedir)
+GENERIC_INCLUDE_INSTALL_DIR = $(INCLUDE_INSTALL_DIR)/generic
@@ -54,7 +54,7 @@
@@ -641,7 +661,13 @@
@echo "Installing header files";
- @for i in $(GENERIC_DIR)/tcl.h $(GENERIC_DIR)/tclDecls.h \
-- $(GENERIC_DIR)/tclPlatDecls.h ; \
+- $(GENERIC_DIR)/tclPlatDecls.h; \
+ @for i in $(GENERIC_DIR)/*.h ; \
do \
- $(INSTALL_DATA) $$i $(INCLUDE_INSTALL_DIR); \
@@ -68,17 +68,29 @@
+ @ln -sf $(GENERIC_INCLUDE_INSTALL_DIR)/tclDecls.h $(INCLUDE_INSTALL_DIR)/tclDecls.h
+ @ln -sf $(GENERIC_INCLUDE_INSTALL_DIR)/tclPlatDecls.h $(INCLUDE_INSTALL_DIR)/tclPlatDecls.h
@echo "Installing library files to $(SCRIPT_INSTALL_DIR)";
-@@ -703,3 +729,2 @@
- @echo "Cross-linking top-level (.1) docs";
-- @$(UNIX_DIR)/mkLinks $(MKLINKS_FLAGS) $(MAN1_INSTALL_DIR)
- @echo "Installing C API (.3) docs";
-@@ -713,3 +738,2 @@
- @echo "Cross-linking C API (.3) docs";
-- @$(UNIX_DIR)/mkLinks $(MKLINKS_FLAGS) $(MAN3_INSTALL_DIR)
- @echo "Installing command (.n) docs";
-@@ -723,3 +747,10 @@
- @echo "Cross-linking command (.n) docs";
-- @$(UNIX_DIR)/mkLinks $(MKLINKS_FLAGS) $(MANN_INSTALL_DIR)
+@@ -712,18 +738,20 @@
+ fi; \
+ done;
+- @echo "Installing and cross-linking top-level (.1) docs";
+- @for i in $(TOP_DIR)/doc/*.1; do \
+- $(UNIX_DIR)/installManPage $(MAN_FLAGS) $$i $(MAN1_INSTALL_DIR); \
+- done
++ @echo "Installing top-level (.1) docs";
++ ${BSD_INSTALL_MAN} $(TOP_DIR)/doc/*.1 $(MAN1_INSTALL_DIR)/
+
+- @echo "Installing and cross-linking C API (.3) docs";
+- @for i in $(TOP_DIR)/doc/*.3; do \
+- $(UNIX_DIR)/installManPage $(MAN_FLAGS) $$i $(MAN3_INSTALL_DIR); \
+- done
++ @echo "Installing C API (.3) docs";
++ ${BSD_INSTALL_MAN} $(TOP_DIR)/doc/*.3 $(MAN3_INSTALL_DIR)/
+
+- @echo "Installing and cross-linking command (.n) docs";
+- @for i in $(TOP_DIR)/doc/*.n; do \
+- $(UNIX_DIR)/installManPage $(MAN_FLAGS) $$i $(MANN_INSTALL_DIR); \
+- done
++ @echo "Installing command (.n) docs";
++ ${BSD_INSTALL_MAN} $(TOP_DIR)/doc/*.n $(MANN_INSTALL_DIR)/
+ @echo "**********"
+ @echo "IMPORTANT:"
+ @echo "**********"
@@ -88,3 +100,4 @@
+ @echo "There are NOT default place, but good place to avoid"
+ @echo "conflicting with another version of Tcl/Tks."
+ # Optional target to install private headers
diff --git a/lang/tcl84/pkg-plist b/lang/tcl84/pkg-plist
index 769ed7ff15a5..6ced51732ca1 100644
--- a/lang/tcl84/pkg-plist
+++ b/lang/tcl84/pkg-plist
@@ -106,8 +106,8 @@ lib/tcl%%TCL_VER%%/encoding/tis-620.enc
lib/tcl%%TCL_VER%%/history.tcl
lib/tcl%%TCL_VER%%/http1.0/http.tcl
lib/tcl%%TCL_VER%%/http1.0/pkgIndex.tcl
-lib/tcl%%TCL_VER%%/http2.4/http.tcl
-lib/tcl%%TCL_VER%%/http2.4/pkgIndex.tcl
+lib/tcl%%TCL_VER%%/http2.5/http.tcl
+lib/tcl%%TCL_VER%%/http2.5/pkgIndex.tcl
lib/tcl%%TCL_VER%%/init.tcl
lib/tcl%%TCL_VER%%/ldAix
lib/tcl%%TCL_VER%%/ldAout.tcl