aboutsummaryrefslogtreecommitdiff
path: root/lang/tclX/Makefile
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2001-08-19 15:03:59 +0000
committerMikhail Teterin <mi@FreeBSD.org>2001-08-19 15:03:59 +0000
commit079e1e238956f3f4c3cff16424a25091b8173f3a (patch)
tree2677aceebd5469ebfc501708132239d20af2afef /lang/tclX/Makefile
parent405b18363bf0a0cd23487ed3f85c46379b62ead4 (diff)
Notes
Diffstat (limited to 'lang/tclX/Makefile')
-rw-r--r--lang/tclX/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/lang/tclX/Makefile b/lang/tclX/Makefile
index 5143e9356215..6b6df140a190 100644
--- a/lang/tclX/Makefile
+++ b/lang/tclX/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tclX
PORTVERSION= 8.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang tcl${TCL_DVER} tk${TCL_DVER}
MASTER_SITES= ftp://ftp.neosoft.com/pub/tcl/tclx-distrib/
DISTNAME= tclX8.2.0
@@ -27,7 +27,6 @@ TCL_DVER?= ${TCL_VER:S/.//}
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-ALL_TARGET= all buildhelp
CONFIGURE_ARGS= --enable-shared \
--with-tcl="${LOCALBASE}/lib/tcl${TCL_VER}" \
--with-tk="${LOCALBASE}/lib/tk${TCL_VER}"
@@ -41,6 +40,8 @@ CONFIGURE_ARGS+=--with-tk="${LOCALBASE}/lib/tk${TCL_VER}"
PLIST_SUB+= X11=''
.endif
+MAKE_ENV= LDFLAGS="-lm"
+
MAN3= CmdWrite.3 Handles.3 Keylist.3 ObjCmdWrite.3 TclXInit.3 \
TclCommandWriting.3 \
TclX_KeyedListDelete.3 TclX_KeyedListGet.3 TclX_KeyedListGetKeys.3 \
@@ -52,6 +53,13 @@ MAN3= CmdWrite.3 Handles.3 Keylist.3 ObjCmdWrite.3 TclXInit.3 \
MANN= Memory.n TclX.n Tcl_DisplayMemory.n Tcl_InitMemory.n \
Tcl_ValidateAllMemory.n ckalloc.n ckfree.n memory.n
+post-build:
+ cd ${WRKSRC}/../tcl/unix && ${MAKE} buildhelp
+.ifndef WITHOUT_X11
+ cd ${WRKSRC}/../tk/unix && ${MAKE} buildhelp
+.endif
+
+
.include <bsd.port.pre.mk>
post-install: