aboutsummaryrefslogtreecommitdiff
path: root/lang/tensile/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-06 19:33:55 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-06 19:33:55 +0000
commit06e66e87b0bde0ab650a71fa4913453792026773 (patch)
treeafa786394c9710c08df7efa778155572a6d8c514 /lang/tensile/Makefile
parentabfedbe513333fb9d7b13fcbcd107ac0952c7366 (diff)
downloadports-06e66e87b0bde0ab650a71fa4913453792026773.tar.gz
ports-06e66e87b0bde0ab650a71fa4913453792026773.zip
Notes
Diffstat (limited to 'lang/tensile/Makefile')
-rw-r--r--lang/tensile/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/lang/tensile/Makefile b/lang/tensile/Makefile
new file mode 100644
index 000000000000..cc56a8e66003
--- /dev/null
+++ b/lang/tensile/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: nsl
+# Date created: May 6, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= nsl
+PORTVERSION= 0.9
+CATEGORIES= lang
+MASTER_SITES= http://savannah.gnu.org/download/nsl/ \
+ http://iling.nw.ru/~artem/downloads/
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= utils:${PORTSDIR}/lang/libutils
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 400010
+LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
+.endif
+
+.include <bsd.port.post.mk>