aboutsummaryrefslogtreecommitdiff
path: root/lang/tinycobol/Makefile
diff options
context:
space:
mode:
authorPatrick S. Gardella <patrick@FreeBSD.org>2000-10-26 15:36:48 +0000
committerPatrick S. Gardella <patrick@FreeBSD.org>2000-10-26 15:36:48 +0000
commit423ab5fb5abd9e0876d74aeab78dc7c291979c0a (patch)
tree8c54af6cee7e3744aea8e3db4dfef37e7c45731c /lang/tinycobol/Makefile
parent9d40c72ae0b29a02465dd300518b89a2baf06483 (diff)
Notes
Diffstat (limited to 'lang/tinycobol/Makefile')
-rw-r--r--lang/tinycobol/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/lang/tinycobol/Makefile b/lang/tinycobol/Makefile
new file mode 100644
index 000000000000..14753fc09781
--- /dev/null
+++ b/lang/tinycobol/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: tinycobol
+# Date created: 26 Oct 2000
+# Whom: Patrick Gardella <patrick@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tinycobol
+PORTVERSION= 0.3
+CATEGORIES= lang
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= tiny-cobol
+
+MAINTAINER= patrick@freebsd.org
+
+LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db
+
+ONLY_FOR_ARCHS= i386
+HAS_CONFIGURE= yes
+USE_GMAKE= yes
+
+CONFIGURE_ARGS= "--with-readline"
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${LDFLAGS}"
+
+pre-build:
+ ${CP} ${FILESDIR}/getopt.h ${WRKSRC}
+
+pre-install:
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/tinycobol
+ ${INSTALL_DATA} ${WRKSRC}/info/*.txt ${PREFIX}/share/doc/tinycobol
+.endif
+
+.include <bsd.port.mk>