aboutsummaryrefslogtreecommitdiff
path: root/lang/tinycobol/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-29 23:14:29 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-29 23:14:29 +0000
commitb01476185ccf30b56af11cc9a39ad12f984614c5 (patch)
treef5e87d9eb0198967ee5977849fa464ae58de4a36 /lang/tinycobol/Makefile
parentf0b648cca2a31e3f097a17cc6596ddbbeddb4bf9 (diff)
Notes
Diffstat (limited to 'lang/tinycobol/Makefile')
-rw-r--r--lang/tinycobol/Makefile26
1 files changed, 11 insertions, 15 deletions
diff --git a/lang/tinycobol/Makefile b/lang/tinycobol/Makefile
index b7299c97d012..9a17e59c3f08 100644
--- a/lang/tinycobol/Makefile
+++ b/lang/tinycobol/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= tinycobol
-PORTVERSION= 0.59
-PORTREVISION= 2
+PORTVERSION= 0.61
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tiny-cobol
@@ -17,31 +16,28 @@ COMMENT= A tiny COBOL compiler for IA32 platforms
LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db2
+INSTALLS_SHLIB= yes
ONLY_FOR_ARCHS= i386
USE_GETOPT_LONG=yes
HAS_CONFIGURE= yes
USE_BISON= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= "--with-readline"
+CONFIGURE_ARGS= --with-libdb=2
+# --with-readline disabled because of CPP-clash between readline/chardefs.h
+# and htcobol.tab.h:PAGE/RETURN/ALPHABETIC
+#CONFIGURE_ARGS+= --with-readline
CPPFLAGS= -I${LOCALBASE}/include
+CFLAGS= ${CPPFGLAGS}
LDFLAGS= -L${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= htcobol.1 htcobf2f.1 htcobolpp.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
-pre-install:
-
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/tinycobol
- ${INSTALL_DATA} ${WRKSRC}/info/*.txt ${PREFIX}/share/doc/tinycobol
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/info/*.txt ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>