aboutsummaryrefslogtreecommitdiff
path: root/lang/tinycobol/Makefile
diff options
context:
space:
mode:
authorPatrick S. Gardella <patrick@FreeBSD.org>2002-02-07 14:03:15 +0000
committerPatrick S. Gardella <patrick@FreeBSD.org>2002-02-07 14:03:15 +0000
commitb9d24b4ab8a4865d32e2791e3e599a327ba583e0 (patch)
tree64e7b15a6a097e821a89ba18af7cb2ab054807ec /lang/tinycobol/Makefile
parent7d412b8e6e71e47c499eca0dc81e11fafcb62d17 (diff)
Notes
Diffstat (limited to 'lang/tinycobol/Makefile')
-rw-r--r--lang/tinycobol/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/lang/tinycobol/Makefile b/lang/tinycobol/Makefile
index a4b5dadb7e5e..8f9ba741d4f6 100644
--- a/lang/tinycobol/Makefile
+++ b/lang/tinycobol/Makefile
@@ -13,7 +13,8 @@ MASTER_SITE_SUBDIR= tiny-cobol
MAINTAINER= patrick@freebsd.org
-LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db
+LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db \
+ gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
ONLY_FOR_ARCHS= i386
HAS_CONFIGURE= yes
@@ -21,10 +22,8 @@ USE_BISON= yes
USE_GMAKE= yes
CONFIGURE_ARGS= "--with-readline"
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${LDFLAGS}"
-
-pre-build:
- ${CP} ${FILESDIR}/getopt.h ${WRKSRC}
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt ${LDFLAGS}" \
+ CPPFLAGS="-I${LOCALBASE}/include"
pre-install: