aboutsummaryrefslogtreecommitdiff
path: root/lang/tinycobol
diff options
context:
space:
mode:
authorPatrick S. Gardella <patrick@FreeBSD.org>2002-11-05 21:51:28 +0000
committerPatrick S. Gardella <patrick@FreeBSD.org>2002-11-05 21:51:28 +0000
commit956433d0865ca633dfe7bdd8663b4b66191800f3 (patch)
tree884d92dbb402b1ace2671ba5a0ecf44ecccb2ed1 /lang/tinycobol
parent679f55238c58945151954230f2b4cfa618f81bd9 (diff)
downloadports-956433d0865ca633dfe7bdd8663b4b66191800f3.tar.gz
ports-956433d0865ca633dfe7bdd8663b4b66191800f3.zip
Notes
Diffstat (limited to 'lang/tinycobol')
-rw-r--r--lang/tinycobol/Makefile2
-rw-r--r--lang/tinycobol/distinfo2
-rw-r--r--lang/tinycobol/files/patch-aa43
-rw-r--r--lang/tinycobol/pkg-plist11
4 files changed, 34 insertions, 24 deletions
diff --git a/lang/tinycobol/Makefile b/lang/tinycobol/Makefile
index 4f2d54eb090d..3ab560effde5 100644
--- a/lang/tinycobol/Makefile
+++ b/lang/tinycobol/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tinycobol
-PORTVERSION= 0.58
+PORTVERSION= 0.59
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tiny-cobol
diff --git a/lang/tinycobol/distinfo b/lang/tinycobol/distinfo
index f171c97f0a37..4d0908e5d1e0 100644
--- a/lang/tinycobol/distinfo
+++ b/lang/tinycobol/distinfo
@@ -1 +1 @@
-MD5 (tinycobol-0.58.tar.gz) = e1646b929b9d9aba9fc04980c0131920
+MD5 (tinycobol-0.59.tar.gz) = 755d41f049f6530aab7f1b9a393472ed
diff --git a/lang/tinycobol/files/patch-aa b/lang/tinycobol/files/patch-aa
index 9e37f03927b3..f3c35804582c 100644
--- a/lang/tinycobol/files/patch-aa
+++ b/lang/tinycobol/files/patch-aa
@@ -1,29 +1,38 @@
---- configure.orig Tue Jan 29 08:30:36 2002
-+++ configure Tue Feb 5 07:30:45 2002
-@@ -522,7 +522,7 @@
+--- configure.orig Sun Oct 20 04:37:38 2002
++++ configure Tue Nov 5 16:23:57 2002
+@@ -952,7 +952,7 @@
+
ac_ext=c
- # CFLAGS is not in ac_cpp because -g, -O, etc. are not valid cpp options.
ac_cpp='$CPP $CPPFLAGS'
--ac_compile='${CC-cc} -c $CFLAGS $CPPFLAGS conftest.$ac_ext 1>&5'
-+ac_compile='${CC-cc} -c $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext 1>&5'
- ac_link='${CC-cc} -o conftest $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
+-ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
++ac_compile='$CC -c $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext >&5'
+ ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
+ ac_compiler_gnu=$ac_cv_c_compiler_gnu
- if (echo "testing\c"; echo 1,2,3) | grep c >/dev/null; then
-@@ -2085,7 +2085,7 @@
- echo $ac_n "(cached) $ac_c" 1>&6
+@@ -4070,7 +4070,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
else
- ac_save_LIBS="$LIBS"
+ ac_check_lib_save_LIBS=$LIBS
-LIBS="-ldb $LIBS"
+LIBS="-ldb2 $LIBS"
- cat > conftest.$ac_ext <<EOF
- #line 2091 "configure"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line 4075 "configure"
#include "confdefs.h"
-@@ -2835,7 +2835,7 @@
- #)
+@@ -4679,7 +4679,7 @@
+ #define USE_DB 1
+ EOF
+
+- htg_ld_args_db="-ldb"
++ htg_ld_args_db="-ldb2"
+ fi
+
+ if test "${db_version}" = "123" ; then
+@@ -5229,7 +5229,7 @@
+ #
LIBS="-L/usr/lib $M_LIBS"
-INCLUDES="-I/usr/include -I../lib -I../"
-+INCLUDES="-I/usr/include -I../lib -I../ -I/usr/local/include"
-
++INCLUDES="-I/usr/include -I../lib -I../ -I/usr/local/include"
# set default directories
+ #
diff --git a/lang/tinycobol/pkg-plist b/lang/tinycobol/pkg-plist
index cab40fbad824..37e1504d4a5b 100644
--- a/lang/tinycobol/pkg-plist
+++ b/lang/tinycobol/pkg-plist
@@ -1,15 +1,16 @@
bin/htcobol
-lib/libhtcobol.a
-lib/libhtcobol2.a
-share/htcobol/htcobolpp
share/htcobol/htcobolrc
+lib/libhtcobol.so.0.59.0
+lib/libhtcobol.so
+lib/libhtcobol.so.0
+share/htcobol/htcobolpp
share/htcobol/copybooks/screen.cpy
-@dirrm share/htcobol/copybooks
-@dirrm share/htcobol
share/doc/tinycobol/Comments.old.txt
share/doc/tinycobol/Compiler-Overview.txt
share/doc/tinycobol/GAS.asm-i386.Info.txt
share/doc/tinycobol/ProgramHeaders.Info.txt
share/doc/tinycobol/VarStructure.Info.txt
share/doc/tinycobol/compiler-design-future.txt
+@dirrm share/htcobol/copybooks
@dirrm share/doc/tinycobol
+@dirrm share/htcobol