aboutsummaryrefslogtreecommitdiff
path: root/lang/tinypy/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-04-02 00:57:07 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-04-02 00:57:07 +0000
commita3f8f8b353e3b12e4e025ca5d0ffb4961823a927 (patch)
tree371849ea50135b6afe54acf63147fd51a291e594 /lang/tinypy/Makefile
parentec05e2e29011cdf399d19d563dbd0c9eba0e2106 (diff)
downloadports-a3f8f8b353e3b12e4e025ca5d0ffb4961823a927.tar.gz
ports-a3f8f8b353e3b12e4e025ca5d0ffb4961823a927.zip
Notes
Diffstat (limited to 'lang/tinypy/Makefile')
-rw-r--r--lang/tinypy/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/lang/tinypy/Makefile b/lang/tinypy/Makefile
new file mode 100644
index 000000000000..aa177dff0653
--- /dev/null
+++ b/lang/tinypy/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: tinypy
+# Date created: 2009-02-26
+# Whom: Marcin Cieslak <saper@SYSTEM.PL>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tinypy
+PORTVERSION= 1.1
+CATEGORIES= lang python
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= saper@SYSTEM.PL
+COMMENT= A minimalist implementation of python in 64k of code
+
+USE_PYTHON_BUILD= yes
+USE_PYDISTUTILS= yes
+
+PYDISTUTILS_BUILD_TARGET= linux
+PYDISTUTILS_NOEGGINFO= yes
+
+PLIST_FILES= bin/tinypy
+PORTEXAMPLES= *
+
+OPTIONS= PYGAME "Enable PyGame support (requires SDL)" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_PYGAME)
+PYDISTUTILS_BUILD_TARGET+= pygame
+USE_SDL= sdl
+.endif
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O.||; s|gcc $$WFLAGS|${CC} ${CFLAGS} -std=c89 -Wall|' \
+ ${WRKSRC}/setup.py
+
+do-configure:
+ @${DO_NADA}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/tinypy ${PREFIX}/bin
+.if !defined(NOPORTEXAMPLES) && defined(WITH_PYGAME)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/julia.py ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.post.mk>