aboutsummaryrefslogtreecommitdiff
path: root/lang/tolua++/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-01-22 23:42:31 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-01-22 23:42:31 +0000
commitc3eab14300fe68ff98aa891519a6952076f24dce (patch)
tree96d8b3053d73ec63570d227739cd3d5deacb1210 /lang/tolua++/Makefile
parentb8df13001bbe5ab5c2b16128dadd2117f8a53f07 (diff)
downloadports-c3eab14300fe68ff98aa891519a6952076f24dce.tar.gz
ports-c3eab14300fe68ff98aa891519a6952076f24dce.zip
Notes
Diffstat (limited to 'lang/tolua++/Makefile')
-rw-r--r--lang/tolua++/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/lang/tolua++/Makefile b/lang/tolua++/Makefile
new file mode 100644
index 000000000000..2775f1396d7e
--- /dev/null
+++ b/lang/tolua++/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: tolua++
+# Date created: 18 Jan 2006
+# Whom: aaron@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= tolua++
+PORTVERSION= 1.0.4
+CATEGORIES= lang devel
+MASTER_SITES= http://www.codenix.com/~tolua/
+DISTNAME= tolua++-current
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= An extended version of tolua, a tool to integrate C/C++ code with Lua
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/scons:${PORTSDIR}/devel/scons
+LIB_DEPENDS= lua:${PORTSDIR}/lang/lua
+
+WRKSRC= ${WRKDIR}/tolua++-${PORTVERSION}
+USE_BZIP2= yes
+INSTALLS_SHLIB= yes
+NO_BUILD= yes
+
+do-build:
+ @cd ${WRKSRC} && scons
+
+do-install:
+ @cd ${WRKSRC} && scons prefix=${PREFIX} install
+
+.include <bsd.port.mk>