aboutsummaryrefslogtreecommitdiff
path: root/lang/tolua50/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-11-21 08:32:23 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-11-21 08:32:23 +0000
commitba0c53550f862ff7a69cbeb07c172123177dac16 (patch)
tree2da1bf28f0f4ea089a0ae22ccc6ce76e9b74a703 /lang/tolua50/Makefile
parent190ea87a7ef96d9fa104f482e77bf09cc4f590b6 (diff)
downloadports-ba0c53550f862ff7a69cbeb07c172123177dac16.tar.gz
ports-ba0c53550f862ff7a69cbeb07c172123177dac16.zip
Notes
Diffstat (limited to 'lang/tolua50/Makefile')
-rw-r--r--lang/tolua50/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/lang/tolua50/Makefile b/lang/tolua50/Makefile
new file mode 100644
index 000000000000..d71e9b2d129b
--- /dev/null
+++ b/lang/tolua50/Makefile
@@ -0,0 +1,29 @@
+#
+# New ports collection makefile for: tolua
+# Date created: 21 November 2004
+# Whom: Edwin Groothuis <edwin@mavetju.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tolua
+PORTVERSION= 5.0.1
+CATEGORIES= lang
+MASTER_SITES= ftp://ftp.tecgraf.puc-rio.br/pub/users/celes/tolua/ \
+ http://www.tecgraf.puc-rio.br/~celes/tolua/
+
+MAINTAINER= edwin@mavetju.org
+COMMENT= toLua: accessing C/C++ code from Lua
+
+LIB_DEPENDS= lua:${PORTSDIR}/lang/lua
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-5.0
+
+USE_GMAKE= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/tolua ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/include/tolua.h ${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/lib/libtolua.a ${PREFIX}/lib
+
+.include <bsd.port.mk>