aboutsummaryrefslogtreecommitdiff
path: root/lang/ucc
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-25 21:11:18 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-25 21:11:18 +0000
commit28206a6325559dc0d951deca9c6bff9754c8b8d5 (patch)
tree23e07849de65501545ff17fb422a4195e7e18ab6 /lang/ucc
parent9a384a01d7d8a7f4cbaf0fcfddb56a0703dd3e0e (diff)
downloadports-28206a6325559dc0d951deca9c6bff9754c8b8d5.tar.gz
ports-28206a6325559dc0d951deca9c6bff9754c8b8d5.zip
Notes
Diffstat (limited to 'lang/ucc')
-rw-r--r--lang/ucc/Makefile23
-rw-r--r--lang/ucc/distinfo3
-rw-r--r--lang/ucc/files/patch-Makefile36
-rw-r--r--lang/ucc/pkg-descr14
-rw-r--r--lang/ucc/pkg-plist9
5 files changed, 85 insertions, 0 deletions
diff --git a/lang/ucc/Makefile b/lang/ucc/Makefile
new file mode 100644
index 000000000000..559c27bdbb99
--- /dev/null
+++ b/lang/ucc/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: ucc
+# Date created: 15 August 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ucc
+PORTVERSION= 1.6.0
+CATEGORIES= lang
+MASTER_SITES= SF
+DISTNAME= ucc160
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= C Compiler Which Implements the ANSI C89 Standard
+
+USE_ZIP= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/lang/ucc/distinfo b/lang/ucc/distinfo
new file mode 100644
index 000000000000..75290ffdfc50
--- /dev/null
+++ b/lang/ucc/distinfo
@@ -0,0 +1,3 @@
+MD5 (ucc160.zip) = 463c2e656383fc10594494268a2735e7
+SHA256 (ucc160.zip) = 784a35c0d69355ea15db843d032ed2a1dba38f23fcd6a950199fcdb93789f25e
+SIZE (ucc160.zip) = 376942
diff --git a/lang/ucc/files/patch-Makefile b/lang/ucc/files/patch-Makefile
new file mode 100644
index 000000000000..72a652162997
--- /dev/null
+++ b/lang/ucc/files/patch-Makefile
@@ -0,0 +1,36 @@
+--- Makefile.orig 2008-05-14 11:13:02.000000000 +0800
++++ Makefile 2008-08-15 13:25:35.000000000 +0800
+@@ -1,21 +1,21 @@
+-UCCDIR = /usr/local/lib/ucc
+-export UCCDIR
++UCCDIR = /usr/local
++#export UCCDIR
+
+ all:
+- make -C driver
+- make -C ucl
++ gmake -C driver
++ gmake -C ucl
+
+ clean:
+- make -C driver clean
+- make -C ucl clean
++ gmake -C driver clean
++ gmake -C ucl clean
+
+ install:
+- mkdir -p $(UCCDIR)
+- cp driver/ucc $(UCCDIR)
+- cp ucl/ucl $(UCCDIR)
+- cp ucl/assert.o $(UCCDIR)
+- cp -r ucl/linux/include $(UCCDIR)
++ mkdir -p $(UCCDIR)/include/ucc
++ cp driver/ucc $(UCCDIR)/bin
++ cp ucl/ucl $(UCCDIR)/bin
++ cp ucl/assert.o $(UCCDIR)/lib
++ cp ucl/linux/include/* $(UCCDIR)/include/ucc/
+
+ test:
+- make -C ucl test
++ gmake -C ucl test
+
diff --git a/lang/ucc/pkg-descr b/lang/ucc/pkg-descr
new file mode 100644
index 000000000000..bd39907de88d
--- /dev/null
+++ b/lang/ucc/pkg-descr
@@ -0,0 +1,14 @@
+Ucc is a C compiler which implements the ANSI C89
+standard with a few extensions. Ucc is released
+under BSD license.
+
+Ucc is specificaly designed for personal research
+and assist the undergraduate or graduate in compiler
+learning. We hope that Ucc will be a seedbed for new
+ideas and world-class optimizing techniques.
+
+Ucc's design and development goals is clear code
+structure,upstanding extensibility,retargetable and
+excellent optimization.
+
+WWW: http://ucc.sf.net
diff --git a/lang/ucc/pkg-plist b/lang/ucc/pkg-plist
new file mode 100644
index 000000000000..c26fb31d5851
--- /dev/null
+++ b/lang/ucc/pkg-plist
@@ -0,0 +1,9 @@
+bin/ucc
+bin/ucl
+lib/assert.o
+include/ucc/assert.h
+include/ucc/float.h
+include/ucc/limits.h
+include/ucc/math.h
+include/ucc/stdarg.h
+@dirrm include/ucc