aboutsummaryrefslogtreecommitdiff
path: root/lang/urweb
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-07-08 22:47:13 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-07-08 22:47:13 +0000
commitc280f67cb691a3ff0c9df08517651e66b416d178 (patch)
treed612b44270c7d7da93f4e3e14250d4ee6437565f /lang/urweb
parent48622b58e5deffc28f4df4afa0ac292b4310ba97 (diff)
downloadports-c280f67cb691a3ff0c9df08517651e66b416d178.tar.gz
ports-c280f67cb691a3ff0c9df08517651e66b416d178.zip
Notes
Diffstat (limited to 'lang/urweb')
-rw-r--r--lang/urweb/Makefile14
-rw-r--r--lang/urweb/distinfo4
-rw-r--r--lang/urweb/files/patch-configure20
-rw-r--r--lang/urweb/pkg-plist4
4 files changed, 16 insertions, 26 deletions
diff --git a/lang/urweb/Makefile b/lang/urweb/Makefile
index e7c7b6f08a55..1138e04bcee3 100644
--- a/lang/urweb/Makefile
+++ b/lang/urweb/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= urweb
-PORTVERSION= 20120925
-PORTREVISION= 2
+PORTVERSION= 20140704
CATEGORIES= lang www
MASTER_SITES= http://www.impredicative.com/ur/
EXTRACT_SUFX= .tgz
@@ -26,12 +25,15 @@ ONLY_FOR_ARCHS= i386 amd64
CFLAGS+= -pthread
OPTIONS_DEFINE= ELISP PGSQL SQLITE MYSQL
-OPTIONS_DEFAULT=ELISP PGSQL
-OPTIONS_EXCLUDE=NLS DOCS
+OPTIONS_DEFAULT= ELISP PGSQL
+OPTIONS_EXCLUDE= NLS DOCS
ELISP_DESC= Install contributed Emacs Lisp
.include <bsd.port.options.mk>
+USE_OPENSSL= yes
+CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
+
.if ${PORT_OPTIONS:MELISP}
PLIST_SUB+= ELISP=""
CONFIGURE_ARGS+= with_emacs=yes
@@ -58,4 +60,8 @@ USE_MYSQL= yes
CONFIGURE_ENV+= MSHEADER="no"
.endif
+post-patch:
+ ${REINPLACE_CMD} -e "s|postgresql/libpq-fe.h|libpq-fe.h|g" \
+ ${WRKSRC}/configure
+
.include <bsd.port.mk>
diff --git a/lang/urweb/distinfo b/lang/urweb/distinfo
index 10067070723e..f62e7b9d94b4 100644
--- a/lang/urweb/distinfo
+++ b/lang/urweb/distinfo
@@ -1,2 +1,2 @@
-SHA256 (urweb-20120925.tgz) = d617edc89a16ab675a8ce13bd25aa19b71837d239b30987da447c126da0be663
-SIZE (urweb-20120925.tgz) = 826968
+SHA256 (urweb-20140704.tgz) = 77ae6b607c2a0fb83cd5f9f2752834d33dda89ca01f76bedb664b55adcd6392b
+SIZE (urweb-20140704.tgz) = 4256612
diff --git a/lang/urweb/files/patch-configure b/lang/urweb/files/patch-configure
deleted file mode 100644
index a029767ee940..000000000000
--- a/lang/urweb/files/patch-configure
+++ /dev/null
@@ -1,20 +0,0 @@
---- configure.orig 2012-09-25 05:16:58.000000000 -0700
-+++ configure 2013-02-16 19:55:33.000000000 -0800
-@@ -11744,14 +11744,14 @@
-
-
- if test -z $PGHEADER; then
-- for ac_header in postgresql/libpq-fe.h
-+ for ac_header in libpq-fe.h
- do :
-- ac_fn_c_check_header_mongrel "$LINENO" "postgresql/libpq-fe.h" "ac_cv_header_postgresql_libpq_fe_h" "$ac_includes_default"
-+ ac_fn_c_check_header_mongrel "$LINENO" "libpq-fe.h" "ac_cv_header_postgresql_libpq_fe_h" "$ac_includes_default"
- if test "x$ac_cv_header_postgresql_libpq_fe_h" = x""yes; then :
- cat >>confdefs.h <<_ACEOF
- #define HAVE_POSTGRESQL_LIBPQ_FE_H 1
- _ACEOF
-- PGHEADER=postgresql/libpq-fe.h
-+ PGHEADER=libpq-fe.h
- fi
-
- done
diff --git a/lang/urweb/pkg-plist b/lang/urweb/pkg-plist
index 41eb745eb826..3114cc546b45 100644
--- a/lang/urweb/pkg-plist
+++ b/lang/urweb/pkg-plist
@@ -3,7 +3,9 @@ include/urweb/config.h
include/urweb/queue.h
include/urweb/request.h
include/urweb/types.h
+include/urweb/types_cpp.h
include/urweb/urweb.h
+include/urweb/urweb_cpp.h
lib/liburweb.a
lib/liburweb.so
lib/liburweb.so.0
@@ -28,6 +30,8 @@ lib/urweb/js/urweb.js
lib/urweb/ur/basis.urs
lib/urweb/ur/char.ur
lib/urweb/ur/char.urs
+lib/urweb/ur/datetime.ur
+lib/urweb/ur/datetime.urs
lib/urweb/ur/list.ur
lib/urweb/ur/list.urs
lib/urweb/ur/listPair.ur