aboutsummaryrefslogtreecommitdiff
path: root/lang/v8-devel
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-03 12:45:27 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-03 12:45:27 +0000
commit59f65c82ef1fb9785e51d03810630a4002b88fa3 (patch)
treee887032a7873793c6df97212af60e11960f36b8e /lang/v8-devel
parent9f764c35ede22eb9e1b5b2d294ffc5d8360431b9 (diff)
downloadports-59f65c82ef1fb9785e51d03810630a4002b88fa3.tar.gz
ports-59f65c82ef1fb9785e51d03810630a4002b88fa3.zip
Notes
Diffstat (limited to 'lang/v8-devel')
-rw-r--r--lang/v8-devel/Makefile4
-rw-r--r--lang/v8-devel/distinfo4
-rw-r--r--lang/v8-devel/files/patch-lithium-codegen-ia32.h11
3 files changed, 4 insertions, 15 deletions
diff --git a/lang/v8-devel/Makefile b/lang/v8-devel/Makefile
index 7ebad47c3f40..09a8a1cb086b 100644
--- a/lang/v8-devel/Makefile
+++ b/lang/v8-devel/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= v8
-PORTVERSION= 3.24.30
-PORTREVISION= 1
+PORTVERSION= 3.27.7
+PORTREVISION= 0
CATEGORIES= lang
MASTER_SITES= LOCAL/vanilla
PKGNAMESUFFIX= -devel
diff --git a/lang/v8-devel/distinfo b/lang/v8-devel/distinfo
index 493cc156bc7c..0be92b2d2b99 100644
--- a/lang/v8-devel/distinfo
+++ b/lang/v8-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (v8-3.24.30.tar.xz) = 9178700254290e38eb7085e44d879ffbc7871dd1eeacebb7c08cb1c49924e22a
-SIZE (v8-3.24.30.tar.xz) = 34185612
+SHA256 (v8-3.27.7.tar.xz) = 1b93c506c27f934df092d4193a3caa5fc845141ea397bf0adbc6e6a81ba55db5
+SIZE (v8-3.27.7.tar.xz) = 34568660
diff --git a/lang/v8-devel/files/patch-lithium-codegen-ia32.h b/lang/v8-devel/files/patch-lithium-codegen-ia32.h
deleted file mode 100644
index 848718a8265b..000000000000
--- a/lang/v8-devel/files/patch-lithium-codegen-ia32.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/ia32/lithium-codegen-ia32.h.orig 2013-12-28 22:35:15.000000000 +0800
-+++ src/ia32/lithium-codegen-ia32.h 2013-12-28 22:35:41.000000000 +0800
-@@ -426,7 +426,7 @@ class LCodeGen: public LCodeGenBase {
- explicit X87Stack(MacroAssembler* masm)
- : stack_depth_(0), is_mutable_(true), masm_(masm) { }
- explicit X87Stack(const X87Stack& other)
-- : stack_depth_(other.stack_depth_), is_mutable_(false), masm_(masm()) {
-+ : stack_depth_(other.stack_depth_), is_mutable_(false), masm_(NULL) {
- for (int i = 0; i < stack_depth_; i++) {
- stack_[i] = other.stack_[i];
- }