aboutsummaryrefslogtreecommitdiff
path: root/lang/x10
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2011-12-26 19:15:23 +0000
committerPawel Pekala <pawel@FreeBSD.org>2011-12-26 19:15:23 +0000
commitf6ecfc9f1949429849937890e205a6924d1d4d7e (patch)
treedd1ccf5d11def0b3ee3a503b071645e966dd939e /lang/x10
parente8d67bc02f0c526a4bc486b99d2350b5f78b0d20 (diff)
downloadports-f6ecfc9f1949429849937890e205a6924d1d4d7e.tar.gz
ports-f6ecfc9f1949429849937890e205a6924d1d4d7e.zip
Notes
Diffstat (limited to 'lang/x10')
-rw-r--r--lang/x10/Makefile48
-rw-r--r--lang/x10/distinfo2
-rw-r--r--lang/x10/files/patch-x10.runtime-Make.rules15
-rw-r--r--lang/x10/pkg-descr6
-rw-r--r--lang/x10/pkg-plist519
5 files changed, 590 insertions, 0 deletions
diff --git a/lang/x10/Makefile b/lang/x10/Makefile
new file mode 100644
index 000000000000..1a91fa41692d
--- /dev/null
+++ b/lang/x10/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: x10
+# Date created: 2011-10-12
+# Whom: Jason Bacon <jwbacon@tds.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= x10
+PORTVERSION= 2.2.1
+CATEGORIES= lang devel java
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= jwbacon@tds.net
+COMMENT= Object-oriented parallal programming language
+
+USE_BZIP2= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+USE_ANT= yes
+
+USE_LDCONFIG= ${PREFIX}/stdlib/lib
+
+# Can't have USE_GMAKE with USE_ANT: They imply conflicting do-build actions.
+BUILD_DEPENDS+= gmake:${PORTSDIR}/devel/gmake \
+ bash:${PORTSDIR}/shells/bash
+
+WRKSRC= ${WRKDIR}/x10.dist
+
+post-patch:
+ ${REINPLACE_CMD} -e 's/value="make"/value="gmake"/g' \
+ ${WRKDIR}/x10.runtime/build.xml
+
+do-install:
+.for f in X10Launcher apgas precommit x10 x10c x10c++ x10j
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/${f} ${PREFIX}/bin
+.endfor
+ ${MKDIR} ${PREFIX}/stdlib
+ ${INSTALL_DATA} ${WRKSRC}/etc/* ${PREFIX}/etc
+ ${INSTALL_DATA} ${WRKSRC}/include/* ${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/lib/* ${PREFIX}/lib
+ ${CP} -R ${WRKSRC}/stdlib/* ${PREFIX}/stdlib
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/samples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/lang/x10/distinfo b/lang/x10/distinfo
new file mode 100644
index 000000000000..7dfff3c69bbf
--- /dev/null
+++ b/lang/x10/distinfo
@@ -0,0 +1,2 @@
+SHA256 (x10-2.2.1-src.tar.bz2) = 7d177e4e3d6a8ad5c76b87ec9a4c96346a758883b540e84645406612b1cdf41f
+SIZE (x10-2.2.1-src.tar.bz2) = 2075405
diff --git a/lang/x10/files/patch-x10.runtime-Make.rules b/lang/x10/files/patch-x10.runtime-Make.rules
new file mode 100644
index 000000000000..afabb17be5e8
--- /dev/null
+++ b/lang/x10/files/patch-x10.runtime-Make.rules
@@ -0,0 +1,15 @@
+--- ../x10.runtime/Make.rules.orig 2011-12-13 14:45:27.000000000 -0600
++++ ../x10.runtime/Make.rules 2011-09-06 10:09:42.000000000 -0500
+@@ -253,9 +253,9 @@
+ override CXXFLAGS += -pthread
+ override CXXFLAGS_SHARED += -shared -fPIC
+ export X10RT_TEST_LDFLAGS = -Wl,--rpath -Wl,"$(X10_HOME)"/x10.runtime/x10rt/lib
+- ifeq ($(shell uname -m),amd64)
+- export X10RT_PLATFORM=freebsd_amd64
+- endif
++ #ifeq ($(shell uname -m),amd64)
++ export X10RT_PLATFORM=freebsd_$(shell uname -m)
++ #endif
+ endif
+ endif
+ endif
diff --git a/lang/x10/pkg-descr b/lang/x10/pkg-descr
new file mode 100644
index 000000000000..50e50b11ad35
--- /dev/null
+++ b/lang/x10/pkg-descr
@@ -0,0 +1,6 @@
+IBM Research is developing the open-source X10 programming language to
+provide a programming model that can address the architectural challenge
+of multiples cores, hardware accelerators, clusters, and supercomputers
+in a manner that provides scalable performance in a productive manner.
+
+WWW: http://x10-lang.org
diff --git a/lang/x10/pkg-plist b/lang/x10/pkg-plist
new file mode 100644
index 000000000000..7d32b52668c1
--- /dev/null
+++ b/lang/x10/pkg-plist
@@ -0,0 +1,519 @@
+bin/X10Launcher
+bin/apgas
+bin/precommit
+bin/x10
+bin/x10c
+bin/x10c++
+bin/x10j
+etc/sharedlib.properties
+etc/x10rt_sockets.properties
+etc/x10rt_standalone.properties
+include/x10_x10rt_MessageHandlers.h
+include/x10_x10rt_TeamSupport.h
+include/x10_x10rt_X10RT.h
+include/x10rt_cpp.h
+include/x10rt_cuda.h
+include/x10rt_front.h
+include/x10rt_jni_helpers.h
+include/x10rt_logical.h
+include/x10rt_net.h
+include/x10rt_ser.h
+include/x10rt_types.h
+lib/com.ibm.wala.cast.java_1.0.0.201101071300.jar
+lib/com.ibm.wala.cast_1.0.0.201101071300.jar
+lib/com.ibm.wala.core_1.1.3.201101071300.jar
+lib/com.ibm.wala.shrike_1.3.1.201101071300.jar
+lib/commons-math-2.2.jar
+lib/ecj.jar
+lib/libx10rt_sockets.so
+lib/libx10rt_standalone.so
+lib/lpg.jar
+lib/org.eclipse.equinox.common_3.6.0.v20100503.jar
+lib/x10c.jar
+lib/x10doc.jar
+lib/x10wala.jar
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ArraySum.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/CUDA/CUDA3DFD.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/CUDA/CUDABlackScholes.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/CUDA/CUDAKernelTest.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/CUDA/CUDAMatMul.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/CUDA/CUDATopology.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/CUDA/KMeansCUDA.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/FRASimpleDist.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/FSSimpleDist.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/GCSpheres.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/HelloWholeWorld.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/HelloWorld.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Histogram.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/KMeans.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/KMeansDist.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/KMeansSPMD.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/MontyPi.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/NQueensDist.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/NQueensPar.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/StructSpheres.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/points.dat
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tutorial/Fibonacci.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tutorial/HeatTransfer_v0.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tutorial/HeatTransfer_v1.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tutorial/HeatTransfer_v2.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tutorial/HeatTransfer_v3.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tutorial/HeatTransfer_v4.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tutorial/HeatTransfer_v5.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tutorial/IntegrateTutorial.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tutorial/QSort.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/work-stealing/Fib.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/work-stealing/FibSeq.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/work-stealing/Integrate.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/work-stealing/IntegrateSeq.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/work-stealing/QuickSort.x10
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/work-stealing/QuickSortSeq.x10
+stdlib/include/gc.h
+stdlib/include/gc/gc.h
+stdlib/include/gc/gc_allocator.h
+stdlib/include/gc/gc_amiga_redirects.h
+stdlib/include/gc/gc_backptr.h
+stdlib/include/gc/gc_config_macros.h
+stdlib/include/gc/gc_cpp.h
+stdlib/include/gc/gc_gcj.h
+stdlib/include/gc/gc_inline.h
+stdlib/include/gc/gc_mark.h
+stdlib/include/gc/gc_pthread_redirects.h
+stdlib/include/gc/gc_tiny_fl.h
+stdlib/include/gc/gc_typed.h
+stdlib/include/gc/gc_version.h
+stdlib/include/gc/leak_detector.h
+stdlib/include/gc/new_gc_alloc.h
+stdlib/include/gc/weakpointer.h
+stdlib/include/gc_cpp.h
+stdlib/include/x10/array/Array.h
+stdlib/include/x10/array/Array__Anonymous__13465.h
+stdlib/include/x10/array/Array__Anonymous__13465__Anonymous__13522.h
+stdlib/include/x10/array/Array__Anonymous__13753.h
+stdlib/include/x10/array/Array__Anonymous__13753__Anonymous__13810.h
+stdlib/include/x10/array/Array__Anonymous__14087.h
+stdlib/include/x10/array/BlockBlockDist.h
+stdlib/include/x10/array/BlockDist.h
+stdlib/include/x10/array/ConstantDist.h
+stdlib/include/x10/array/Dist.h
+stdlib/include/x10/array/DistArray.h
+stdlib/include/x10/array/DistArray__Anonymous__27239.h
+stdlib/include/x10/array/DistArray__LocalState.h
+stdlib/include/x10/array/EmptyRegion.h
+stdlib/include/x10/array/EmptyRegion__ERIterator.h
+stdlib/include/x10/array/FullRegion.h
+stdlib/include/x10/array/Mat.h
+stdlib/include/x10/array/MatBuilder.h
+stdlib/include/x10/array/PeriodicDist.h
+stdlib/include/x10/array/PlaceGroup.h
+stdlib/include/x10/array/PlaceGroup__WorldPlaceGroup.h
+stdlib/include/x10/array/Point.h
+stdlib/include/x10/array/PolyMat.h
+stdlib/include/x10/array/PolyMatBuilder.h
+stdlib/include/x10/array/PolyRegion.h
+stdlib/include/x10/array/PolyRow.h
+stdlib/include/x10/array/PolyScanner.h
+stdlib/include/x10/array/PolyScanner__Anonymous__9371.h
+stdlib/include/x10/array/PolyScanner__RailIt.h
+stdlib/include/x10/array/RectLayout.h
+stdlib/include/x10/array/RectRegion.h
+stdlib/include/x10/array/RectRegion1D.h
+stdlib/include/x10/array/RectRegion1D__RRIterator.h
+stdlib/include/x10/array/RectRegion__RRIterator.h
+stdlib/include/x10/array/Region.h
+stdlib/include/x10/array/RemoteArray.h
+stdlib/include/x10/array/Row.h
+stdlib/include/x10/array/SparsePlaceGroup.h
+stdlib/include/x10/array/UnboundedRegionException.h
+stdlib/include/x10/array/UniqueDist.h
+stdlib/include/x10/array/ValRow.h
+stdlib/include/x10/array/VarMat.h
+stdlib/include/x10/array/VarRow.h
+stdlib/include/x10/array/WrappedDistPlaceRestricted.h
+stdlib/include/x10/array/WrappedDistRegionRestricted.h
+stdlib/include/x10/compiler/Abort.h
+stdlib/include/x10/compiler/AsyncClosure.h
+stdlib/include/x10/compiler/ByRef.h
+stdlib/include/x10/compiler/CUDA.h
+stdlib/include/x10/compiler/CUDADirectParams.h
+stdlib/include/x10/compiler/CompileTimeConstant.h
+stdlib/include/x10/compiler/CompilerFlags.h
+stdlib/include/x10/compiler/Det.h
+stdlib/include/x10/compiler/Embed.h
+stdlib/include/x10/compiler/Endpoint.h
+stdlib/include/x10/compiler/Ephemeral.h
+stdlib/include/x10/compiler/Finalization.h
+stdlib/include/x10/compiler/FinishAsync.h
+stdlib/include/x10/compiler/Global.h
+stdlib/include/x10/compiler/Header.h
+stdlib/include/x10/compiler/Ifdef.h
+stdlib/include/x10/compiler/Ifndef.h
+stdlib/include/x10/compiler/Immediate.h
+stdlib/include/x10/compiler/Impure.h
+stdlib/include/x10/compiler/Incomplete.h
+stdlib/include/x10/compiler/InitDispatcher.h
+stdlib/include/x10/compiler/Inline.h
+stdlib/include/x10/compiler/InlineOnly.h
+stdlib/include/x10/compiler/LocalVar.h
+stdlib/include/x10/compiler/Mutable.h
+stdlib/include/x10/compiler/Native.h
+stdlib/include/x10/compiler/NativeCPPCompilationUnit.h
+stdlib/include/x10/compiler/NativeCPPExtern.h
+stdlib/include/x10/compiler/NativeCPPInclude.h
+stdlib/include/x10/compiler/NativeCPPOutputFile.h
+stdlib/include/x10/compiler/NativeClass.h
+stdlib/include/x10/compiler/NativeDef.h
+stdlib/include/x10/compiler/NativeRep.h
+stdlib/include/x10/compiler/NativeString.h
+stdlib/include/x10/compiler/NoInferType.h
+stdlib/include/x10/compiler/NoInline.h
+stdlib/include/x10/compiler/NoReturn.h
+stdlib/include/x10/compiler/NoSuperCall.h
+stdlib/include/x10/compiler/NoThisAccess.h
+stdlib/include/x10/compiler/NonEscaping.h
+stdlib/include/x10/compiler/PerProcess.h
+stdlib/include/x10/compiler/Pinned.h
+stdlib/include/x10/compiler/PlaceLocalHandle.h
+stdlib/include/x10/compiler/Pragma.h
+stdlib/include/x10/compiler/Pure.h
+stdlib/include/x10/compiler/Ref.h
+stdlib/include/x10/compiler/RemoteInvocation.h
+stdlib/include/x10/compiler/SetOps.h
+stdlib/include/x10/compiler/StackAllocate.h
+stdlib/include/x10/compiler/SuppressTransientError.h
+stdlib/include/x10/compiler/Uncounted.h
+stdlib/include/x10/compiler/Uninitialized.h
+stdlib/include/x10/compiler/Unroll.h
+stdlib/include/x10/compiler/Volatile.h
+stdlib/include/x10/compiler/WS.h
+stdlib/include/x10/compiler/X10JavaSerializable.h
+stdlib/include/x10/compiler/tests/ERR.h
+stdlib/include/x10/compiler/tests/ShouldBeErr.h
+stdlib/include/x10/compiler/tests/ShouldNotBeERR.h
+stdlib/include/x10/compiler/ws/AsyncFrame.h
+stdlib/include/x10/compiler/ws/AtFrame.h
+stdlib/include/x10/compiler/ws/CollectingFinish.h
+stdlib/include/x10/compiler/ws/FinishFrame.h
+stdlib/include/x10/compiler/ws/Frame.h
+stdlib/include/x10/compiler/ws/MainFrame.h
+stdlib/include/x10/compiler/ws/RegularFrame.h
+stdlib/include/x10/compiler/ws/RemoteFinish.h
+stdlib/include/x10/compiler/ws/RootFinish.h
+stdlib/include/x10/compiler/ws/ThrowFrame.h
+stdlib/include/x10/compiler/ws/TryFrame.h
+stdlib/include/x10/compiler/ws/Worker.h
+stdlib/include/x10/io/Console.h
+stdlib/include/x10/io/CustomSerialization.h
+stdlib/include/x10/io/EOFException.h
+stdlib/include/x10/io/File.h
+stdlib/include/x10/io/FileNotFoundException.h
+stdlib/include/x10/io/FileReader.h
+stdlib/include/x10/io/FileReader__FileInputStream.h
+stdlib/include/x10/io/FileSystem.h
+stdlib/include/x10/io/FileWriter.h
+stdlib/include/x10/io/FileWriter__FileOutputStream.h
+stdlib/include/x10/io/File__NativeFile.h
+stdlib/include/x10/io/FilterReader.h
+stdlib/include/x10/io/FilterWriter.h
+stdlib/include/x10/io/IOException.h
+stdlib/include/x10/io/InputStreamReader.h
+stdlib/include/x10/io/InputStreamReader__InputStream.h
+stdlib/include/x10/io/Marshal.h
+stdlib/include/x10/io/Marshal__BooleanMarshal.h
+stdlib/include/x10/io/Marshal__ByteMarshal.h
+stdlib/include/x10/io/Marshal__CharMarshal.h
+stdlib/include/x10/io/Marshal__DoubleMarshal.h
+stdlib/include/x10/io/Marshal__FloatMarshal.h
+stdlib/include/x10/io/Marshal__IntMarshal.h
+stdlib/include/x10/io/Marshal__LineMarshal.h
+stdlib/include/x10/io/Marshal__LongMarshal.h
+stdlib/include/x10/io/Marshal__ShortMarshal.h
+stdlib/include/x10/io/Marshal__UByteMarshal.h
+stdlib/include/x10/io/Marshal__UIntMarshal.h
+stdlib/include/x10/io/Marshal__ULongMarshal.h
+stdlib/include/x10/io/Marshal__UShortMarshal.h
+stdlib/include/x10/io/NotSerializableException.h
+stdlib/include/x10/io/OutputStreamWriter.h
+stdlib/include/x10/io/OutputStreamWriter__OutputStream.h
+stdlib/include/x10/io/Printer.h
+stdlib/include/x10/io/PutbackReader.h
+stdlib/include/x10/io/Readable.h
+stdlib/include/x10/io/Reader.h
+stdlib/include/x10/io/ReaderIterator.h
+stdlib/include/x10/io/SerialData.h
+stdlib/include/x10/io/StringWriter.h
+stdlib/include/x10/io/Writable.h
+stdlib/include/x10/io/Writer.h
+stdlib/include/x10/lang/Acc.h
+stdlib/include/x10/lang/Accumulator.h
+stdlib/include/x10/lang/Activity.h
+stdlib/include/x10/lang/Activity__ClockPhases.h
+stdlib/include/x10/lang/Any.h
+stdlib/include/x10/lang/Arithmetic.h
+stdlib/include/x10/lang/ArithmeticException.h
+stdlib/include/x10/lang/ArrayIndexOutOfBoundsException.h
+stdlib/include/x10/lang/AssertionError.h
+stdlib/include/x10/lang/BadPlaceException.h
+stdlib/include/x10/lang/Bitwise.h
+stdlib/include/x10/lang/Boolean.h
+stdlib/include/x10/lang/Byte.h
+stdlib/include/x10/lang/Cell.h
+stdlib/include/x10/lang/Char.h
+stdlib/include/x10/lang/ClassCastException.h
+stdlib/include/x10/lang/Clock.h
+stdlib/include/x10/lang/ClockUseException.h
+stdlib/include/x10/lang/Closure.h
+stdlib/include/x10/lang/Comparable.h
+stdlib/include/x10/lang/Complex.h
+stdlib/include/x10/lang/Debug.h
+stdlib/include/x10/lang/Deque.h
+stdlib/include/x10/lang/Double.h
+stdlib/include/x10/lang/Error.h
+stdlib/include/x10/lang/Exception.h
+stdlib/include/x10/lang/FailedDynamicCheckException.h
+stdlib/include/x10/lang/FinishAccumulator.h
+stdlib/include/x10/lang/FinishState.h
+stdlib/include/x10/lang/FinishState__CollectingFinish.h
+stdlib/include/x10/lang/FinishState__CollectingFinishState.h
+stdlib/include/x10/lang/FinishState__Finish.h
+stdlib/include/x10/lang/FinishState__FinishAsync.h
+stdlib/include/x10/lang/FinishState__FinishHere.h
+stdlib/include/x10/lang/FinishState__FinishSPMD.h
+stdlib/include/x10/lang/FinishState__FinishSkeleton.h
+stdlib/include/x10/lang/FinishState__FinishStates.h
+stdlib/include/x10/lang/FinishState__LocalFinish.h
+stdlib/include/x10/lang/FinishState__RemoteCollectingFinish.h
+stdlib/include/x10/lang/FinishState__RemoteFinish.h
+stdlib/include/x10/lang/FinishState__RemoteFinishAsync.h
+stdlib/include/x10/lang/FinishState__RemoteFinishSPMD.h
+stdlib/include/x10/lang/FinishState__RemoteFinishSkeleton.h
+stdlib/include/x10/lang/FinishState__RootCollectingFinish.h
+stdlib/include/x10/lang/FinishState__RootFinish.h
+stdlib/include/x10/lang/FinishState__RootFinishAsync.h
+stdlib/include/x10/lang/FinishState__RootFinishSPMD.h
+stdlib/include/x10/lang/FinishState__RootFinishSkeleton.h
+stdlib/include/x10/lang/FinishState__StatefulReducer.h
+stdlib/include/x10/lang/FinishState__UncountedFinish.h
+stdlib/include/x10/lang/Float.h
+stdlib/include/x10/lang/Fun_0_0.h
+stdlib/include/x10/lang/Fun_0_1.h
+stdlib/include/x10/lang/Fun_0_2.h
+stdlib/include/x10/lang/Fun_0_3.h
+stdlib/include/x10/lang/Fun_0_4.h
+stdlib/include/x10/lang/Fun_0_5.h
+stdlib/include/x10/lang/Fun_0_6.h
+stdlib/include/x10/lang/Fun_0_7.h
+stdlib/include/x10/lang/Fun_0_8.h
+stdlib/include/x10/lang/Fun_0_9.h
+stdlib/include/x10/lang/GlobalCell.h
+stdlib/include/x10/lang/GlobalRef.h
+stdlib/include/x10/lang/GlobalRef__LocalEval.h
+stdlib/include/x10/lang/IBox.h
+stdlib/include/x10/lang/IllegalAccAccess.h
+stdlib/include/x10/lang/IllegalArgumentException.h
+stdlib/include/x10/lang/IllegalMonitorStateException.h
+stdlib/include/x10/lang/IllegalOperationException.h
+stdlib/include/x10/lang/IllegalThreadStateException.h
+stdlib/include/x10/lang/Indexable.h
+stdlib/include/x10/lang/Int.h
+stdlib/include/x10/lang/IntRange.h
+stdlib/include/x10/lang/IntRange__IntRangeIt.h
+stdlib/include/x10/lang/InterruptedException.h
+stdlib/include/x10/lang/Iterable.h
+stdlib/include/x10/lang/Iterator.h
+stdlib/include/x10/lang/Lock__ReentrantLock.h
+stdlib/include/x10/lang/Long.h
+stdlib/include/x10/lang/LongRange.h
+stdlib/include/x10/lang/LongRange__LongRangeIt.h
+stdlib/include/x10/lang/Math.h
+stdlib/include/x10/lang/MultipleExceptions.h
+stdlib/include/x10/lang/NullPointerException.h
+stdlib/include/x10/lang/NumberFormatException.h
+stdlib/include/x10/lang/Object.h
+stdlib/include/x10/lang/OutOfMemoryError.h
+stdlib/include/x10/lang/Place.h
+stdlib/include/x10/lang/PlaceLocalHandle.h
+stdlib/include/x10/lang/PlaceLocalHandle_Impl.h
+stdlib/include/x10/lang/Reducible.h
+stdlib/include/x10/lang/Reference.h
+stdlib/include/x10/lang/Runtime.h
+stdlib/include/x10/lang/RuntimeException.h
+stdlib/include/x10/lang/Runtime__Mortal.h
+stdlib/include/x10/lang/Runtime__Pool.h
+stdlib/include/x10/lang/Runtime__Remote.h
+stdlib/include/x10/lang/Runtime__RemoteControl.h
+stdlib/include/x10/lang/Runtime__Semaphore.h
+stdlib/include/x10/lang/Runtime__Worker.h
+stdlib/include/x10/lang/Runtime__X10RTMessageStats.h
+stdlib/include/x10/lang/Runtime__X10RTStats.h
+stdlib/include/x10/lang/Sequence.h
+stdlib/include/x10/lang/Settable.h
+stdlib/include/x10/lang/Short.h
+stdlib/include/x10/lang/StackOverflowError.h
+stdlib/include/x10/lang/String.h
+stdlib/include/x10/lang/StringHelper.h
+stdlib/include/x10/lang/StringIndexOutOfBoundsException.h
+stdlib/include/x10/lang/System.h
+stdlib/include/x10/lang/Thread.h
+stdlib/include/x10/lang/Throwable.h
+stdlib/include/x10/lang/UByte.h
+stdlib/include/x10/lang/UInt.h
+stdlib/include/x10/lang/ULong.h
+stdlib/include/x10/lang/UShort.h
+stdlib/include/x10/lang/UnsupportedOperationException.h
+stdlib/include/x10/lang/VoidFun_0_0.h
+stdlib/include/x10/lang/VoidFun_0_1.h
+stdlib/include/x10/lang/VoidFun_0_2.h
+stdlib/include/x10/lang/VoidFun_0_3.h
+stdlib/include/x10/lang/VoidFun_0_4.h
+stdlib/include/x10/lang/VoidFun_0_5.h
+stdlib/include/x10/lang/VoidFun_0_6.h
+stdlib/include/x10/lang/VoidFun_0_7.h
+stdlib/include/x10/lang/VoidFun_0_8.h
+stdlib/include/x10/lang/VoidFun_0_9.h
+stdlib/include/x10/lang/Zero.h
+stdlib/include/x10/lang/_.h
+stdlib/include/x10/lang/annotations/Annotation.h
+stdlib/include/x10/lang/annotations/ClassAnnotation.h
+stdlib/include/x10/lang/annotations/ExpressionAnnotation.h
+stdlib/include/x10/lang/annotations/FieldAnnotation.h
+stdlib/include/x10/lang/annotations/ImportAnnotation.h
+stdlib/include/x10/lang/annotations/MethodAnnotation.h
+stdlib/include/x10/lang/annotations/PackageAnnotation.h
+stdlib/include/x10/lang/annotations/StatementAnnotation.h
+stdlib/include/x10/lang/annotations/TypeAnnotation.h
+stdlib/include/x10/util/AbstractCollection.h
+stdlib/include/x10/util/AbstractContainer.h
+stdlib/include/x10/util/ArrayBuilder.h
+stdlib/include/x10/util/ArrayList.h
+stdlib/include/x10/util/ArrayList__It.h
+stdlib/include/x10/util/Box.h
+stdlib/include/x10/util/Builder.h
+stdlib/include/x10/util/CUDAUtilities.h
+stdlib/include/x10/util/Collection.h
+stdlib/include/x10/util/CollectionIterator.h
+stdlib/include/x10/util/Container.h
+stdlib/include/x10/util/GrowableIndexedMemoryChunk.h
+stdlib/include/x10/util/HashMap.h
+stdlib/include/x10/util/HashMap__EntriesIterator.h
+stdlib/include/x10/util/HashMap__EntrySet.h
+stdlib/include/x10/util/HashMap__HashEntry.h
+stdlib/include/x10/util/HashMap__KeySet.h
+stdlib/include/x10/util/HashMap__State.h
+stdlib/include/x10/util/HashSet.h
+stdlib/include/x10/util/Indexed.h
+stdlib/include/x10/util/IndexedMemoryChunk.h
+stdlib/include/x10/util/List.h
+stdlib/include/x10/util/ListIterator.h
+stdlib/include/x10/util/Map.h
+stdlib/include/x10/util/MapIterator.h
+stdlib/include/x10/util/MapSet.h
+stdlib/include/x10/util/Map__Entry.h
+stdlib/include/x10/util/NoSuchElementException.h
+stdlib/include/x10/util/Option.h
+stdlib/include/x10/util/OptionsParser.h
+stdlib/include/x10/util/OptionsParser__Err.h
+stdlib/include/x10/util/Ordered.h
+stdlib/include/x10/util/Pair.h
+stdlib/include/x10/util/Random.h
+stdlib/include/x10/util/RemoteIndexedMemoryChunk.h
+stdlib/include/x10/util/Set.h
+stdlib/include/x10/util/Stack.h
+stdlib/include/x10/util/StringBuilder.h
+stdlib/include/x10/util/Team.h
+stdlib/include/x10/util/Team__DoubleIdx.h
+stdlib/include/x10/util/Timer.h
+stdlib/include/x10/util/Vec.h
+stdlib/include/x10/util/WorkerLocalHandle.h
+stdlib/include/x10/util/WorkerLocalStorage.h
+stdlib/include/x10/util/concurrent/AtomicBoolean.h
+stdlib/include/x10/util/concurrent/AtomicDouble.h
+stdlib/include/x10/util/concurrent/AtomicFloat.h
+stdlib/include/x10/util/concurrent/AtomicInteger.h
+stdlib/include/x10/util/concurrent/AtomicLong.h
+stdlib/include/x10/util/concurrent/AtomicReference.h
+stdlib/include/x10/util/concurrent/Fences.h
+stdlib/include/x10/util/concurrent/Future.h
+stdlib/include/x10/util/concurrent/IntLatch.h
+stdlib/include/x10/util/concurrent/Latch.h
+stdlib/include/x10/util/concurrent/Lock.h
+stdlib/include/x10/util/concurrent/Monitor.h
+stdlib/include/x10/util/concurrent/SPMDBarrier.h
+stdlib/include/x10/util/concurrent/SimpleIntLatch.h
+stdlib/include/x10/util/concurrent/SimpleLatch.h
+stdlib/include/x10aux/RTT.h
+stdlib/include/x10aux/alloc.h
+stdlib/include/x10aux/array_utils.h
+stdlib/include/x10aux/assert.h
+stdlib/include/x10aux/atomic_boolean_funs.h
+stdlib/include/x10aux/atomic_int_funs.h
+stdlib/include/x10aux/atomic_long_funs.h
+stdlib/include/x10aux/atomic_ops.h
+stdlib/include/x10aux/basic_functions.h
+stdlib/include/x10aux/boolean_utils.h
+stdlib/include/x10aux/bootstrap.h
+stdlib/include/x10aux/byte_utils.h
+stdlib/include/x10aux/captured_lval.h
+stdlib/include/x10aux/char_utils.h
+stdlib/include/x10aux/class_cast.h
+stdlib/include/x10aux/config.h
+stdlib/include/x10aux/cuda_kernel.cuh
+stdlib/include/x10aux/cuda_kernel.h
+stdlib/include/x10aux/debug.h
+stdlib/include/x10aux/deserialization_dispatcher.h
+stdlib/include/x10aux/double_utils.h
+stdlib/include/x10aux/float_utils.h
+stdlib/include/x10aux/fun_utils.h
+stdlib/include/x10aux/hash.h
+stdlib/include/x10aux/init_dispatcher.h
+stdlib/include/x10aux/int_utils.h
+stdlib/include/x10aux/io/FILEPtrInputStream.h
+stdlib/include/x10aux/io/FILEPtrOutputStream.h
+stdlib/include/x10aux/io/FILEPtrStream.h
+stdlib/include/x10aux/itables.h
+stdlib/include/x10aux/lock.h
+stdlib/include/x10aux/long_utils.h
+stdlib/include/x10aux/math.h
+stdlib/include/x10aux/math_utils.h
+stdlib/include/x10aux/network.h
+stdlib/include/x10aux/place_local.h
+stdlib/include/x10aux/pragmas.h
+stdlib/include/x10aux/ref.h
+stdlib/include/x10aux/reference_logger.h
+stdlib/include/x10aux/serialization.h
+stdlib/include/x10aux/short_utils.h
+stdlib/include/x10aux/static_init.h
+stdlib/include/x10aux/string_utils.h
+stdlib/include/x10aux/system_utils.h
+stdlib/include/x10aux/throw.h
+stdlib/include/x10aux/vec_decl.h
+stdlib/include/x10rt.h
+stdlib/lib/libgc.a
+stdlib/lib/libgc.so
+stdlib/lib/libgc.so.1
+stdlib/lib/libx10.so
+stdlib/libx10.properties
+stdlib/x10.jar
+@dirrm stdlib/lib
+@dirrm stdlib/include/x10aux/io
+@dirrm stdlib/include/x10aux
+@dirrm stdlib/include/x10/util/concurrent
+@dirrm stdlib/include/x10/util
+@dirrm stdlib/include/x10/lang/annotations
+@dirrm stdlib/include/x10/lang
+@dirrm stdlib/include/x10/io
+@dirrm stdlib/include/x10/compiler/ws
+@dirrm stdlib/include/x10/compiler/tests
+@dirrm stdlib/include/x10/compiler
+@dirrm stdlib/include/x10/array
+@dirrm stdlib/include/x10
+@dirrm stdlib/include/gc
+@dirrm stdlib/include
+@dirrm stdlib
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/work-stealing
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/tutorial
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/guide
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/CUDA
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%@exec mkdir -p %D/%%EXAMPLESDIR%%/guide