aboutsummaryrefslogtreecommitdiff
path: root/lang/xotcl/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-11-27 02:30:32 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-11-27 02:30:32 +0000
commitf18ce877019d0e652e034e10696d971c70cc0c00 (patch)
tree69d568a5625ff09ee18ea72d6e0ac6a0b4f802b8 /lang/xotcl/Makefile
parentfc2938152324d264a4c8c1ffeeea7ff35c5a5396 (diff)
Notes
Diffstat (limited to 'lang/xotcl/Makefile')
-rw-r--r--lang/xotcl/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/lang/xotcl/Makefile b/lang/xotcl/Makefile
index 7d954feec393..1a7cedda75d1 100644
--- a/lang/xotcl/Makefile
+++ b/lang/xotcl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xotcl
-PORTVERSION= 1.5.2
+PORTVERSION= 1.5.3
CATEGORIES= lang tcl83 tcl84
MASTER_SITES= http://media.wu-wien.ac.at/download/
@@ -23,6 +23,7 @@ USE_GMAKE= yes
PLIST_SUB+= PORTVERSION=${PORTVERSION}
OPTIONS= AOLSERVER "AOL server module" off \
+ THREADS "Force threaded build" off \
TUTORIAL "Install XOTcl tutorial" off
CONFIGURE_ARGS+= --exec-prefix=${PREFIX} \
@@ -48,6 +49,14 @@ PLIST_SUB+= TUTORIAL=""
PLIST_SUB+= TUTORIAL="@comment "
.endif
+.if defined(WITH_THREADS)
+TCL_THREADED!= ${ECHO_EMD} 'puts [array names tcl_platform -exact threaded]' | ${TCLSH}
+.if empty(TCL_THREADED)
+IGNORE= WITH_THREADS option is selected. You need Tcl with threads to use this port. Please install Tcl with WITH_THREADS defined or from lang/tcl84-thread port and try again.
+.endif
+CONFIGURE_ARGS+= --enable-threads
+.endif
+
INSTALL_TARGET+= install-shells
.if !defined(NO_INSTALL_MANPAGES)
MAN1= xotclsh.1