aboutsummaryrefslogtreecommitdiff
path: root/lang/xotcl
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-05-13 09:14:15 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-05-13 09:14:15 +0000
commit3001b6a84b561272d529e67209dcd77671d0ad93 (patch)
tree79ee4b13121ca69939f2ce106017a619d1582113 /lang/xotcl
parent4f1765631a478f325d3dd071ab6c6cd44eb71093 (diff)
downloadports-3001b6a84b561272d529e67209dcd77671d0ad93.tar.gz
ports-3001b6a84b561272d529e67209dcd77671d0ad93.zip
Notes
Diffstat (limited to 'lang/xotcl')
-rw-r--r--lang/xotcl/Makefile9
-rw-r--r--lang/xotcl/distinfo4
-rw-r--r--lang/xotcl/files/patch-Makefile.in29
-rw-r--r--lang/xotcl/files/patch-configure12
4 files changed, 30 insertions, 24 deletions
diff --git a/lang/xotcl/Makefile b/lang/xotcl/Makefile
index 6c739569e1f9..4e6e16964c10 100644
--- a/lang/xotcl/Makefile
+++ b/lang/xotcl/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: xotcl
-# Date created: Mon Sep 25 15:31:00 CET 2006
-# Whom: Martin Matuska <mm@FreeBSD.org>
-#
+# Created by: Martin Matuska <mm@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= xotcl
-PORTVERSION= 1.6.6
-PORTREVISION= 1
+PORTVERSION= 1.6.7
CATEGORIES?= lang tcl
MASTER_SITES= SF \
http://media.wu-wien.ac.at/download/
diff --git a/lang/xotcl/distinfo b/lang/xotcl/distinfo
index 2f492920cdf0..5f562384c1ca 100644
--- a/lang/xotcl/distinfo
+++ b/lang/xotcl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xotcl-1.6.6.tar.gz) = 40f0eb7068aca0fe344b284019e0570eed928654b95b696805b3796be495c040
-SIZE (xotcl-1.6.6.tar.gz) = 1923067
+SHA256 (xotcl-1.6.7.tar.gz) = b2b09acd61bc2c76703f8d0de504d578862f24ccfea2f21c3140c62fd8378618
+SIZE (xotcl-1.6.7.tar.gz) = 1506814
diff --git a/lang/xotcl/files/patch-Makefile.in b/lang/xotcl/files/patch-Makefile.in
index c049e931ca36..493bf72370cc 100644
--- a/lang/xotcl/files/patch-Makefile.in
+++ b/lang/xotcl/files/patch-Makefile.in
@@ -1,6 +1,14 @@
---- Makefile.in.orig 2009-03-04 16:11:13.000000000 +0100
-+++ Makefile.in 2010-05-11 10:36:59.435600858 +0200
-@@ -264,11 +264,11 @@
+--- Makefile.in.orig 2011-11-01 13:24:01.000000000 +0100
++++ Makefile.in 2013-05-13 11:07:34.000000000 +0200
+@@ -30,6 +30,7 @@
+ src_generic_dir = ${srcdir}/generic
+ src_man_dir = ${srcdir}/man
+ TCL_LIB_SPEC = @TCL_LIB_SPEC@
++TCL_STUB_LIB_SPEC = @TCL_STUB_LIB_SPEC@
+ TK_LIB_SPEC = @TK_LIB_SPEC@
+ subdirs = @subdirs@
+ aol_prefix = @aol_prefix@
+@@ -264,11 +265,11 @@
#========================================================================
# This rule installs platform-independent files, such as header files.
#========================================================================
@@ -15,7 +23,7 @@
done;
@echo "Installing Libraries to $(DESTDIR)$(pkglibdir)/"
@for i in $(libdirs) ; do \
-@@ -286,7 +286,7 @@
+@@ -286,7 +287,7 @@
$(INSTALL_DATA) $(src_lib_dir)/$$i $(DESTDIR)$(pkglibdir)/$$i ; \
done;
cat unix/pkgIndex.unix >> $(DESTDIR)$(pkglibdir)/pkgIndex.tcl
@@ -24,25 +32,28 @@
@echo "Installing Applications to $(DESTDIR)$(pkglibdir)/apps/"
@for i in $(appdirs) ; do \
echo " Installing $$i/" ; \
-@@ -430,13 +430,15 @@
+@@ -429,14 +430,16 @@
+ xotclsh: tclAppInit.o $(PKG_OBJECTS) $(CONDITIONAL_STUB_OBJECTS)
$(CC) -rdynamic -o $@ tclAppInit.o \
$(PKG_OBJECTS) \
- $(CFLAGS) $(TCL_LIB_SPEC) \
+- $(CFLAGS) $(TCL_LIB_SPEC) \
- $(DMALLOC_LIB) $(CONDITIONAL_STUB_OBJECTS)
++ $(CFLAGS) $(TCL_STUB_LIB_SPEC) $(TCL_LIB_SPEC) \
+ $(DMALLOC_LIB) $(CONDITIONAL_STUB_OBJECTS) \
+ $(LDFLAGS_DEFAULT)
xowish: tkAppInit.o $(PKG_OBJECTS) $(CONDITIONAL_STUB_OBJECTS)
$(CC) -rdynamic -o $@ tkAppInit.o \
$(PKG_OBJECTS) \
- $(CFLAGS) $(TCL_LIB_SPEC) $(TK_LIB_SPEC) \
+- $(CFLAGS) $(TCL_LIB_SPEC) $(TK_LIB_SPEC) \
- $(DMALLOC_LIB) $(CONDITIONAL_STUB_OBJECTS)
++ $(CFLAGS) $(TCL_STUB_LIB_SPEC) $(TCL_LIB_SPEC) $(TK_LIB_SPEC) \
+ $(DMALLOC_LIB) $(CONDITIONAL_STUB_OBJECTS) \
+ $(LDFLAGS_DEFAULT)
install-shells:
@if test -f xotclsh; then \
-@@ -550,7 +552,6 @@
+@@ -550,7 +553,6 @@
else \
echo " $(RANLIB) $(DESTDIR)$(pkglibdir)/$$p"; \
$(RANLIB) $(DESTDIR)$(pkglibdir)/$$p; \
@@ -50,7 +61,7 @@
fi; \
ext=`echo $$p|sed -e "s/.*\.//"`; \
if test "x$$ext" = "xdll"; then \
-@@ -607,12 +608,12 @@
+@@ -607,12 +609,12 @@
rm -f $(DESTDIR)$(bindir)/$$p; \
done
diff --git a/lang/xotcl/files/patch-configure b/lang/xotcl/files/patch-configure
index 04982e3dd889..5c520ff22c21 100644
--- a/lang/xotcl/files/patch-configure
+++ b/lang/xotcl/files/patch-configure
@@ -1,11 +1,11 @@
---- configure.orig 2010-03-06 11:14:38.000000000 +0100
-+++ configure 2010-05-11 10:30:25.126687046 +0200
-@@ -7341,7 +7342,7 @@
+--- configure.orig 2011-11-03 13:20:08.000000000 +0100
++++ configure 2013-05-13 11:03:08.000000000 +0200
+@@ -5499,7 +5499,7 @@
esac
result="Using ${TCL_INCLUDES}"
else
- if test ! -f "${TCL_SRC_DIR}/generic/tclInt.h" ; then
+ if test ! -f "${TCL_INCLUDEDIR}/generic/tclInt.h" ; then
- { { echo "$as_me:$LINENO: error: Cannot find private header tclInt.h in ${TCL_SRC_DIR}" >&5
- echo "$as_me: error: Cannot find private header tclInt.h in ${TCL_SRC_DIR}" >&2;}
- { (exit 1); exit 1; }; }
+ as_fn_error $? "Cannot find private header tclInt.h in ${TCL_SRC_DIR}" "$LINENO" 5
+ fi
+ result="Using srcdir found in tclConfig.sh: ${TCL_SRC_DIR}"