aboutsummaryrefslogtreecommitdiff
path: root/lang/xotcl
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-20 11:39:16 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-20 11:39:16 +0000
commit6ee3321befc07af15871586b4d11ed64fed416db (patch)
tree939910ebf4bfd82249ed53fe5eeaa3c69c310bac /lang/xotcl
parent3cc822b9bc60cf6b60f3b65dc7fb6d0c82410ce2 (diff)
downloadports-6ee3321befc07af15871586b4d11ed64fed416db.tar.gz
ports-6ee3321befc07af15871586b4d11ed64fed416db.zip
Notes
Diffstat (limited to 'lang/xotcl')
-rw-r--r--lang/xotcl/Makefile50
1 files changed, 11 insertions, 39 deletions
diff --git a/lang/xotcl/Makefile b/lang/xotcl/Makefile
index 1f18c36d80dd..8aa09b594741 100644
--- a/lang/xotcl/Makefile
+++ b/lang/xotcl/Makefile
@@ -7,10 +7,9 @@
PORTNAME= xotcl
PORTVERSION= 1.5.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES?= lang tcl84
MASTER_SITES= http://media.wu-wien.ac.at/download/
-PKGNAMESUFFIX?= ${THREADS_SUFFIX}
MAINTAINER= martin@matuska.org
COMMENT= Object-oriented scripting language based on Tcl
@@ -21,8 +20,7 @@ USE_TCL_VER?= 84
IGNORE= supported values for USE_TCL_VER are only 84 and 85
.endif
-USE_TCL= ${USE_TCL_VER}
-USE_TCL_BUILD= ${USE_TCL_VER}
+LIB_DEPENDS+= tcl${USE_TCL_VER}-threads:${PORTSDIR}/lang/tcl${USE_TCL_VER}-thread
INSTALL_TARGET= install
ALL_TARGET= all test-nohttp
USE_GMAKE= yes
@@ -47,7 +45,6 @@ PLIST= ${WRKDIR}/pkg-plist.aolserver
PLIST_FILES= ${AOLSERVERBASE:S/${LOCALBASE}\///}/modules/tcl/xotcl.tcl
LATEST_LINK= aolserver-xotcl
NO_BUILD= yes
-WITH_THREADS= yes
.endif
.if defined(WITH_ACTIWEB)
@@ -70,44 +67,19 @@ INSTALL_TARGET+= install-shells
MAN1= xotclsh.1
.endif
-. if exists(${TCLSH})
-_TCL_IS_THREADED!= ${ECHO_CMD} 'puts [array names tcl_platform -exact threaded]' | ${TCLSH} || return 0
-. if !defined(TCL_WITH_THREADS) && !defined(WITH_THREADS) && !empty(_TCL_IS_THREADED)
-TCL_WITH_THREADS= yes
-. endif
-. endif
-
-.if defined(TCL_WITH_THREADS) || defined(WITH_THREADS)
-. if defined(_TCL_IS_THREADED) && empty(_TCL_IS_THREADED)
-IGNORE= Tcl with threads is required. Please install Tcl with WITH_THREADS defined or from lang/tcl${USE_TCL} port and try again
-. endif
-CONFIGURE_ARGS+= --enable-threads
-. if !defined(AOLSERVER_XOTCL)
-THREADS_SUFFIX= -threads
-. endif
-USE_TCL= ${USE_TCL_VER}-thread
-USE_TCL_BUILD= ${USE_TCL_VER}-thread
-.include "${PORTSDIR}/Mk/bsd.tcl.mk"
-. else
-CONFIGURE_ARGS+= --disable-threads
-.endif
-
-LATEST_LINK?= xotcl${THREADS_SUFFIX}
-
CONFIGURE_ARGS+= --exec-prefix=${PREFIX} \
--libdir=${PREFIX}/lib \
- --with-tcl=${TCL_LIBDIR} \
- --with-tclinclude=${TCL_INCLUDEDIR}/generic/ \
+ --enable-threads \
+ --with-tcl=${LOCALBASE}/lib/tcl${USE_TCL_VER:S/8/8./}-threads \
+ --with-tclinclude=${LOCALBASE}/include/tcl${USE_TCL_VER:S/8/8./}/generic/ \
--with-xotclsh
-.if !defined(AOLSERVER_XOTCL) # Install for aolserver module
-pre-configure:
-. if defined(TCL_WITH_THREADS) || defined(WITH_THREADS)
- @${ECHO_CMD} "*************************************************"
- @${ECHO_CMD} "NOTICE: XOTcl will be built with threads support."
- @${ECHO_CMD} "*************************************************"
-. endif
-.else # installation for aolserver module
+post-patch:
+ @${REINPLACE_CMD} -e 's|$${TCL_MINOR_VERSION}$${TCL_DBGX}|$${TCL_MINOR_VERSION}$${TCL_DBGX}-threads|g' \
+ ${WRKSRC}/configure
+
+.if defined(AOLSERVER_XOTCL) # Install for aolserver module
+
do-install:
@${INSTALL_DATA} ${WRKSRC}/generic/aol-xotcl.tcl ${AOLSERVERBASE}/modules/tcl/xotcl.tcl
.endif