aboutsummaryrefslogtreecommitdiff
path: root/lang/xsb/files
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-20 19:53:10 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-20 19:53:10 +0000
commit041df375fc27d450d730f7e68fd463841a599911 (patch)
treef31503800f1ee81db8caa9ad2a7ab3fd4c9c4a40 /lang/xsb/files
parent79eb24a0367e8edf7ef418be738f1d887591fea3 (diff)
Notes
Diffstat (limited to 'lang/xsb/files')
-rw-r--r--lang/xsb/files/patch-aa28
-rw-r--r--lang/xsb/files/patch-ab28
-rw-r--r--lang/xsb/files/patch-ac4
-rw-r--r--lang/xsb/files/patch-ad27
-rw-r--r--lang/xsb/files/patch-ae4
-rw-r--r--lang/xsb/files/patch-af35
-rw-r--r--lang/xsb/files/patch-ag20
7 files changed, 85 insertions, 61 deletions
diff --git a/lang/xsb/files/patch-aa b/lang/xsb/files/patch-aa
index 0eaa3a3e9dd1..03eab6ffbb73 100644
--- a/lang/xsb/files/patch-aa
+++ b/lang/xsb/files/patch-aa
@@ -1,16 +1,16 @@
---- configure.old Thu Jul 5 12:42:10 2001
-+++ configure Sun Jul 29 15:51:36 2001
-@@ -1561,7 +1561,7 @@
- # if --with-gcc, take it as a sign of trouble
- # with gcc and lower optimization levels
- if test -n "$with_gcc" ; then
+--- configure.orig Sat Apr 27 11:18:26 2002
++++ configure Sat Apr 27 11:02:49 2002
+@@ -1664,7 +1664,7 @@
+ CFLAGS=""
+ c_inline_level=""
+ else
- emuloop_opt_level=-${optimization_level-"O4 -fomit-frame-pointer"}
+ emuloop_opt_level=-${optimization_level-"O2 -fomit-frame-pointer"}
trutils_opt_level=-${optimization_level-"O1 -fomit-frame-pointer"}
builtins_opt_level=-${optimization_level-"O1 -fomit-frame-pointer"}
if test -n "$optimization_level"; then
-@@ -1572,9 +1572,9 @@
- CFLAGS="-Wall -ansi -pedantic"
+@@ -1676,9 +1676,9 @@
+ fi
else
case $CC in
- gcc) emuloop_opt_level=-${optimization_level-"O4 -fomit-frame-pointer"}
@@ -21,7 +21,7 @@
if test -n "$optimization_level"; then
c_inline_level=""
else
-@@ -1583,23 +1583,23 @@
+@@ -1687,23 +1687,23 @@
CFLAGS="-Wall -ansi -pedantic"
;;
cc) if test "$__sunpro_c" = "no"; then
@@ -33,8 +33,7 @@
+ builtins_opt_level=-${optimization_level-"O2"}
else
# emuloop_opt_level is the optimization level for emuloop.c
-- # Using xO4 would take SunPro more than an hour, hence xO2.
-+ # Using xO2 would take SunPro more than an hour, hence xO2.
+ # Using xO4 would take SunPro more than an hour, hence xO2.
emuloop_opt_level=-${optimization_level-"xO2"}
- trutils_opt_level=-${optimization_level-"xO4"}
- builtins_opt_level=-${optimization_level-"xO4"}
@@ -53,12 +52,7 @@
c_inline_level=""
CFLAGS="-Xa"
;;
-@@ -3006,16 +3006,16 @@
- #fi
-
-
--# Normally, the optimization level will be O4.
-+# Normally, the optimization level will be O2.
+@@ -3231,12 +3231,12 @@
# SGI64 must have O1 and 32 bit SGI's can have O2
if test "$__sunpro_c" = "no"; then
if test "$CC" = "gcc" ; then
diff --git a/lang/xsb/files/patch-ab b/lang/xsb/files/patch-ab
index b3f39d714fbe..972737c4b9e4 100644
--- a/lang/xsb/files/patch-ab
+++ b/lang/xsb/files/patch-ab
@@ -1,16 +1,16 @@
---- configure.in.old Thu Jul 5 12:42:10 2001
-+++ configure.in Sun Jul 29 15:52:05 2001
-@@ -579,7 +579,7 @@
- # if --with-gcc, take it as a sign of trouble
- # with gcc and lower optimization levels
- if test -n "$with_gcc" ; then
+--- configure.in.orig Sat Apr 27 11:20:37 2002
++++ configure.in Sat Apr 27 11:20:21 2002
+@@ -652,7 +652,7 @@
+ CFLAGS=""
+ c_inline_level=""
+ else
- emuloop_opt_level=-${optimization_level-"O4 -fomit-frame-pointer"}
+ emuloop_opt_level=-${optimization_level-"O2 -fomit-frame-pointer"}
trutils_opt_level=-${optimization_level-"O1 -fomit-frame-pointer"}
builtins_opt_level=-${optimization_level-"O1 -fomit-frame-pointer"}
if test -n "$optimization_level"; then
-@@ -590,9 +590,9 @@
- CFLAGS="-Wall -ansi -pedantic"
+@@ -664,9 +664,9 @@
+ fi
else
case $CC in
- gcc) emuloop_opt_level=-${optimization_level-"O4 -fomit-frame-pointer"}
@@ -21,7 +21,7 @@
if test -n "$optimization_level"; then
c_inline_level=""
else
-@@ -601,23 +601,23 @@
+@@ -675,23 +675,23 @@
CFLAGS="-Wall -ansi -pedantic"
;;
cc) if test "$__sunpro_c" = "no"; then
@@ -33,8 +33,7 @@
+ builtins_opt_level=-${optimization_level-"O2"}
else
# emuloop_opt_level is the optimization level for emuloop.c
-- # Using xO4 would take SunPro more than an hour, hence xO2.
-+ # Using xO2 would take SunPro more than an hour, hence xO2.
+ # Using xO4 would take SunPro more than an hour, hence xO2.
emuloop_opt_level=-${optimization_level-"xO2"}
- trutils_opt_level=-${optimization_level-"xO4"}
- builtins_opt_level=-${optimization_level-"xO4"}
@@ -53,12 +52,7 @@
c_inline_level=""
CFLAGS="-Xa"
;;
-@@ -1036,16 +1036,16 @@
- #fi
-
-
--# Normally, the optimization level will be O4.
-+# Normally, the optimization level will be O2.
+@@ -1161,12 +1161,12 @@
# SGI64 must have O1 and 32 bit SGI's can have O2
if test "$__sunpro_c" = "no"; then
if test "$CC" = "gcc" ; then
diff --git a/lang/xsb/files/patch-ac b/lang/xsb/files/patch-ac
index 64f3c55ee94a..780959e94503 100644
--- a/lang/xsb/files/patch-ac
+++ b/lang/xsb/files/patch-ac
@@ -1,5 +1,5 @@
---- makexsb.in.old Sun Jul 29 15:37:36 2001
-+++ makexsb.in Sun Jul 29 16:18:20 2001
+--- makexsb.in.orig Sat Apr 27 11:23:44 2002
++++ makexsb.in Sat Apr 27 11:23:32 2002
@@ -74,9 +74,9 @@
if test -r "$makefile" ; then
diff --git a/lang/xsb/files/patch-ad b/lang/xsb/files/patch-ad
index 022697bb350f..10ae3824c972 100644
--- a/lang/xsb/files/patch-ad
+++ b/lang/xsb/files/patch-ad
@@ -1,6 +1,6 @@
---- topMakefile.in.old Sun Jul 29 16:23:01 2001
-+++ topMakefile.in Sun Jul 29 16:22:28 2001
-@@ -164,9 +164,9 @@
+--- topMakefile.in.orig Sat Apr 27 11:25:35 2002
++++ topMakefile.in Sat Apr 27 11:26:48 2002
+@@ -172,9 +172,9 @@
emu: ${src_config_prefix}/xsb_config.h ${src_config_prefix}/xsb_debug.h
cd ${src_emudir}; \
@@ -12,7 +12,7 @@
$(srcdir)/build/touch.sh $(srcdir)/build/.xsb_build_failed) \
2>&1 | tee -a ../build/Installation_summary; \
(test ! -f $(srcdir)/build/.xsb_build_failed || \
-@@ -174,7 +174,7 @@
+@@ -182,7 +182,7 @@
gpp:
@echo ""; echo "Making gpp"
@@ -21,16 +21,16 @@
# Compiling the interface with sModels.
smodels:
-@@ -182,7 +182,7 @@
+@@ -190,7 +190,7 @@
echo "Compiling smodels interface"; \
rm -f *.o Makefile *.h *.O *.so 2>/dev/null || echo ""; \
ln -s ${src_config_prefix}/smoMakefile ./Makefile; \
-- make XSB=$(src_scriptdir)/xsb$(config_tag) @smodels_goal@ 2>&1\
-+ gmake XSB=$(src_scriptdir)/xsb$(config_tag) @smodels_goal@ 2>&1\
+- make CROSS_SIMULATOR=@CROSS_SIMULATOR@ XSB=$(src_scriptdir)/xsb$(config_tag) @smodels_goal@ 2>&1\
++ gmake CROSS_SIMULATOR=@CROSS_SIMULATOR@ XSB=$(src_scriptdir)/xsb$(config_tag) @smodels_goal@ 2>&1\
| tee -a ../../build/Installation_summary
# Goal for making an XSB load module to be linked with external
-@@ -193,10 +193,10 @@
+@@ -201,10 +201,10 @@
# This invokes xsboramod and xsbmod goals in emuMakefile, respectively
xsbmod: ${src_config_prefix}/xsb_config.h ${src_config_prefix}/xsb_debug.h
cd ${src_emudir}; \
@@ -43,7 +43,7 @@
emu_clean: do_cleaning inform_executable
-@@ -305,10 +305,10 @@
+@@ -394,10 +394,10 @@
chmod 644 $(install_config_libdir)/xsb_configuration.O
remake_dot_O_files:
@@ -56,3 +56,12 @@
# clean for this architecture only
configclean::
+@@ -419,7 +419,7 @@
+ @cd ../packages; ../build/clean_pkgs.sh
+ @-cd ${src_examples}; rm -f *.O *.o *~ */*.O */*.o */*~
+ @echo "Cleaning up ${src_libdir}"
+- @-(cd ${src_libdir}; make clean)
++ @-(cd ${src_libdir}; gmake clean)
+
+ # recreate the makefiles
+ again: Makefile.in emuMakefile.in config.status ${src_config_prefix}/config.cache
diff --git a/lang/xsb/files/patch-ae b/lang/xsb/files/patch-ae
index 1ce95d56b296..c1184532e30b 100644
--- a/lang/xsb/files/patch-ae
+++ b/lang/xsb/files/patch-ae
@@ -1,5 +1,5 @@
---- ../Makefile.orig Sun Jul 29 17:47:07 2001
-+++ ../Makefile Sun Jul 29 17:47:59 2001
+--- ../Makefile.orig Sat Apr 27 11:28:50 2002
++++ ../Makefile Sat Apr 27 11:28:39 2002
@@ -38,16 +38,16 @@
syslib::
diff --git a/lang/xsb/files/patch-af b/lang/xsb/files/patch-af
index 620c21bf5aa7..403491563b5c 100644
--- a/lang/xsb/files/patch-af
+++ b/lang/xsb/files/patch-af
@@ -1,29 +1,36 @@
---- register.sh~ Tue Apr 11 18:30:27 2000
-+++ register.sh Wed Aug 1 15:25:39 2001
-@@ -6,21 +6,15 @@
+--- register.sh.orig Sat Apr 27 11:34:29 2002
++++ register.sh Sat Apr 27 11:33:33 2002
+@@ -4,23 +4,20 @@
+ cat <<EOF
+ *******************************************************************************
- The installation process is now complete. The log is in: Installation_summary
+-The installation process is now complete. The log is in: Installation_summary
++The installation process is now complete.
-We would like to ask you to email this log to us.
-+We would like to ask you to email this log to us:
-+
-+ xsb-installation@lists.sourceforge.net
-+
- Installation logs help the XSB group to keep track of the usage of the
- system on different architectures and to isolate problems more easily.
+-Installation logs help the XSB group to keep track of the usage of the
+-system on different architectures and to isolate problems more easily.
++A log of this process has been created in:
-The log will be sent automatically to xsb-installation@lists.sourceforge.net
-Would you like to send us the installation log? (y/n): y
-+*******************************************************************************
- EOF
--
+-EOF
++ Installation_summary
++
++We would like to ask you to email this log to us:
+
-read sendlog
--
++ xsb-installation@lists.sourceforge.net
+
-if test "$sendlog" != "n" -a "$sendlog" != "no" -a "$sendlog" != "N" ; then
- (cat sendlog.msg Installation_summary \
- | mail xsb-installation@lists.sourceforge.net) \
- && echo "" ; echo "Thank you!"; echo ""
-fi
++Installation logs help the XSB group to keep track of the usage of the
++system on different architectures and to isolate problems more easily.
++*******************************************************************************
++EOF
cat <<EOF
Should you find a bug in XSB, please report it using our bug tracking system at
diff --git a/lang/xsb/files/patch-ag b/lang/xsb/files/patch-ag
new file mode 100644
index 000000000000..dc36e75996b9
--- /dev/null
+++ b/lang/xsb/files/patch-ag
@@ -0,0 +1,20 @@
+--- config.guess.orig Tue Jun 18 11:40:04 2002
++++ config.guess Tue Jun 18 11:40:48 2002
+@@ -79,7 +79,7 @@
+ fi
+
+
+-dummy=dummy-$$
++dummy=/tmp/dummy-$$
+ trap 'rm -f $dummy.c $dummy.o $dummy; exit 1' 1 2 15
+
+ # Use $HOST_CC if defined. $CC may point to a cross-compiler
+@@ -92,7 +92,7 @@
+ else
+ echo 'int dummy(){}' >$dummy.c
+ for c in cc c89 gcc; do
+- ($c $dummy.c -c) >/dev/null 2>&1
++ ($c $dummy.c -c -o $dummy.o) >/dev/null 2>&1
+ if test $? = 0; then
+ CC_FOR_BUILD="$c"; break
+ fi