aboutsummaryrefslogtreecommitdiff
path: root/lang/yabasic/Makefile
diff options
context:
space:
mode:
authorMark Pulford <markp@FreeBSD.org>2001-06-14 07:40:22 +0000
committerMark Pulford <markp@FreeBSD.org>2001-06-14 07:40:22 +0000
commit3a26ce1394c0358c066a93e5d32e1f00e372afb8 (patch)
tree033c30dee3cd2760bfdd50a6259618f8081a9302 /lang/yabasic/Makefile
parenta010a20ed116dfdb50aafbde548e25c3cc048b63 (diff)
downloadports-3a26ce1394c0358c066a93e5d32e1f00e372afb8.tar.gz
ports-3a26ce1394c0358c066a93e5d32e1f00e372afb8.zip
Notes
Diffstat (limited to 'lang/yabasic/Makefile')
-rw-r--r--lang/yabasic/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/lang/yabasic/Makefile b/lang/yabasic/Makefile
index 6d6d56609e73..02958782b3d0 100644
--- a/lang/yabasic/Makefile
+++ b/lang/yabasic/Makefile
@@ -10,12 +10,23 @@ PORTVERSION= 2.681
CATEGORIES= lang
MASTER_SITES= http://www.yabasic.de/download/
-MAINTAINER= elwood@mc5sys.in-berlin.de
-
-BROKEN= "Patches fail to apply; needs to be updated to new version"
+MAINTAINER= ports@FreeBSD.org
USE_BISON= yes
USE_XLIB= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${X11BASE}/include"
+MAN1= yabasic.1
+
+post-patch:
+ ${PERL} -pi -e "s|<malloc.h>|<stdlib.h>|g" ${WRKSRC}/bison.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/yabasic ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/yabasic.1 ${MANPREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/yabasic
+ ${INSTALL_DATA} ${WRKSRC}/yabasic.htm ${PREFIX}/share/doc/yabasic
+.endif
.include <bsd.port.mk>