aboutsummaryrefslogtreecommitdiff
path: root/lang/yap-devel/Makefile
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-28 14:56:08 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-28 14:56:08 +0000
commit323f1991bcecf1c12367ab9d26033e5f9009a410 (patch)
tree26d540921af460425a9c23cdc92c7bd6e8f719d9 /lang/yap-devel/Makefile
parentd8496072aee28a4a0802a6be370e382cb194cfbe (diff)
downloadports-323f1991bcecf1c12367ab9d26033e5f9009a410.tar.gz
ports-323f1991bcecf1c12367ab9d26033e5f9009a410.zip
Notes
Diffstat (limited to 'lang/yap-devel/Makefile')
-rw-r--r--lang/yap-devel/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/lang/yap-devel/Makefile b/lang/yap-devel/Makefile
index 947194d61b7d..c825dca3f5d8 100644
--- a/lang/yap-devel/Makefile
+++ b/lang/yap-devel/Makefile
@@ -15,22 +15,23 @@ LICENSE_COMB= dual
CONFLICTS= yap-6.2.*
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS MYDDAS
+MYDDAS_DESC= Enable MySQL support
-.include <bsd.port.options.mk>
+OPTIONS_SUB= yes
-.if ${PORT_OPTIONS:MDOCS}
-USE_TEX= base texmf latex
-BUILD_DEPENDS+= ${LOCALBASE}/bin/texi2html:${PORTSDIR}/textproc/texi2html
-BUILD_DEPENDS+= ${LOCALBASE}/bin/texi2pdf:${PORTSDIR}/print/texinfo
-.endif
+DOCS_USE= TEX=base,texmf,latex
+DOCS_BUILD_DEPENDS= ${LOCALBASE}/bin/texi2html:${PORTSDIR}/textproc/texi2html \
+ ${LOCALBASE}/bin/texi2pdf:${PORTSDIR}/print/texinfo
+
+MYDDAS_LIB_DEPENDS= libiodbc.so:${PORTSDIR}/databases/libiodbc
+MYDDAS_CONFIGURE_ENABLE= myddas myddas-top-level
STRIP= #none
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --enable-max-performance \
- --disable-clpbn-bp
+CONFIGURE_ARGS+= --enable-max-performance --disable-clpbn-bp
USES= gmake
USE_GCC= any
@@ -41,6 +42,8 @@ EXTRACT_AFTER_ARGS= | ${SETENV} LC_ALL=en_US.UTF-8 ${TAR} -xf -
DOCSDIR= ${PREFIX}/share/doc/Yap
DATADIR= ${PREFIX}/share/Yap
+.include <bsd.port.options.mk>
+
post-build:
.if empty(PORT_OPTIONS:MDOCS)
# prevent the installation of docs files