aboutsummaryrefslogtreecommitdiff
path: root/lang/yap/Makefile
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-09-09 18:30:48 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-09-09 18:30:48 +0000
commita574054750b0a85efa4bbbd84da03bad35e406d5 (patch)
tree456f959f7d56164e5da44788f48e7c4be5d34687 /lang/yap/Makefile
parent7672c67032169d645530ea7edc54e06ebf02e707 (diff)
downloadports-a574054750b0a85efa4bbbd84da03bad35e406d5.tar.gz
ports-a574054750b0a85efa4bbbd84da03bad35e406d5.zip
Notes
Diffstat (limited to 'lang/yap/Makefile')
-rw-r--r--lang/yap/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/lang/yap/Makefile b/lang/yap/Makefile
index aadf42ddab82..487cb1953a69 100644
--- a/lang/yap/Makefile
+++ b/lang/yap/Makefile
@@ -7,9 +7,10 @@
#
PORTNAME= yap
-PORTVERSION= 4.5.6
+PORTVERSION= 5.0.0
CATEGORIES= lang
-MASTER_SITES= http://www.ncc.up.pt/~vsc/Yap/Yap4.5/
+MASTER_SITES= http://www.ncc.up.pt/~vsc/Yap/%SUBDIR%/
+MASTER_SITE_SUBDIR= Yap-${PORTVERSION:R}
DISTNAME= Yap-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
@@ -17,6 +18,7 @@ COMMENT= A high-performance Prolog compiler
LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -26,11 +28,17 @@ INFO= yap
.include <bsd.port.pre.mk>
-ONLY_FOR_ARCHS= i386
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
post-extract:
@${RM} -f ${WRKSRC}/docs/*.info*
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|@value{VERSION}|${PORTVERSION}|g' ${WRKSRC}/docs/yap.tex
+
post-build:
cd ${WRKSRC}/docs && makeinfo --no-split yap.tex