aboutsummaryrefslogtreecommitdiff
path: root/lang/yap/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-11-06 21:03:44 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-11-06 21:03:44 +0000
commit53331551bd966d3855e3c7588f1abe5b695908b5 (patch)
tree66b45344bb72154ec9f60cfe3f67c60482312c3d /lang/yap/Makefile
parent586f52a39eef70c7901528dab9f09692f6489299 (diff)
downloadports-53331551bd966d3855e3c7588f1abe5b695908b5.tar.gz
ports-53331551bd966d3855e3c7588f1abe5b695908b5.zip
Notes
Diffstat (limited to 'lang/yap/Makefile')
-rw-r--r--lang/yap/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/lang/yap/Makefile b/lang/yap/Makefile
index 720140c45d50..b29c6bc0b7be 100644
--- a/lang/yap/Makefile
+++ b/lang/yap/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= yap
-PORTVERSION= 4.3.22
+PORTVERSION= 4.4.3
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,7 +19,19 @@ COMMENT= A high-performance Prolog compiler
LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+INFO= yap
+
+post-extract:
+ @${RM} -f ${WRKSRC}/docs/*.info*
+
+post-build:
+ cd ${WRKSRC}/docs && makeinfo --no-split yap.tex
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/docs/yap.info ${PREFIX}/info
+ install-info ${PREFIX}/info/yap.info ${PREFIX}/info/dir
+
.include <bsd.port.mk>