aboutsummaryrefslogtreecommitdiff
path: root/lang/yorick/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1997-11-24 09:23:01 +0000
committerThomas Gellekum <tg@FreeBSD.org>1997-11-24 09:23:01 +0000
commita04dca10be307b32526cc5f4db2ba731ecec046e (patch)
tree45d58bd45a5d5ee7935b5e7629a5edc140e0b65e /lang/yorick/Makefile
parent559e9ffa0a0ff9f4c5cfb5e86bcc0a7acd31059d (diff)
Yorick port. Yorick is an interpreted language tailored for
scientific computing. PR: 5132 Submitted by: Pedro Giffuni <giffunip@asme.org>
Notes
Notes: svn path=/head/; revision=8794
Diffstat (limited to 'lang/yorick/Makefile')
-rw-r--r--lang/yorick/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/lang/yorick/Makefile b/lang/yorick/Makefile
new file mode 100644
index 000000000000..2cc5e18a8958
--- /dev/null
+++ b/lang/yorick/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: Yorick
+# Version required: 1.4.1
+# Date created: 26 Oct 97
+# Whom: Pedro Giffuni <giffunip@asme.org>
+#
+# $Id$
+#
+
+DISTNAME= yorick-1.4
+PKGNAME= yorick-1.4.1
+CATEGORIES= lang math
+MASTER_SITES= ftp://ftp-icf.llnl.gov/pub/Yorick/ \
+ ftp://wuarchive.wustl.edu/languages/yorick/ \
+ ftp://netlib.att.com/netlib/env/ \
+ ftp://netlib2.cs.utk.edu/env/
+
+PATCH_SITES= ftp://ftp-icf.llnl.gov/pub/Yorick/
+PATCHFILES= yorick-1.4.diff.gz
+
+MAINTAINER= giffunip@asme.org
+
+PATCH_DIST_STRIP=-p1
+HAS_CONFIGURE= yes
+ALL_TARGET=
+MAN1= yorick.1 gist.1
+
+post-install:
+ strip $(PREFIX)/bin/yorick
+ strip $(PREFIX)/bin/gist
+ @${INSTALL_MAN} ${WRKSRC}/yorick.1 ${PREFIX}/man/man1/
+ @${INSTALL_MAN} ${WRKSRC}/gist.1 ${PREFIX}/man/man1/
+.if defined(NOPORTDOCS)
+ ${RM} -rf $(PREFIX)/share/yorick/1.4/doc
+.endif
+
+.include <bsd.port.mk>