aboutsummaryrefslogtreecommitdiff
path: root/lang/yorick/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-05-20 15:23:32 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-05-20 15:23:32 +0000
commit71213a28720fe5c4a7b392c8c5aacd6b40a2e9be (patch)
treec6e68cde4c0b02bdcf47b90f976a05005e94e096 /lang/yorick/Makefile
parentde8f4a332ea6f087fbb52741186eedbbf424e439 (diff)
Notes
Diffstat (limited to 'lang/yorick/Makefile')
-rw-r--r--lang/yorick/Makefile42
1 files changed, 11 insertions, 31 deletions
diff --git a/lang/yorick/Makefile b/lang/yorick/Makefile
index b0c17cd09b00..b76eed9f840a 100644
--- a/lang/yorick/Makefile
+++ b/lang/yorick/Makefile
@@ -5,45 +5,24 @@
# $FreeBSD$
#
-# History: 1.4.1 port by Pedro Giffuni <giffunip@asme.org>
-# 1.5.02 port by ports@FreeBSD.org,
-# from submission by Ed Alley <wea@llnl.gov>
-# 1.5.07 port by David H. Munro <munro1@llnl.gov>
-# 1.5.12 port by David H. Munro <munro1@llnl.gov>, 01/Nov/02
-# 1.5.14 port by David H. Munro <munro1@llnl.gov>, 01/Oct/03
-# 1.5.07 notes:
-# (1) info pages installed in PREFIX/info for consistency with other apps
-# -- really should be in PREFIX/share/info
-# (2) several fixes to allow PREFIX for package install to be different
-# from PREFIX at build time (which is compiled into yorick and gist):
-# (a) PREFIX/bin/{yorick,gist} are softlinks, which allows
-# yorick and gist to compute ${PREFIX}/lib/${PORTNAME} at runtime
-# (b) softlink for g/ put in lib/${PORTNAME} for gist
-# (c) softlink doc/ so yorick online help is correct
-# (d) copy of paths.i put in lib/${PORTNAME}/bin for yorick
-# (e) pkg-install script added to fiddle softlinks, paths.i, and
-# Maketmpl if PREFIX has changed at install time
-# -- assume DOCSDIR and DATADIR take default values as does pkg-plist
-# 1.5.08 replaces 1.5.07 infant mortality
-
PORTNAME= yorick
-PORTVERSION= 1.5.14
+PORTVERSION= 1.6.02
CATEGORIES= lang math
-MASTER_SITES= ftp://ftp-icf.llnl.gov/pub/Yorick/
+MASTER_SITES= ftp://ftp-icf.llnl.gov/pub/Yorick/ \
+ http://www.maumae.net/yorick/
EXTRACT_SUFX= .tgz
-MAINTAINER= munro1@llnl.gov
+MAINTAINER= johans@stack.nl
COMMENT= Interpreted language and scientific graphics
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
USE_XLIB= yes
-MAKE_ARGS= Y_HOME="${PREFIX}/lib/${PORTNAME}" Y_SITE="${DATADIR}" \
- Y_DOCDIR=/dev/null
+MAKE_ARGS= Y_HOME=relocatable Y_DOCDIR=/dev/null
MAN1= yorick.1 gist.1
INFO= yorick
-PORTDOCS= FILE_FORMATS README drat.doc drat.tex graph.doc hex.doc \
+PORTDOCS= FILE_FORMATS README drat.doc graph.doc hex.doc \
library.doc math.doc refs.pdf refs.ps refs.tex std.doc \
yorick.pdf yorick.ps yorick.tex
@@ -57,21 +36,22 @@ post-build:
.endif
post-install:
+ ${INSTALL_DATA} ${WRKSRC}/emacs/yorick.el ${WRKSRC}/relocatable
+ @${RM} -rf ${WRKSRC}/relocatable/doc
+ @${RM} -rf ${PREFIX}/lib/${PORTNAME}
+ @${MV} ${WRKSRC}/relocatable ${PREFIX}/lib/${PORTNAME}
.for file in gist yorick
${INSTALL_MAN} ${WRKSRC}/doc/${file}.1 ${PREFIX}/man/man1
@${STRIP_CMD} ${PREFIX}/lib/${PORTNAME}/bin/${file}
@${LN} -sf ${PREFIX}/lib/${PORTNAME}/bin/${file} ${PREFIX}/bin/${file}
.endfor
@${STRIP_CMD} ${PREFIX}/lib/${PORTNAME}/lib/codger
- ${INSTALL_DATA} ${WRKSRC}/emacs/yorick.el ${DATADIR}
- @${LN} -sf ../../share/${PORTNAME}/g ${PREFIX}/lib/${PORTNAME}/g
- @${CP} ${DATADIR}/i0/paths.i ${PREFIX}/lib/${PORTNAME}/bin/paths.i
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
.endfor
- @${LN} -sf ../doc/${PORTNAME} ${DATADIR}/doc
+ @${LN} -sf ${DOCSDIR} ${PREFIX}/lib/${PORTNAME}/doc
for f in ${WRKSRC}/doc/yorick.info*; do \
${INSTALL_DATA} $$f ${PREFIX}/info; \
done