aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2018-10-21 18:17:03 +0000
committerGleb Popov <arrowd@FreeBSD.org>2018-10-21 18:17:03 +0000
commit0906474aefae3515e2baa5c9d5bc52772548deef (patch)
treed99c2dea28611a1a89b25331720f1a0e7a5a56cd /lang
parentf98c4d232acf05a943f6e99cdad78c9ebf25cfe1 (diff)
downloadports-0906474aefae3515e2baa5c9d5bc52772548deef.tar.gz
ports-0906474aefae3515e2baa5c9d5bc52772548deef.zip
lang/ghc: Cosmetic changes to Makefile and build.mk files.
Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D17636
Notes
Notes: svn path=/head/; revision=482720
Diffstat (limited to 'lang')
-rw-r--r--lang/ghc/Makefile12
-rw-r--r--lang/ghc/files/build.boot.mk.in7
-rw-r--r--lang/ghc/files/build.mk.in8
3 files changed, 13 insertions, 14 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 0870908f9539..e64657d43230 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -42,8 +42,6 @@ NO_CCACHE= ccache: error: Failed to create directory /nonexistent/.ccache/tmp: P
# This is better fixed in files/build.mk.in
GNU_CONFIGURE= yes
-# disable xelatex: PR 231438
-CONFIGURE_ENV+= ac_cv_path_XELATEX=
CONFIGURE_ARGS= --with-gmp-includes=${LOCALBASE}/include \
--with-gmp-libraries=${LOCALBASE}/lib \
--with-iconv-includes=${LOCALBASE}/include \
@@ -78,17 +76,17 @@ DYNAMIC_CONFIGURE_ARGS= --with-system-libffi \
# The version number is needed as lang/gcc installs a different version
DYNAMIC_LIB_DEPENDS= libffi.so.6:devel/libffi
-# Append substitutions for build.mk -- the files uses '#' as comments
+# Append substitutions for build.mk
BOOT_SUB_LIST= HSC2HS=${LOCALBASE}/bin/hsc2hs
BOOT_SUB_LIST_OFF= HSC2HS=${BOOT_HSC2HS}
DOCS_BUILD_DEPENDS+= sphinx-build:textproc/py-sphinx
-DYNAMIC_SUB_LIST= WITH_DYNAMIC=""
-DYNAMIC_SUB_LIST_OFF= WITH_DYNAMIC="\#"
+DYNAMIC_SUB_LIST= WITH_DYNAMIC="YES"
+DYNAMIC_SUB_LIST_OFF= WITH_DYNAMIC="NO"
-PROFILE_SUB_LIST= WITH_PROFILE=""
-PROFILE_SUB_LIST_OFF= WITH_PROFILE="\#"
+PROFILE_SUB_LIST= WITH_PROFILE="YES"
+PROFILE_SUB_LIST_OFF= WITH_PROFILE="NO"
DOCS_SUB_LIST= WITH_DOCS="YES"
DOCS_SUB_LIST_OFF= WITH_DOCS="NO"
diff --git a/lang/ghc/files/build.boot.mk.in b/lang/ghc/files/build.boot.mk.in
index 557732a69a03..c38f6c9806f0 100644
--- a/lang/ghc/files/build.boot.mk.in
+++ b/lang/ghc/files/build.boot.mk.in
@@ -1,8 +1,9 @@
GhcLibWays = v
XMLDocWays =
-HADDOCK_DOCS =
-HSCOLOUR_SRCS =
+HADDOCK_DOCS = NO
+HSCOLOUR_SRCS = NO
INTEGER_LIBRARY = integer-simple
-DYNAMIC_GHC_PROGRAMS =
+DYNAMIC_GHC_PROGRAMS = NO
+BUILD_PROF_LIBS = NO
BIN_DIST_NAME = ghc-%%GHC_VERSION%%-boot
BIN_DIST_TAR = ghc-%%GHC_VERSION%%-boot.tar
diff --git a/lang/ghc/files/build.mk.in b/lang/ghc/files/build.mk.in
index 8bbbb04ae120..366ab8678fc5 100644
--- a/lang/ghc/files/build.mk.in
+++ b/lang/ghc/files/build.mk.in
@@ -2,12 +2,12 @@ docdir = %%PREFIX%%/share/doc/ghc-%%GHC_VERSION%%
htmldir = %%PREFIX%%/share/doc/ghc-%%GHC_VERSION%%
mandir = %%PREFIX%%/man
infodir = %%PREFIX%%/info
-GhcLibWays = v
-%%WITH_PROFILE%%GhcLibWays += p
-%%WITH_DYNAMIC%%GhcLibWays += dyn
-DYNAMIC_GHC_PROGRAMS = %%WITH_DYNAMIC%%YES
+DYNAMIC_GHC_PROGRAMS = %%WITH_DYNAMIC%%
+BUILD_PROF_LIBS = %%WITH_PROFILE%%
HADDOCK_DOCS = %%WITH_DOCS%%
HSCOLOUR_SRCS = %%WITH_DOCS%%
+# disable xelatex: PR 231438
+BUILD_SPHINX_PDF = NO
BSD_PATH_TO_HSC2HS = %%HSC2HS%%
SRC_HC_OPTS += -I%%NCURSESINC%% -L%%NCURSESLIB%% -I%%LOCALBASE%%/include -L%%LOCALBASE%%/lib
SRC_CC_OPTS += %%CFLAGS%%