aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJulien Laffaye <jlaffaye@FreeBSD.org>2011-06-29 19:51:17 +0000
committerJulien Laffaye <jlaffaye@FreeBSD.org>2011-06-29 19:51:17 +0000
commit120964af64b17547dd4dbcd3039a73ab8bb67952 (patch)
treea02a85b0620b7d8fdffffb9c7d1efd500e54ccf5 /lang
parent3a0a528ec1449c7c0801622e0d322c1502ba2d06 (diff)
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/php52/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/lang/php52/Makefile b/lang/php52/Makefile
index 51b88f751228..1a331750cc3b 100644
--- a/lang/php52/Makefile
+++ b/lang/php52/Makefile
@@ -7,6 +7,7 @@
PORTNAME= php52
PORTVERSION= 5.2.17
+PORTREVISION= 1
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
MASTER_SITE_SUBDIR= distributions
@@ -46,7 +47,8 @@ OPTIONS= CLI "Build CLI version" on \
DISCARD "Enable discard-path support (CGI only)" off \
FASTCGI "Enable fastcgi support (CGI only)" on \
FPM "Enable fastcgi process manager (CGI only)" off \
- PATHINFO "Enable path-info-check support (CGI only)" on
+ PATHINFO "Enable path-info-check support (CGI only)" on \
+ LINKTHR "Link thread lib (for threaded extensions)" off
CONFLICTS= php4-4* php5-5.3*
@@ -170,6 +172,10 @@ CONFIGURE_ENV+= ac_cv_pthreads_lib="" \
MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+.if defined(WITH_LINKTHR)
+CONFIGURE_ENV+= LIBS="${LIBS} ${PTHREAD_LIBS}"
+.endif
+
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+=--enable-debug
.endif