aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2002-08-04 20:40:14 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2002-08-04 20:40:14 +0000
commit6153e1ab4af6e331c3165905ff515df2cfb95c96 (patch)
treeadb4079e0e85437706d18e8717fd7334c910bcb0 /lang
parenteba61de8f05eb2b9221b6831266a3daa20607fad (diff)
downloadports-6153e1ab4af6e331c3165905ff515df2cfb95c96.tar.gz
ports-6153e1ab4af6e331c3165905ff515df2cfb95c96.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/icc/Makefile11
-rw-r--r--lang/icc/pkg-plist2
-rw-r--r--lang/icc7/Makefile11
-rw-r--r--lang/icc7/pkg-plist2
4 files changed, 20 insertions, 6 deletions
diff --git a/lang/icc/Makefile b/lang/icc/Makefile
index 1bb8da854a69..551a9d32d44f 100644
--- a/lang/icc/Makefile
+++ b/lang/icc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= icc
PORTVERSION= 6.0.159
+PORTREVISION= 1
CATEGORIES= lang linux
MASTER_SITES=
DISTNAME= l_cc_pu_6.0.159
@@ -45,7 +46,7 @@ post-extract:
# intel-ecc6-6.0-159.ia64.rpm \
# intel-eldb6-6.0-228.ia64.rpm \
# intel-esubh6-6.0-159.ia64.rpm
- @cd ${WRKSRC}; rpm2cpio ${i} | cpio -idu --quiet
+ @cd ${WRKSRC}; rpm2cpio 2>/dev/null ${i} | cpio -idu --quiet
.endfor
pre-patch:
@@ -67,7 +68,7 @@ post-patch:
# Correct some paths and patch some files
.for i in ia32/bin/icc ia32/bin/icc.cfg ia32/bin/iccvars.csh \
ia32/bin/iccvars.sh ia32/bin/icpc ia32/bin/icpc.cfg docs/csupport
- @${SED} 's@export -n IA32ROOT; unset IA32ROOT;@@g; s@-a "<INSTALLDIR>/compiler60/ia32/bin/icc" @@g; s@-a "<INSTALLDIR>/compiler60/ia32/bin/icpc" @@g; s@\<INSTALLDIR\>@${PREFIX}/intel@g; s@-tp p6@@; s@man -w@manpath -q@g; s:\<INSTALLTIMECOMBOPACKAGEID\>:Intel(R) C++ Compiler for Linux:g' \
+ @${SED} 's@export -n IA32ROOT; unset IA32ROOT;@@g; s@-a "<INSTALLDIR>/compiler60/ia32/bin/icc" @@g; s@-a "<INSTALLDIR>/compiler60/ia32/bin/icpc" @@g; s@\<INSTALLDIR\>@${PREFIX}/intel@g; s@-tp p6@@; s@man -w@manpath -q@g; s:\<INSTALLTIMECOMBOPACKAGEID\>:${DISTNAME}:g' \
${WRKSRC}/opt/intel/compiler60/${i} \
>${WRKSRC}/opt/intel/compiler60/${i}.seded
@${MV} -f ${WRKSRC}/opt/intel/compiler60/${i}.seded \
@@ -80,7 +81,11 @@ post-patch:
@${RM} -rf ${WRKSRC}/opt/intel/compiler60/docs
.endif
# Provide a more FreeBSD'ish compile environment
- @${ECHO} -e "\n-Ulinux\n-U__linux__\n-U__linux\n\n-D__FreeBSD__=${ICCCFGVAL}\n-D__ELF__=1\n" >>${WRKSRC}/opt/intel/compiler60/ia32/bin/icc.cfg
+.for i in icc.cfg icpc.cfg
+ @${ECHO} -e "\n-Ulinux\n-U__linux__\n-U__linux\n\n-D__FreeBSD__=${ICCCFGVAL}\n-D__ELF__=1\n" >>${WRKSRC}/opt/intel/compiler60/ia32/bin/${i}
+ @${CHMOD} a-x,g-w ${WRKSRC}/opt/intel/compiler60/ia32/bin/${i}
+.endfor
+ @cd ${WRKSRC}/opt/intel/compiler60/ia32/bin/ && ${LN} -s icc.cfg iccbin.cfg && ${LN} -s icpc.cfg icpcbin.cfg
# \n-Qlocation,ld,/usr/bin\n\n-sox-\n
# Some magic to be able to link
@${SED} 's:@@PREFIX@@:${PREFIX}:g' ${FILESDIR}/ld >${WRKSRC}/opt/intel/compiler60/ia32/bin/ld
diff --git a/lang/icc/pkg-plist b/lang/icc/pkg-plist
index 7b578d4558c0..63595e62ddde 100644
--- a/lang/icc/pkg-plist
+++ b/lang/icc/pkg-plist
@@ -685,6 +685,7 @@ intel/compiler60/ia32/bin/INTEL
intel/compiler60/ia32/bin/icc
intel/compiler60/ia32/bin/icc.cfg
intel/compiler60/ia32/bin/iccbin
+intel/compiler60/ia32/bin/iccbin.cfg
intel/compiler60/ia32/bin/iccfilt
intel/compiler60/ia32/bin/iccvars.csh
intel/compiler60/ia32/bin/iccvars.sh
@@ -692,6 +693,7 @@ intel/compiler60/ia32/bin/icid
intel/compiler60/ia32/bin/icpc
intel/compiler60/ia32/bin/icpc.cfg
intel/compiler60/ia32/bin/icpcbin
+intel/compiler60/ia32/bin/icpcbin.cfg
intel/compiler60/ia32/bin/icpi
intel/compiler60/ia32/bin/ld
intel/compiler60/ia32/bin/lmgrd.intel
diff --git a/lang/icc7/Makefile b/lang/icc7/Makefile
index 1bb8da854a69..551a9d32d44f 100644
--- a/lang/icc7/Makefile
+++ b/lang/icc7/Makefile
@@ -7,6 +7,7 @@
PORTNAME= icc
PORTVERSION= 6.0.159
+PORTREVISION= 1
CATEGORIES= lang linux
MASTER_SITES=
DISTNAME= l_cc_pu_6.0.159
@@ -45,7 +46,7 @@ post-extract:
# intel-ecc6-6.0-159.ia64.rpm \
# intel-eldb6-6.0-228.ia64.rpm \
# intel-esubh6-6.0-159.ia64.rpm
- @cd ${WRKSRC}; rpm2cpio ${i} | cpio -idu --quiet
+ @cd ${WRKSRC}; rpm2cpio 2>/dev/null ${i} | cpio -idu --quiet
.endfor
pre-patch:
@@ -67,7 +68,7 @@ post-patch:
# Correct some paths and patch some files
.for i in ia32/bin/icc ia32/bin/icc.cfg ia32/bin/iccvars.csh \
ia32/bin/iccvars.sh ia32/bin/icpc ia32/bin/icpc.cfg docs/csupport
- @${SED} 's@export -n IA32ROOT; unset IA32ROOT;@@g; s@-a "<INSTALLDIR>/compiler60/ia32/bin/icc" @@g; s@-a "<INSTALLDIR>/compiler60/ia32/bin/icpc" @@g; s@\<INSTALLDIR\>@${PREFIX}/intel@g; s@-tp p6@@; s@man -w@manpath -q@g; s:\<INSTALLTIMECOMBOPACKAGEID\>:Intel(R) C++ Compiler for Linux:g' \
+ @${SED} 's@export -n IA32ROOT; unset IA32ROOT;@@g; s@-a "<INSTALLDIR>/compiler60/ia32/bin/icc" @@g; s@-a "<INSTALLDIR>/compiler60/ia32/bin/icpc" @@g; s@\<INSTALLDIR\>@${PREFIX}/intel@g; s@-tp p6@@; s@man -w@manpath -q@g; s:\<INSTALLTIMECOMBOPACKAGEID\>:${DISTNAME}:g' \
${WRKSRC}/opt/intel/compiler60/${i} \
>${WRKSRC}/opt/intel/compiler60/${i}.seded
@${MV} -f ${WRKSRC}/opt/intel/compiler60/${i}.seded \
@@ -80,7 +81,11 @@ post-patch:
@${RM} -rf ${WRKSRC}/opt/intel/compiler60/docs
.endif
# Provide a more FreeBSD'ish compile environment
- @${ECHO} -e "\n-Ulinux\n-U__linux__\n-U__linux\n\n-D__FreeBSD__=${ICCCFGVAL}\n-D__ELF__=1\n" >>${WRKSRC}/opt/intel/compiler60/ia32/bin/icc.cfg
+.for i in icc.cfg icpc.cfg
+ @${ECHO} -e "\n-Ulinux\n-U__linux__\n-U__linux\n\n-D__FreeBSD__=${ICCCFGVAL}\n-D__ELF__=1\n" >>${WRKSRC}/opt/intel/compiler60/ia32/bin/${i}
+ @${CHMOD} a-x,g-w ${WRKSRC}/opt/intel/compiler60/ia32/bin/${i}
+.endfor
+ @cd ${WRKSRC}/opt/intel/compiler60/ia32/bin/ && ${LN} -s icc.cfg iccbin.cfg && ${LN} -s icpc.cfg icpcbin.cfg
# \n-Qlocation,ld,/usr/bin\n\n-sox-\n
# Some magic to be able to link
@${SED} 's:@@PREFIX@@:${PREFIX}:g' ${FILESDIR}/ld >${WRKSRC}/opt/intel/compiler60/ia32/bin/ld
diff --git a/lang/icc7/pkg-plist b/lang/icc7/pkg-plist
index 7b578d4558c0..63595e62ddde 100644
--- a/lang/icc7/pkg-plist
+++ b/lang/icc7/pkg-plist
@@ -685,6 +685,7 @@ intel/compiler60/ia32/bin/INTEL
intel/compiler60/ia32/bin/icc
intel/compiler60/ia32/bin/icc.cfg
intel/compiler60/ia32/bin/iccbin
+intel/compiler60/ia32/bin/iccbin.cfg
intel/compiler60/ia32/bin/iccfilt
intel/compiler60/ia32/bin/iccvars.csh
intel/compiler60/ia32/bin/iccvars.sh
@@ -692,6 +693,7 @@ intel/compiler60/ia32/bin/icid
intel/compiler60/ia32/bin/icpc
intel/compiler60/ia32/bin/icpc.cfg
intel/compiler60/ia32/bin/icpcbin
+intel/compiler60/ia32/bin/icpcbin.cfg
intel/compiler60/ia32/bin/icpi
intel/compiler60/ia32/bin/ld
intel/compiler60/ia32/bin/lmgrd.intel