aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2010-04-19 10:43:42 +0000
committerAlex Dupre <ale@FreeBSD.org>2010-04-19 10:43:42 +0000
commitbf330a57d40cb5c6f57f61de4d24c0dcbf14dbee (patch)
treefbc3a0515acb659ae86ec22a706ac4607711c903 /lang
parent7db76e2b98b1517c19aa3a79957ac3b37bf853ae (diff)
downloadports-bf330a57d40cb5c6f57f61de4d24c0dcbf14dbee.tar.gz
ports-bf330a57d40cb5c6f57f61de4d24c0dcbf14dbee.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/ecl/Makefile4
-rw-r--r--lang/gcc/Makefile3
-rw-r--r--lang/gcc42/Makefile4
-rw-r--r--lang/gcc43/Makefile3
-rw-r--r--lang/gcc44/Makefile3
-rw-r--r--lang/gcc45/Makefile3
-rw-r--r--lang/gcc46/Makefile3
-rw-r--r--lang/gcc47/Makefile3
-rw-r--r--lang/gcc48/Makefile3
-rw-r--r--lang/gcl/Makefile4
-rw-r--r--lang/ghc/Makefile4
-rw-r--r--lang/gnat-gcc43/Makefile4
-rw-r--r--lang/gnat-gcc44/Makefile3
-rw-r--r--lang/gnat/Makefile4
-rw-r--r--lang/gnustep-base/Makefile3
-rw-r--r--lang/guile/Makefile4
-rw-r--r--lang/hs-brainfuck/Makefile3
-rw-r--r--lang/hs-unlambda/Makefile3
-rw-r--r--lang/ikarus/Makefile4
-rw-r--r--lang/librep/Makefile3
-rw-r--r--lang/maude/Makefile4
-rw-r--r--lang/mlton/Makefile4
-rw-r--r--lang/moscow_ml/Makefile4
-rw-r--r--lang/mozart/Makefile4
-rw-r--r--lang/newlisp/Makefile4
-rw-r--r--lang/ofc/Makefile4
-rw-r--r--lang/open-cobol-devel/Makefile4
-rw-r--r--lang/open-cobol/Makefile4
-rw-r--r--lang/parrot/Makefile3
-rw-r--r--lang/php4/Makefile.ext2
-rw-r--r--lang/php5/Makefile.ext2
-rw-r--r--lang/php53/Makefile.ext2
-rw-r--r--lang/pike72/Makefile4
-rw-r--r--lang/pike76/Makefile4
-rw-r--r--lang/pike78/Makefile4
-rw-r--r--lang/q/Makefile4
-rw-r--r--lang/qscheme/Makefile4
-rw-r--r--lang/stklos/Makefile4
-rw-r--r--lang/swi-pl/Makefile3
-rw-r--r--lang/whitespace/Makefile4
40 files changed, 77 insertions, 63 deletions
diff --git a/lang/ecl/Makefile b/lang/ecl/Makefile
index 1e7aff12dd26..1e7f405dc655 100644
--- a/lang/ecl/Makefile
+++ b/lang/ecl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ecl
PORTVERSION= 0.9l
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang lisp
MASTER_SITES= SF/${PORTNAME}s/${PORTNAME}s/${PORTVERSION}
EXTRACT_SUFX= .tgz
@@ -15,7 +15,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= olgeni@FreeBSD.org
COMMENT= An ANSI Common Lisp implementation
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 gc.1:${PORTSDIR}/devel/boehm-gc
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp gc.1:${PORTSDIR}/devel/boehm-gc
USE_GMAKE= yes
USE_PERL5_BUILD=yes
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index 3017ada4b2c8..7c640eb44d15 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.5.1.20100415
+PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -18,7 +19,7 @@ DISTFILES= gcc-core-${VERSIONSTRING}${EXTRACT_SUFX} \
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.5
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
mpfr.3:${PORTSDIR}/math/mpfr \
mpc.2:${PORTSDIR}/math/mpc
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
diff --git a/lang/gcc42/Makefile b/lang/gcc42/Makefile
index 19b8c90409aa..5cada080983f 100644
--- a/lang/gcc42/Makefile
+++ b/lang/gcc42/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.2.5.20090325
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -19,7 +19,7 @@ DISTFILES= gcc-core-${VERSIONSTRING}${EXTRACT_SUFX} \
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.2
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
mpfr.3:${PORTSDIR}/math/mpfr
VERSIONSTRING= ${PORTVERSION:C/([0-9]+\.[0-9]+).*\.([0-9]+)/\1-\2/}
diff --git a/lang/gcc43/Makefile b/lang/gcc43/Makefile
index 74d59f13c6e2..67a5986a757d 100644
--- a/lang/gcc43/Makefile
+++ b/lang/gcc43/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.3.5.20100404
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -17,7 +18,7 @@ DISTFILES= gcc-core-${VERSIONSTRING}${EXTRACT_SUFX} \
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.3
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
mpfr.3:${PORTSDIR}/math/mpfr
.if defined(MAINTAINER_MODE)
diff --git a/lang/gcc44/Makefile b/lang/gcc44/Makefile
index 239b384c0d99..e40d4ea495d1 100644
--- a/lang/gcc44/Makefile
+++ b/lang/gcc44/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.4.4.20100413
+PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -18,7 +19,7 @@ DISTFILES= gcc-core-${VERSIONSTRING}${EXTRACT_SUFX} \
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.4
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
mpfr.3:${PORTSDIR}/math/mpfr
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
RUN_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
diff --git a/lang/gcc45/Makefile b/lang/gcc45/Makefile
index 3017ada4b2c8..7c640eb44d15 100644
--- a/lang/gcc45/Makefile
+++ b/lang/gcc45/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.5.1.20100415
+PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -18,7 +19,7 @@ DISTFILES= gcc-core-${VERSIONSTRING}${EXTRACT_SUFX} \
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.5
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
mpfr.3:${PORTSDIR}/math/mpfr \
mpc.2:${PORTSDIR}/math/mpc
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
diff --git a/lang/gcc46/Makefile b/lang/gcc46/Makefile
index 3017ada4b2c8..7c640eb44d15 100644
--- a/lang/gcc46/Makefile
+++ b/lang/gcc46/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.5.1.20100415
+PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -18,7 +19,7 @@ DISTFILES= gcc-core-${VERSIONSTRING}${EXTRACT_SUFX} \
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.5
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
mpfr.3:${PORTSDIR}/math/mpfr \
mpc.2:${PORTSDIR}/math/mpc
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index 3017ada4b2c8..7c640eb44d15 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.5.1.20100415
+PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -18,7 +19,7 @@ DISTFILES= gcc-core-${VERSIONSTRING}${EXTRACT_SUFX} \
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.5
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
mpfr.3:${PORTSDIR}/math/mpfr \
mpc.2:${PORTSDIR}/math/mpc
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index 3017ada4b2c8..7c640eb44d15 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.5.1.20100415
+PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -18,7 +19,7 @@ DISTFILES= gcc-core-${VERSIONSTRING}${EXTRACT_SUFX} \
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.5
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
mpfr.3:${PORTSDIR}/math/mpfr \
mpc.2:${PORTSDIR}/math/mpc
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
diff --git a/lang/gcl/Makefile b/lang/gcl/Makefile
index 6c46c20ff007..295d22348778 100644
--- a/lang/gcl/Makefile
+++ b/lang/gcl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gcl
PORTVERSION= 2.6.7
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= lang tcl tk
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gcl
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= gcl
MAINTAINER= ports@FreeBSD.org
COMMENT= GNU Common Lisp
-LIB_DEPENDS= gmp:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp
ONLY_FOR_ARCHS= i386
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index c9690ba25e48..ad41848ff0d5 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -6,7 +6,7 @@
PORTNAME= ghc
PORTVERSION= 6.10.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang haskell
MASTER_SITES= http://www.haskell.org/ghc/dist/${PORTVERSION}/:source \
${MASTER_SITE_LOCAL:S/$/:boot/} \
@@ -31,7 +31,7 @@ GHCPATH_VERSION= 0.1.0.5
USE_AUTOTOOLS= autoconf:262:env
USE_BZIP2= yes
-LIB_DEPENDS+= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS+= gmp.10:${PORTSDIR}/math/gmp
USE_PERL5= yes
USE_GMAKE= yes
diff --git a/lang/gnat-gcc43/Makefile b/lang/gnat-gcc43/Makefile
index bdd94cd2a5e3..2830f3574b3d 100644
--- a/lang/gnat-gcc43/Makefile
+++ b/lang/gnat-gcc43/Makefile
@@ -9,7 +9,7 @@
PORTNAME= gnat-gcc
PORTVERSION= 4.3.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang
MASTER_SITES= GCC/releases/gcc-${PORTVERSION} \
CENKES:boot \
@@ -22,7 +22,7 @@ DISTFILES= gcc-core-${PORTVERSION}${EXTRACT_SUFX} \
MAINTAINER= karel@lovetemple.net
COMMENT= The GNU Ada Compiler system
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
mpfr.3:${PORTSDIR}/math/mpfr
ONLY_FOR_ARCHS= i386
diff --git a/lang/gnat-gcc44/Makefile b/lang/gnat-gcc44/Makefile
index b77765573195..e915be099e2e 100644
--- a/lang/gnat-gcc44/Makefile
+++ b/lang/gnat-gcc44/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gnat-gcc
PORTVERSION= 4.4.0
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= GCC/releases/gcc-${PORTVERSION} \
http://coreland.ath.cx/data/code/gnatport/src/:boot
@@ -19,7 +20,7 @@ DISTFILES= gcc-core-${PORTVERSION}${EXTRACT_SUFX} \
MAINTAINER= freebsd-ports@coreland.ath.cx
COMMENT= The GNU Ada Compiler system
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
mpfr.3:${PORTSDIR}/math/mpfr
ONLY_FOR_ARCHS= i386 amd64
diff --git a/lang/gnat/Makefile b/lang/gnat/Makefile
index 216e7a0ddea1..77603b43843e 100644
--- a/lang/gnat/Makefile
+++ b/lang/gnat/Makefile
@@ -14,7 +14,7 @@
PORTNAME= gnat
PORTVERSION= 2009
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_LOCAL}:boot
MASTER_SITE_SUBDIR= deischen/gcc/:boot
@@ -23,7 +23,7 @@ DISTFILES= ${gcc_srcfile}:gcc ${gnat_srcfile}:gnat
MAINTAINER= eischen@vigrid.com
COMMENT= The GNU Ada Compiler system
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
mpfr.3:${PORTSDIR}/math/mpfr
ONLY_FOR_ARCHS= i386
diff --git a/lang/gnustep-base/Makefile b/lang/gnustep-base/Makefile
index 194b17d79116..5ec43a01b6a8 100644
--- a/lang/gnustep-base/Makefile
+++ b/lang/gnustep-base/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnustep-base
PORTVERSION= 1.19.3
+PORTREVISION= 1
CATEGORIES= lang devel gnustep
MASTER_SITES= ${MASTER_SITE_GNUSTEP}
MASTER_SITE_SUBDIR= core
@@ -16,7 +17,7 @@ COMMENT= GNUstep Foundation library
LIB_DEPENDS+= xml2.5:${PORTSDIR}/textproc/libxml2
LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
-LIB_DEPENDS+= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS+= gmp.10:${PORTSDIR}/math/gmp
USE_AUTOTOOLS= autoconf:262
GNU_CONFIGURE= yes
diff --git a/lang/guile/Makefile b/lang/guile/Makefile
index 412737594d34..c4d90a90bec0 100644
--- a/lang/guile/Makefile
+++ b/lang/guile/Makefile
@@ -7,7 +7,7 @@
PORTNAME= guile
PORTVERSION= 1.8.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang scheme
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= guile
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= guile
MAINTAINER= amatus@gnu.org
COMMENT= GNU Ubiquitous Intelligent Language for Extension
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
USE_AUTOTOOLS= autoconf:262 libltdl:22
USE_GMAKE= yes
diff --git a/lang/hs-brainfuck/Makefile b/lang/hs-brainfuck/Makefile
index 3e463647f0ff..27766814e370 100644
--- a/lang/hs-brainfuck/Makefile
+++ b/lang/hs-brainfuck/Makefile
@@ -7,6 +7,7 @@
PORTNAME= brainfuck
PORTVERSION= 0.1
+PORTREVISION= 1
CATEGORIES= lang haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
PKGNAMEPREFIX= hs-
@@ -16,7 +17,7 @@ COMMENT= Brainfuck interpreter written in Haskell
BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
GHC_VERSION= 6.10.4
BRAINFUCK_VERSION= ${PORTVERSION}
diff --git a/lang/hs-unlambda/Makefile b/lang/hs-unlambda/Makefile
index 7c3db24bcb12..790aeae9a7bc 100644
--- a/lang/hs-unlambda/Makefile
+++ b/lang/hs-unlambda/Makefile
@@ -7,6 +7,7 @@
PORTNAME= unlambda
PORTVERSION= 0.1
+PORTREVISION= 1
CATEGORIES= lang haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
PKGNAMEPREFIX= hs-
@@ -16,7 +17,7 @@ COMMENT= Unlambda interpreter written in Haskell
BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
GHC_VERSION= 6.10.4
UNLAMBDA_VERSION= ${PORTVERSION}
diff --git a/lang/ikarus/Makefile b/lang/ikarus/Makefile
index de7a6c1182b6..62e96d27e729 100644
--- a/lang/ikarus/Makefile
+++ b/lang/ikarus/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ikarus
PORTVERSION= 0.0.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang scheme
MASTER_SITES= http://www.ikarus-scheme.org/ \
LOCAL/glarkin
@@ -15,7 +15,7 @@ MASTER_SITES= http://www.ikarus-scheme.org/ \
MAINTAINER= vmagerya@gmail.com
COMMENT= Optimizing incremental native-code compiler for R6RS Scheme
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/lang/librep/Makefile b/lang/librep/Makefile
index 183b13372d3b..edaa85b5c131 100644
--- a/lang/librep/Makefile
+++ b/lang/librep/Makefile
@@ -7,6 +7,7 @@
PORTNAME= librep
PORTVERSION= 0.90.2
+PORTREVISION= 1
CATEGORIES= lang elisp gnome
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
@@ -14,7 +15,7 @@ MAINTAINER= anray@FreeBSD.org
COMMENT= An Emacs Lisp like runtime library
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm \
- gmp.8:${PORTSDIR}/math/libgmp4 \
+ gmp.10:${PORTSDIR}/math/gmp \
ffi.5:${PORTSDIR}/devel/libffi
RUN_DEPENDS= gtar:${PORTSDIR}/archivers/gtar
diff --git a/lang/maude/Makefile b/lang/maude/Makefile
index 74378f054149..c3a24df59159 100644
--- a/lang/maude/Makefile
+++ b/lang/maude/Makefile
@@ -7,7 +7,7 @@
PORTNAME= maude
PORTVERSION= 2.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= http://maude.cs.uiuc.edu/versions/${PORTVERSION}/
DISTNAME= Maude-${PORTVERSION}
@@ -17,7 +17,7 @@ COMMENT= A high-performance reflective language
LIB_DEPENDS= bdd:${PORTSDIR}/science/buddy \
tecla:${PORTSDIR}/devel/libtecla \
- gmp:${PORTSDIR}/math/libgmp4
+ gmp:${PORTSDIR}/math/gmp
USE_BISON= build
USE_AUTOTOOLS= aclocal:19 automake:19
diff --git a/lang/mlton/Makefile b/lang/mlton/Makefile
index 2dddefd7545c..fdeb7a7f89e9 100644
--- a/lang/mlton/Makefile
+++ b/lang/mlton/Makefile
@@ -12,7 +12,7 @@
PORTNAME= mlton
PORTVERSION= 20070826
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= lang
MASTER_SITES= http://mlton.org/pages/Download/attachments/ \
http://mlton.org/pages/Experimental/attachments/ \
@@ -24,7 +24,7 @@ EXTRACT_ONLY= ${SRC_DIST}
MAINTAINER= jesper.louis.andersen@gmail.com
COMMENT= An optimizing Standard ML compiler
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
diff --git a/lang/moscow_ml/Makefile b/lang/moscow_ml/Makefile
index 7a4ded2c176f..620146f066a9 100644
--- a/lang/moscow_ml/Makefile
+++ b/lang/moscow_ml/Makefile
@@ -7,7 +7,7 @@
PORTNAME= moscow_ml
PORTVERSION= 2.01
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang
MASTER_SITES= http://www.dina.kvl.dk/~sestoft/mosml/
DISTNAME= mos201src
@@ -15,7 +15,7 @@ DISTNAME= mos201src
MAINTAINER= johans@FreeBSD.org
COMMENT= Moscow ML, a lightweight implementation of Standard ML
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
gdbm.3:${PORTSDIR}/databases/gdbm
RESTRICTED= Restrictions on for-profit distribution.
diff --git a/lang/mozart/Makefile b/lang/mozart/Makefile
index bdb7f27ebdac..11263d248a6e 100644
--- a/lang/mozart/Makefile
+++ b/lang/mozart/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mozart
PORTVERSION= 1.3.1.20040616
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= lang tk parallel
MASTER_SITES= http://www.mozart-oz.org/download/mozart-ftp/store/1.3.1-2004-06-16/
DISTFILES= ${DISTNAME}-src.tar.gz
@@ -20,7 +20,7 @@ COMMENT= A distributed language with constraint-based inference
BUILD_DEPENDS= emacs:${PORTSDIR}/editors/emacs
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm \
- gmp.8:${PORTSDIR}/math/libgmp4 \
+ gmp.10:${PORTSDIR}/math/gmp \
tk84.1:${PORTSDIR}/x11-toolkits/tk84
MOZART_DOCS= mozart-${PORTVERSION}-doc.tar.gz
diff --git a/lang/newlisp/Makefile b/lang/newlisp/Makefile
index 54ffc15482dc..30bb98aef481 100644
--- a/lang/newlisp/Makefile
+++ b/lang/newlisp/Makefile
@@ -8,7 +8,7 @@
PORTNAME= newlisp
PORTVERSION= 10.2.1
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://www.newlisp.org/downloads/
#MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
@@ -45,7 +45,7 @@ CFLAGS+= -DNEWLISP64
.endif
.if defined(WITH_GMP)
-LIB_DEPENDS+= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS+= gmp.10:${PORTSDIR}/math/gmp
MODULES+= gmp
PLIST_SUB+= GMP=""
.else
diff --git a/lang/ofc/Makefile b/lang/ofc/Makefile
index e0a3172f887a..7f5b744fb3ef 100644
--- a/lang/ofc/Makefile
+++ b/lang/ofc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ofc
PORTVERSION= 0.8.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang
MASTER_SITES= http://ofc.dvoudheusden.net/download/
@@ -35,7 +35,7 @@ LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
.endif
.if defined (WITH_GMP)
-LIB_DEPENDS+= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS+= gmp.10:${PORTSDIR}/math/gmp
.endif
.include <bsd.port.mk>
diff --git a/lang/open-cobol-devel/Makefile b/lang/open-cobol-devel/Makefile
index bd93e673e7d8..1f56d177dbff 100644
--- a/lang/open-cobol-devel/Makefile
+++ b/lang/open-cobol-devel/Makefile
@@ -6,14 +6,14 @@
PORTNAME= open-cobol
PORTVERSION= 1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= http://freebsd.dev-urandom.com/open-cobol/
MAINTAINER= glen.j.barber@gmail.com
COMMENT= An open-source COBOL compiler
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
CONFLICTS= open-cobol-1.[0]*
diff --git a/lang/open-cobol/Makefile b/lang/open-cobol/Makefile
index 11d6a1b65453..cd3b16d83aa2 100644
--- a/lang/open-cobol/Makefile
+++ b/lang/open-cobol/Makefile
@@ -8,14 +8,14 @@
PORTNAME= open-cobol
PORTVERSION= 1.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang
MASTER_SITES= SF
MAINTAINER= glen.j.barber@gmail.com
COMMENT= An open-source COBOL compiler
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
CONFLICTS= open-cobol-1.[1]*
diff --git a/lang/parrot/Makefile b/lang/parrot/Makefile
index efa25624bc95..7981b116af73 100644
--- a/lang/parrot/Makefile
+++ b/lang/parrot/Makefile
@@ -7,6 +7,7 @@
PORTNAME= parrot
PORTVERSION= ${PARROT_VERSION}
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= ftp://ftp.parrot.org/pub/parrot/releases/devel/${PORTVERSION}/
@@ -16,7 +17,7 @@ COMMENT= Parrot - virtual machine for dynamic languages
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
${LOCALBASE}/bin/pcre-config:${PORTSDIR}/devel/pcre
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
icudata.38:${PORTSDIR}/devel/icu
MAKE_JOBS_UNSAFE= yes
diff --git a/lang/php4/Makefile.ext b/lang/php4/Makefile.ext
index df6604a30124..1857c04c1133 100644
--- a/lang/php4/Makefile.ext
+++ b/lang/php4/Makefile.ext
@@ -125,7 +125,7 @@ USE_GETTEXT= yes
.endif
.if ${PHP_MODNAME} == "gmp"
-LIB_DEPENDS+= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS+= gmp.10:${PORTSDIR}/math/gmp
CONFIGURE_ARGS+=--with-gmp=${LOCALBASE}
.endif
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 72b30400e301..498cf0a677fd 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -105,7 +105,7 @@ USE_GETTEXT= yes
.endif
.if ${PHP_MODNAME} == "gmp"
-LIB_DEPENDS+= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS+= gmp.10:${PORTSDIR}/math/gmp
CONFIGURE_ARGS+=--with-gmp=${LOCALBASE}
.endif
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index 72b30400e301..498cf0a677fd 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -105,7 +105,7 @@ USE_GETTEXT= yes
.endif
.if ${PHP_MODNAME} == "gmp"
-LIB_DEPENDS+= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS+= gmp.10:${PORTSDIR}/math/gmp
CONFIGURE_ARGS+=--with-gmp=${LOCALBASE}
.endif
diff --git a/lang/pike72/Makefile b/lang/pike72/Makefile
index ce20913ad43f..ad88f99eb7ca 100644
--- a/lang/pike72/Makefile
+++ b/lang/pike72/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pike72
PORTVERSION= 7.2.570
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= lang
MASTER_SITES= ftp://ftp.oav.net/pike/7.2/unofficial/ \
ftp://ftp.us.caudium.net/pub/pike/7.2/unofficial/
@@ -20,7 +20,7 @@ LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \
gdbm.3:${PORTSDIR}/databases/gdbm \
mird.1:${PORTSDIR}/databases/mird \
- gmp.8:${PORTSDIR}/math/libgmp4
+ gmp.10:${PORTSDIR}/math/gmp
DEPRECATED= No longer maintained upstream, consider switching \
to a more modern version: lang/pike76 or lang/pike78
diff --git a/lang/pike76/Makefile b/lang/pike76/Makefile
index c861358843b4..b33db6fc90bd 100644
--- a/lang/pike76/Makefile
+++ b/lang/pike76/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pike76
PORTVERSION= 7.6.112
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= lang
MASTER_SITES= ftp://pike.ida.liu.se/pub/pike/beta/${PORTVERSION}/ \
http://pike.ida.liu.se/pub/pike/beta/${PORTVERSION}/ \
@@ -25,7 +25,7 @@ LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
gdbm.3:${PORTSDIR}/databases/gdbm \
pcre.0:${PORTSDIR}/devel/pcre \
mird.1:${PORTSDIR}/databases/mird \
- gmp.8:${PORTSDIR}/math/libgmp4
+ gmp.10:${PORTSDIR}/math/gmp
CONFLICTS= pike7[28]-[0-9]*
diff --git a/lang/pike78/Makefile b/lang/pike78/Makefile
index e21d0437dce6..1625f648030f 100644
--- a/lang/pike78/Makefile
+++ b/lang/pike78/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pike78
PORTVERSION= 7.8.352
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang
MASTER_SITES= ftp://pike.ida.liu.se/pub/pike/all/${PORTVERSION}/ \
http://pike.ida.liu.se/pub/pike/all/${PORTVERSION}/ \
@@ -25,7 +25,7 @@ LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
pcre.0:${PORTSDIR}/devel/pcre \
nettle.3:${PORTSDIR}/security/nettle \
mird.1:${PORTSDIR}/databases/mird \
- gmp.8:${PORTSDIR}/math/libgmp4
+ gmp.10:${PORTSDIR}/math/gmp
CONFLICTS= pike7[26]-[0-9]*
diff --git a/lang/q/Makefile b/lang/q/Makefile
index 7c73ba94e073..9c51e05d73f2 100644
--- a/lang/q/Makefile
+++ b/lang/q/Makefile
@@ -7,7 +7,7 @@
PORTNAME= q
PORTVERSION= 7.11
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= lang
MASTER_SITES= SF/${PORTNAME}-lang/${PORTNAME}/${PORTVERSION}
@@ -18,7 +18,7 @@ LIB_DEPENDS= MagickWand.3:${PORTSDIR}/graphics/ImageMagick \
curl.6:${PORTSDIR}/ftp/curl \
freetype.9:${PORTSDIR}/print/freetype2 \
gdbm.3:${PORTSDIR}/databases/gdbm \
- gmp.8:${PORTSDIR}/math/libgmp4 \
+ gmp.10:${PORTSDIR}/math/gmp \
iodbc.3:${PORTSDIR}/databases/libiodbc \
xml2.5:${PORTSDIR}/textproc/libxml2 \
xslt.2:${PORTSDIR}/textproc/libxslt \
diff --git a/lang/qscheme/Makefile b/lang/qscheme/Makefile
index 8197ec67f65f..005502d70e3f 100644
--- a/lang/qscheme/Makefile
+++ b/lang/qscheme/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qscheme
PORTVERSION= 0.5.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= lang scheme
MASTER_SITES= http://www.sof.ch/dan/qscheme/files/
@@ -16,7 +16,7 @@ COMMENT= A small and fast Scheme interpreter
BUILD_DEPENDS= ${LOCALBASE}/lib/libavcall.a:${PORTSDIR}/devel/ffcall\
${LOCALBASE}/lib/libpcre.a:${PORTSDIR}/devel/pcre \
- ${LOCALBASE}/lib/libgmp.a:${PORTSDIR}/math/libgmp4
+ ${LOCALBASE}/lib/libgmp.a:${PORTSDIR}/math/gmp
LIB_DEPENDS= getline:${PORTSDIR}/devel/libgetline
GNU_CONFIGURE= yes
diff --git a/lang/stklos/Makefile b/lang/stklos/Makefile
index c3e7194b6d73..51d88384c37c 100644
--- a/lang/stklos/Makefile
+++ b/lang/stklos/Makefile
@@ -7,7 +7,7 @@
PORTNAME= stklos
PORTVERSION= 0.98
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang scheme
MASTER_SITES= http://www.stklos.net/download/ \
ftp://kaolin.essi.fr/pub/STklos/
@@ -15,7 +15,7 @@ MASTER_SITES= http://www.stklos.net/download/ \
MAINTAINER= vmagerya@gmail.com
COMMENT= The successor of the STk Scheme interpreter
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
pcre.0:${PORTSDIR}/devel/pcre \
ffi.5:${PORTSDIR}/devel/libffi \
gc.1:${PORTSDIR}/devel/boehm-gc-threaded
diff --git a/lang/swi-pl/Makefile b/lang/swi-pl/Makefile
index 7cfa29198725..4a56ccf61ba2 100644
--- a/lang/swi-pl/Makefile
+++ b/lang/swi-pl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= swi-pl
PORTVERSION= 5.8.3
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://www.swi-prolog.org/download/stable/src/
DISTNAME= pl-${PORTVERSION}
@@ -14,7 +15,7 @@ DISTNAME= pl-${PORTVERSION}
MAINTAINER= g.gonter@ieee.org
COMMENT= Edinburgh-style Prolog compiler
-LIB_DEPENDS= gmp:${PORTSDIR}/math/libgmp4 \
+LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp \
readline:${PORTSDIR}/devel/readline
LIB_DEPENDS+= odbc:${PORTSDIR}/databases/unixODBC
diff --git a/lang/whitespace/Makefile b/lang/whitespace/Makefile
index 9561e9579515..f4ff953863e8 100644
--- a/lang/whitespace/Makefile
+++ b/lang/whitespace/Makefile
@@ -7,7 +7,7 @@
PORTNAME= whitespace
PORTVERSION= 0.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang
MASTER_SITES= http://compsoc.dur.ac.uk/whitespace/downloads/
DISTNAME= wspace-${PORTVERSION}
@@ -17,7 +17,7 @@ MAINTAINER= llwang@infor.org
COMMENT= An interpreter for the Whitespace programming language
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
WRKSRC= ${WRKDIR}/WSpace
USE_GMAKE= yes