aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-31 23:00:21 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-31 23:00:21 +0000
commit6bd407bcb28be2c7e1b7d43f1e42ce56a2987e31 (patch)
treee8003e288b2d932ecbe7735ef2d7e89c6cbbaae3 /lang
parentd1735b853f799f19085da4327b342b0130b3dc6b (diff)
downloadports-6bd407bcb28be2c7e1b7d43f1e42ce56a2987e31.tar.gz
ports-6bd407bcb28be2c7e1b7d43f1e42ce56a2987e31.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/php4-extensions/Makefile5
-rw-r--r--lang/php4/Makefile.ext5
2 files changed, 8 insertions, 2 deletions
diff --git a/lang/php4-extensions/Makefile b/lang/php4-extensions/Makefile
index 85934c081e80..f0b429dfb820 100644
--- a/lang/php4-extensions/Makefile
+++ b/lang/php4-extensions/Makefile
@@ -74,6 +74,7 @@ OPTIONS= BCMATH "bc style precision math functions" off \
PCNTL "pcntl support (CLI only)" off \
PCRE "Perl Compatible Regular Expression support" on \
PDF "PDFlib support (implies GD)" off \
+ PFPRO "PayFlow Pro support" off \
PGSQL "PostgreSQL database support" off \
POSIX "POSIX-like functions" on \
PSPELL "pspell support" off \
@@ -109,8 +110,8 @@ ALL_OPTIONS= BCMATH BZ2 CALENDAR CRACK CTYPE CURL DBA DBASE DBX DIO \
DOMXML EXIF FILEINFO FILEPRO FRIBIDI FTP GD GETTEXT \
GMP ICONV IMAGICK IMAP INTERBASE LDAP MBSTRING MCAL MCRYPT \
MCVE MHASH MIME_MAGIC MING MNOGOSEARCH MSSQL MYSQL NCURSES \
- ODBC OPENSSL ORACLE OVERLOAD PANDA PCNTL PCRE PDF PGSQL POSIX \
- PSPELL READLINE RECODE SESSION SHMOP SNMP SOCKETS \
+ ODBC OPENSSL ORACLE OVERLOAD PANDA PCNTL PCRE PDF PFPRO \
+ PGSQL POSIX PSPELL READLINE RECODE SESSION SHMOP SNMP SOCKETS \
SYBASE_CT SYSVMSG SYSVSEM SYSVSHM TOKENIZER \
WDDX XML XMLRPC XSLT YAZ YP ZIP ZLIB
diff --git a/lang/php4/Makefile.ext b/lang/php4/Makefile.ext
index fe616c381db6..830e33195f37 100644
--- a/lang/php4/Makefile.ext
+++ b/lang/php4/Makefile.ext
@@ -262,6 +262,11 @@ CONFIGURE_ARGS+=--with-pcre-regex=yes
PHP_HEADER_DIRS=pcrelib
.endif
+.if ${PHP_MODNAME} == "pfpro"
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libpfpro.so:${PORTSDIR}/finance/pfpro
+CONFIGURE_ARGS+=--with-pfpro
+.endif
+
.if ${PHP_MODNAME} == "pgsql"
USE_PGSQL= YES