aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2006-01-31 08:36:02 +0000
committerAlex Dupre <ale@FreeBSD.org>2006-01-31 08:36:02 +0000
commitfae3e9d08c906a914aee57d04ac75d21f05b0dfc (patch)
treed2c9d7ad43c90d3661ab1c9196a242db5d1fcc90 /lang
parent676db5a9e0b9c675082cd4dd7a0a977333b5e737 (diff)
downloadports-fae3e9d08c906a914aee57d04ac75d21f05b0dfc.tar.gz
ports-fae3e9d08c906a914aee57d04ac75d21f05b0dfc.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/php4/Makefile4
-rw-r--r--lang/php5/Makefile4
-rw-r--r--lang/php53/Makefile4
3 files changed, 9 insertions, 3 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index a32ca430af68..f0f8d5adad77 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -104,9 +104,11 @@ CONFIGURE_ARGS+=--disable-cgi
.include <bsd.port.pre.mk>
-CONFIGURE_ENV= ac_cv_pthreads_lib=${PTHREAD_LIBS} \
+CONFIGURE_ENV+= ac_cv_pthreads_lib=${PTHREAD_LIBS} \
ac_cv_pthreads_cflags=${PTHREAD_CFLAGS}
+MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+
.if defined(WITH_OPENSSL)
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE} \
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 4e33af8a9dca..fd677ae1c48e 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -109,9 +109,11 @@ CONFIGURE_ARGS+=--disable-cgi
.include <bsd.port.pre.mk>
-CONFIGURE_ENV= ac_cv_pthreads_lib=${PTHREAD_LIBS} \
+CONFIGURE_ENV+= ac_cv_pthreads_lib=${PTHREAD_LIBS} \
ac_cv_pthreads_cflags=${PTHREAD_CFLAGS}
+MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+
.if defined(WITH_APACHE)
.if ${APACHE_VERSION} > 13
CONFIGURE_ARGS+=--with-apxs2=${APXS}
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index 4e33af8a9dca..fd677ae1c48e 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -109,9 +109,11 @@ CONFIGURE_ARGS+=--disable-cgi
.include <bsd.port.pre.mk>
-CONFIGURE_ENV= ac_cv_pthreads_lib=${PTHREAD_LIBS} \
+CONFIGURE_ENV+= ac_cv_pthreads_lib=${PTHREAD_LIBS} \
ac_cv_pthreads_cflags=${PTHREAD_CFLAGS}
+MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+
.if defined(WITH_APACHE)
.if ${APACHE_VERSION} > 13
CONFIGURE_ARGS+=--with-apxs2=${APXS}