aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2010-10-07 08:44:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2010-10-07 08:44:28 +0000
commit07a59f75b400551a003edaa6b69d6512f91b1747 (patch)
treee9de07b23ee275f8ffb39f12edcd3ce840eb3f65 /lang
parentc7479bd663e59daa503276a1dfe659718ec09c39 (diff)
downloadports-07a59f75b400551a003edaa6b69d6512f91b1747.tar.gz
ports-07a59f75b400551a003edaa6b69d6512f91b1747.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/gnustep-libobjc/Makefile30
-rw-r--r--lang/gnustep-libobjc/distinfo3
-rw-r--r--lang/gnustep-libobjc/pkg-descr22
-rw-r--r--lang/gnustep-libobjc/pkg-plist18
5 files changed, 74 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 7ef60fa0c16d..b5756e39f30f 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -112,6 +112,7 @@
SUBDIR += gnat-gcc44
SUBDIR += gnustep-base
SUBDIR += gnustep-guile
+ SUBDIR += gnustep-libobjc
SUBDIR += gnustep-objc
SUBDIR += go
SUBDIR += gpc
diff --git a/lang/gnustep-libobjc/Makefile b/lang/gnustep-libobjc/Makefile
new file mode 100644
index 000000000000..b582ae74f84c
--- /dev/null
+++ b/lang/gnustep-libobjc/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: libobjc2
+# Date created: 06 Octil 2010
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= libobjc2
+PORTVERSION= 1.0
+CATEGORIES= lang devel gnustep
+MASTER_SITES= http://download.gna.org/gnustep/
+PKGNAMEPREFIX= gnustep-
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= GNUstep Objective-C runtime for GCC and LLVM
+
+LICENSE= MIT
+
+USE_BZIP2= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+GNUSTEP_WITHOUT_LIBOBJC= yes
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKE_ENV+= GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
+DEFAULT_LIBVERSION= 4
+
+.include <bsd.port.mk>
diff --git a/lang/gnustep-libobjc/distinfo b/lang/gnustep-libobjc/distinfo
new file mode 100644
index 000000000000..3204f9a8a393
--- /dev/null
+++ b/lang/gnustep-libobjc/distinfo
@@ -0,0 +1,3 @@
+MD5 (libobjc2-1.0.tar.bz2) = 0d6c683f765c43721f3d6f83d7df4921
+SHA256 (libobjc2-1.0.tar.bz2) = 8903157a6fe6b82b4571a33855f98e0da0fe92a94f69a9a5edd1af94310f0566
+SIZE (libobjc2-1.0.tar.bz2) = 66560
diff --git a/lang/gnustep-libobjc/pkg-descr b/lang/gnustep-libobjc/pkg-descr
new file mode 100644
index 000000000000..8906ef33d507
--- /dev/null
+++ b/lang/gnustep-libobjc/pkg-descr
@@ -0,0 +1,22 @@
+GNUstep Objective-C Runtime
+
+The GNUstep Objective-C runtime is designed as a drop-in replacement for the
+GCC runtime. It supports both a legacy and a modern ABI, allowing code
+compiled with old versions of GCC to be supported without requiring
+recompilation. The modern ABI adds the following features:
+- Non-fragile instance variables.
+- Protocol uniquing.
+- Object planes support.
+- Declared property introspection.
+
+Both ABIs support the following feature above and beyond the GCC runtime:
+- The modern Objective-C runtime APIs, introduced with OS X 10.5.
+- Blocks (closures).
+- Low memory profile for platforms where memory usage is more important than
+ speed.
+- Synthesised property accessors.
+- Efficient support for @synchronized()
+- Type-dependent dispatch, eliminating stack corruption from mismatched
+ selectors.
+
+LICENSE: MIT
diff --git a/lang/gnustep-libobjc/pkg-plist b/lang/gnustep-libobjc/pkg-plist
new file mode 100644
index 000000000000..90c6c01b286b
--- /dev/null
+++ b/lang/gnustep-libobjc/pkg-plist
@@ -0,0 +1,18 @@
+GNUstep/System/Library/Headers/objc/Availability.h
+GNUstep/System/Library/Headers/objc/Object.h
+GNUstep/System/Library/Headers/objc/Protocol.h
+GNUstep/System/Library/Headers/objc/blocks_runtime.h
+GNUstep/System/Library/Headers/objc/capabilities.h
+GNUstep/System/Library/Headers/objc/encoding.h
+GNUstep/System/Library/Headers/objc/hooks.h
+GNUstep/System/Library/Headers/objc/objc-api.h
+GNUstep/System/Library/Headers/objc/objc.h
+GNUstep/System/Library/Headers/objc/runtime.h
+GNUstep/System/Library/Headers/objc/slot.h
+GNUstep/System/Library/Headers/toydispatch/toydispatch.h
+GNUstep/System/Library/Libraries/libobjc.so
+GNUstep/System/Library/Libraries/libobjc.so.%%MAJORLIBVERSION%%
+GNUstep/System/Library/Libraries/libtoydispatch.so
+GNUstep/System/Library/Libraries/libtoydispatch.so.%%MAJORVERSION%%
+@dirrm GNUstep/System/Library/Headers/toydispatch
+@dirrm GNUstep/System/Library/Headers/objc