aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2005-03-15 03:05:04 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2005-03-15 03:05:04 +0000
commit9be610132750ecb41f99e84d7f98dc7370f2d66c (patch)
tree2218b0ded6929ee04b45adfac1d86add015793a7 /lang
parenta3d0dcae3f4a81e3a8cb889b97409a41db13b6d9 (diff)
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/pugs/Makefile49
-rw-r--r--lang/pugs/distinfo2
-rw-r--r--lang/pugs/pkg-descr5
-rw-r--r--lang/pugs/pkg-plist14
5 files changed, 71 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 601bcb48f65b..146392816f5d 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -199,6 +199,7 @@
SUBDIR += pnetc
SUBDIR += pnetlib
SUBDIR += ptoc
+ SUBDIR += pugs
SUBDIR += py-compiler
SUBDIR += py-mx-base
SUBDIR += py-prolog
diff --git a/lang/pugs/Makefile b/lang/pugs/Makefile
new file mode 100644
index 000000000000..477a08ada4e6
--- /dev/null
+++ b/lang/pugs/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: lang/pugs
+# Date created: Mon Mar 14 16:01:08 CST 2005
+# Whom: clsung
+#
+# $FreeBSD$
+#
+
+PORTNAME= pugs
+PORTVERSION= 6.0.11
+CATEGORIES= lang devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/A/AU/AUTRIJUS
+DISTNAME= Perl6-Pugs-${PORTVERSION}
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= A Perl6 Implementation
+
+RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
+ ${SITE_PERL}/${PERL_ARCH}/Term/ReadLine/Gnu.pm:${PORTSDIR}/devel/p5-ReadLine-Gnu
+BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+
+PERL_CONFIGURE= yes
+
+MAN3= Perl6::Pugs.3
+
+.include <bsd.port.pre.mk>
+
+post-configure:
+ @${REINPLACE_CMD} -e '/^INSTALLPRIVLIB/s,${PREFIX}/lib,${PREFIX}/lib/perl6,;' \
+ -e '/^INSTALLARCHLIB/s,${PREFIX}/lib,${PREFIX}/lib/perl6/mach,' \
+ ${WRKSRC}/Makefile
+
+.if !defined(NOPORTDOCS)
+EXDIR= ${WRKSRC}/examples
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ @${CP} -R ${EXDIR}/ ${EXAMPLESDIR}
+ @${FIND} -s ${EXAMPLESDIR} -type f | \
+ ${SED} -e 's|^${PREFIX}/||' >> ${TMPPLIST}
+ @${FIND} -d ${EXAMPLESDIR} -type d | \
+ ${SED} -e 's|^${PREFIX}/|@dirrm |' >> ${TMPPLIST}
+.endif
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.x or later.
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/lang/pugs/distinfo b/lang/pugs/distinfo
new file mode 100644
index 000000000000..53a93eaf50c5
--- /dev/null
+++ b/lang/pugs/distinfo
@@ -0,0 +1,2 @@
+MD5 (Perl6-Pugs-6.0.11.tar.gz) = 0ff4b1f4b93d2288894e975f0e4926a1
+SIZE (Perl6-Pugs-6.0.11.tar.gz) = 315826
diff --git a/lang/pugs/pkg-descr b/lang/pugs/pkg-descr
new file mode 100644
index 000000000000..0b4cde2b4582
--- /dev/null
+++ b/lang/pugs/pkg-descr
@@ -0,0 +1,5 @@
+Pugs is an implementation of Perl 6, written in Haskell.
+It aims to support the full Perl6 specification,
+as detailed in the Synopses.
+
+WWW: http://pugscode.org/
diff --git a/lang/pugs/pkg-plist b/lang/pugs/pkg-plist
new file mode 100644
index 000000000000..455025f49e96
--- /dev/null
+++ b/lang/pugs/pkg-plist
@@ -0,0 +1,14 @@
+bin/kwid
+bin/pugs
+bin/pugscc
+lib/perl6/Kwid.pm
+lib/perl6/perlkwid.kwid
+lib/perl6/Test.pm
+%%SITE_PERL%%/Perl6/Pugs.pm
+%%SITE_PERL%%/Pugs/MakeMaker.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Perl6/Pugs/.packlist
+@dirrm %%SITE_PERL%%/Pugs
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Perl6/Pugs
+@unexec rmdir %D/lib/perl6 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Perl6 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Perl6 2>/dev/null || true