aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-01-11 22:05:13 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-01-11 22:05:13 +0000
commitf0bbc5549847636f4855a852391d983d21ba36b9 (patch)
tree59e939c7f40e98b12bb2925e7f40b77cf109f817 /lang
parentb7899c7f1914fe429a1cb3ad0d80697907d811df (diff)
downloadports-f0bbc5549847636f4855a852391d983d21ba36b9.tar.gz
ports-f0bbc5549847636f4855a852391d983d21ba36b9.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/ruby18/Makefile18
-rw-r--r--lang/ruby19/Makefile9
2 files changed, 15 insertions, 12 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index 274207baa2b1..6f7aec4844fa 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -41,9 +41,11 @@ RUBY_NO_BUILD_DEPENDS= yes
RUBY_NO_RUN_DEPENDS= yes
_RUBY_SYSLIBDIR= ${PREFIX}/lib
-OPTIONS= ONIGURUMA "Build with oniguruma regular expressions lib" off \
- RDOC "Build and install Rdoc indexes" on \
- DEBUG "Compile-in debug info" off
+OPTIONS_DEFINE= ONIGURUMA RDOC DEBUG
+ONIGURUMA_DESC= Build with oniguruma regular expressions lib
+RDOC_DESC= Build and install Rdoc indexes
+DEBUG_DESC= Compile-in debug info
+OPTIONS_DEFAULT= RDOC
.include <bsd.port.pre.mk>
@@ -74,7 +76,7 @@ LDFLAGS+= ${PTHREAD_LIBS}
CONFIGURE_ARGS+=--enable-pthread
.endif
-.if defined(WITH_ONIGURUMA)
+.if ${PORT_OPTIONS:MONIGURUMA}
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}+oniguruma
BUILD_DEPENDS+= ${NONEXISTENT}:${ONIGURUMA_PORTDIR}:patch
ONIGURUMA_PORTDIR=${PORTSDIR}/devel/oniguruma
@@ -87,7 +89,7 @@ PLIST_SUB+= ONIGURUMA="@comment "
#
# Disable doc generation if requested or docs disabled at all
#
-.if !defined(WITHOUT_RDOC) && !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MRDOC} && ${PORT_OPTIONS:MDOCS}
CONFIGURE_ARGS+= --enable-install-doc
.else
CONFIGURE_ARGS+= --disable-install-doc
@@ -144,7 +146,7 @@ post-patch:
.endfor
pre-configure:
-.if defined(WITH_ONIGURUMA)
+.if ${PORT_OPTIONS:MONIGURUMA}
cd ${ONIGURUMA_WRKSRC}; ./configure; \
${MAKE} -f Makefile ${RUBY_RELVERSION:S/.//g} \
RUBYDIR="${WRKSRC}"
@@ -152,7 +154,7 @@ pre-configure:
${TOUCH} ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
post-configure:
-.if defined(WITH_ONIGURUMA)
+.if ${PORT_OPTIONS:MONIGURUMA}
cd ${WRKSRC}/ && ${PATCH} -p0 < ${PATCHDIR}/extrapatch-oniguruma-reggnu.c
.endif
@@ -202,7 +204,7 @@ post-install:
. endfor
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
# Create all dirs required (":u" isn't avaiable in STABLE yet :-()
${MKDIR} ${EXTSAMPLES:C,^([^/]+)/.*,\1,:S,^,${RUBY_EXAMPLESDIR}/,}
${MKDIR} ${EXTDOCS:C,^([^/]+)/.*,\1,:S,^,${RUBY_DOCDIR}/,}
diff --git a/lang/ruby19/Makefile b/lang/ruby19/Makefile
index cd18d92ef063..7b368496edd4 100644
--- a/lang/ruby19/Makefile
+++ b/lang/ruby19/Makefile
@@ -44,8 +44,9 @@ MAKE_JOBS_UNSAFE= yes
NO_LATEST_LINK= yes
-OPTIONS= RDOC "Build and install Rdoc indexes" off \
- DEBUG "Compile-in debug info" off
+OPTIONS_DEFINE= RDOC DEBUG
+RDOC_DESC= Build and install Rdoc indexes
+DEBUG_DESC= Compile-in debug info
.include <bsd.port.pre.mk>
@@ -66,7 +67,7 @@ LDFLAGS+= ${PTHREAD_LIBS} # libraries dependent op libpthread.
#
# Disable doc generation if requested or docs disabled at all
#
-.if defined(WITH_RDOC) && !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MRDOC} && ${PORT_OPTIONS:MDOCS}
CONFIGURE_ARGS+= --enable-install-doc
.else
CONFIGURE_ARGS+= --disable-install-doc
@@ -180,7 +181,7 @@ post-install:
. endfor
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
# Create all dirs required (":u" isn't avaiable in STABLE yet :-()
${MKDIR} ${EXTSAMPLES:C,^([^/]+)/.*,\1,:S,^,${RUBY_EXAMPLESDIR}/,}
${MKDIR} ${EXTDOCS:C,^([^/]+)/.*,\1,:S,^,${RUBY_DOCDIR}/,}