aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMarcel Moolenaar <marcel@FreeBSD.org>2004-02-16 19:03:00 +0000
committerMarcel Moolenaar <marcel@FreeBSD.org>2004-02-16 19:03:00 +0000
commite91938d7ff4abd39aace9ef5b2ca4f6359ec9ce5 (patch)
tree114bc45beb503ce9db68be646be2e0fd73954858 /lang
parentf78667fc99a299bbc50e08c2dcaaa54d7469b25f (diff)
downloadports-e91938d7ff4abd39aace9ef5b2ca4f6359ec9ce5.tar.gz
ports-e91938d7ff4abd39aace9ef5b2ca4f6359ec9ce5.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/python/Makefile2
-rw-r--r--lang/python23/Makefile2
-rw-r--r--lang/python24/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index f1e5839bdd2b..cca1766771f9 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -76,7 +76,7 @@ PLIST_SUB+= X86_ONLY=""
.else
PLIST_SUB+= X86_ONLY="@comment "
.endif
-.if ${ARCH} == amd64
+.if ${ARCH} == amd64 || ${ARCH} == ia64
CFLAGS+= -fPIC
.endif
.if ${ARCH} == amd64 || ${ARCH} == ia64 || ${ARCH} == sparc64 || ${ARCH} == alpha
diff --git a/lang/python23/Makefile b/lang/python23/Makefile
index f1e5839bdd2b..cca1766771f9 100644
--- a/lang/python23/Makefile
+++ b/lang/python23/Makefile
@@ -76,7 +76,7 @@ PLIST_SUB+= X86_ONLY=""
.else
PLIST_SUB+= X86_ONLY="@comment "
.endif
-.if ${ARCH} == amd64
+.if ${ARCH} == amd64 || ${ARCH} == ia64
CFLAGS+= -fPIC
.endif
.if ${ARCH} == amd64 || ${ARCH} == ia64 || ${ARCH} == sparc64 || ${ARCH} == alpha
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index f1e5839bdd2b..cca1766771f9 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -76,7 +76,7 @@ PLIST_SUB+= X86_ONLY=""
.else
PLIST_SUB+= X86_ONLY="@comment "
.endif
-.if ${ARCH} == amd64
+.if ${ARCH} == amd64 || ${ARCH} == ia64
CFLAGS+= -fPIC
.endif
.if ${ARCH} == amd64 || ${ARCH} == ia64 || ${ARCH} == sparc64 || ${ARCH} == alpha