aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-03-26 16:44:25 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-03-26 16:44:25 +0000
commitacf996bc6953cb7050710baafe41c3e289b65f06 (patch)
treebd1c2707527fe4b674c4d0591b6b45e21c7866a4 /lang
parent3fad381f96d85d8c03fe12c59405a7807c6a6c2e (diff)
downloadports-acf996bc6953cb7050710baafe41c3e289b65f06.tar.gz
ports-acf996bc6953cb7050710baafe41c3e289b65f06.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/php4/Makefile12
-rw-r--r--lang/php4/distinfo4
-rw-r--r--lang/php4/files/patch-configure80
-rw-r--r--lang/php4/files/patch-ext::gd::libgd::gdft.c14
-rw-r--r--lang/php4/files/patch-scripts::Makefile.frag11
-rw-r--r--lang/php4/pkg-plist5
6 files changed, 46 insertions, 80 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index cdc3bfd73919..f2a6626250f0 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -20,7 +20,7 @@
#
PORTNAME= php4
-PORTVERSION= 4.3.4
+PORTVERSION= 4.3.5
PORTREVISION= 7
CATEGORIES?= lang devel www
MASTER_SITES= http://www.php.net/distributions/:release \
@@ -110,6 +110,8 @@ CONFIGURE_ARGS+=--enable-fastcgi
CONFIGURE_ARGS+=--enable-discard-path
.endif
SAPI_FILE= bin/php
+.else
+CONFIGURE_ARGS+=--disable-cgi
.endif
PLIST_SUB+= APACHE="@comment "
.else
@@ -247,11 +249,15 @@ CONFIGURE_ARGS+=--with-curl=${LOCALBASE}
.if defined(WITH_DB4)
WITH_DB4_VER?= 41
+.if ${WITH_DB4_VER} == 42
+LIB_DEPENDS+= db4.2.2:${PORTSDIR}/databases/db42
+.else
.if ${WITH_DB4_VER} == 4
LIB_DEPENDS+= db4.0:${PORTSDIR}/databases/db4
.else
LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
.endif
+.endif
CONFIGURE_ARGS+=--with-db4=${LOCALBASE}
.endif
@@ -583,8 +589,7 @@ CONFIGURE_ARGS+=--enable-debug
EXT_DIR:= ${EXT_DIR}-debug
.endif
-PLIST_SUB+= SAPI_FILE=${SAPI_FILE} \
- EXT_DIR=${EXT_DIR}
+PLIST_SUB+= SAPI_FILE=${SAPI_FILE}
.if ${OSVERSION} < 400014 || defined(WITHOUT_IPV6)
CONFIGURE_ARGS+=--disable-ipv6
@@ -714,7 +719,6 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/php.ini-dist ${PREFIX}/etc
@${INSTALL_DATA} ${WRKSRC}/php.ini-recommended ${PREFIX}/etc
@${INSTALL_DATA} ${WRKDIR}/php.conf ${PREFIX}/etc
- @${TOUCH} ${PREFIX}/lib/php/${EXT_DIR}/.keepme
.if !defined(WITHOUT_APACHE)
@${ECHO_CMD} "*****************************************************************************"
@${ECHO_CMD} ""
diff --git a/lang/php4/distinfo b/lang/php4/distinfo
index 6ad1155fc686..233516635d31 100644
--- a/lang/php4/distinfo
+++ b/lang/php4/distinfo
@@ -1,2 +1,2 @@
-MD5 (php-4.3.4.tar.bz2) = b9dd601863e08e52e3c4d5e02c2627cf
-SIZE (php-4.3.4.tar.bz2) = 3774324
+MD5 (php-4.3.5.tar.bz2) = 29e61c125ac6278897c6c219f5d100d1
+SIZE (php-4.3.5.tar.bz2) = 3947414
diff --git a/lang/php4/files/patch-configure b/lang/php4/files/patch-configure
index 2e87a132a3a1..83b46f3a6d3e 100644
--- a/lang/php4/files/patch-configure
+++ b/lang/php4/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig Mon Nov 3 00:27:51 2003
-+++ configure Sat Jan 24 12:58:20 2004
+--- configure.orig Thu Mar 25 15:03:34 2004
++++ configure Fri Mar 26 16:36:02 2004
@@ -617,6 +617,8 @@
ac_help="$ac_help
--enable-gd-jis-conv GD: Enable JIS-mapped Japanese font support."
@@ -8,8 +8,8 @@
+ac_help="$ac_help
--with-gettext[=DIR] Include GNU gettext support."
ac_help="$ac_help
- --with-gmp Include GNU MP support"
-@@ -23070,6 +23072,10 @@
+ --with-gmp[=DIR] Include GNU MP support"
+@@ -23147,6 +23149,10 @@
THIS_PREFIX=$i
THIS_INCLUDE=$i/db4/db.h
break
@@ -20,16 +20,16 @@
elif test -f "$i/include/db4/db.h"; then
THIS_PREFIX=$i
THIS_INCLUDE=$i/include/db4/db.h
-@@ -23089,7 +23095,7 @@
+@@ -23166,7 +23172,7 @@
fi
done
-- for LIB in db-4.1 db-4.0 db-4 db4 db; do
-+ for LIB in db-4.1 db-4.0 db-4 db41 db4 db; do
+- for LIB in db-4.2 db-4.1 db-4.0 db-4 db4 db; do
++ for LIB in db-4.2 db-4.1 db-4.0 db-4 db41 db4 db; do
if test -f $THIS_PREFIX/lib/lib$LIB.a -o -f $THIS_PREFIX/lib/lib$LIB.$SHLIB_SUFFIX_NAME; then
old_LDFLAGS=$LDFLAGS
-@@ -29623,6 +29629,31 @@
+@@ -29711,6 +29717,31 @@
@@ -61,7 +61,7 @@
-@@ -29775,7 +29806,7 @@
+@@ -29863,7 +29894,7 @@
libgd/gd_io_file.c libgd/gd_ss.c libgd/gd_io_ss.c libgd/gd_png.c libgd/gd_jpeg.c \
libgd/gdxpm.c libgd/gdfontt.c libgd/gdfonts.c libgd/gdfontmb.c libgd/gdfontl.c \
libgd/gdfontg.c libgd/gdtables.c libgd/gdft.c libgd/gdcache.c libgd/gdkanji.c \
@@ -70,7 +70,7 @@
libgd/xbm.c"
for ac_func in fabsf floorf
-@@ -29850,6 +29881,11 @@
+@@ -29938,6 +29969,11 @@
fi
@@ -82,7 +82,7 @@
if test "$PHP_JPEG_DIR" != "no"; then
for i in $PHP_JPEG_DIR /usr/local /usr; do
-@@ -31561,6 +31597,9 @@
+@@ -31649,6 +31685,9 @@
cat >> confdefs.h <<\EOF
#define HAVE_GD_BUNDLED 1
@@ -92,7 +92,7 @@
EOF
cat >> confdefs.h <<\EOF
-@@ -31615,6 +31654,14 @@
+@@ -31703,6 +31742,14 @@
GDLIB_CFLAGS="$GDLIB_CFLAGS -DJISX0208"
fi
@@ -107,7 +107,7 @@
else
if test "$PHP_GD" != "no"; then
-@@ -35964,6 +36011,137 @@
+@@ -36052,6 +36099,137 @@
esac
done
@@ -243,9 +243,9 @@
+ done
+
echo $ac_n "checking for gdCacheCreate in -lgd""... $ac_c" 1>&6
- echo "configure:35969: checking for gdCacheCreate in -lgd" >&5
+ echo "configure:36057: checking for gdCacheCreate in -lgd" >&5
ac_lib_var=`echo gd'_'gdCacheCreate | sed 'y%./+-%__p_%'`
-@@ -61825,6 +62003,102 @@
+@@ -62586,6 +62764,102 @@
if test "$ext_shared" = "yes"; then
@@ -348,7 +348,7 @@
ORACLE_SHARED_LIBADD="-lnlsrtl3 $ORACLE_SHARED_LIBADD"
if test -n "$ORACLE_DIR/lib"; then
-@@ -79004,29 +79278,6 @@
+@@ -79741,29 +80015,6 @@
else
@@ -378,7 +378,7 @@
case ct in
c|c_r|pthread*) ;;
*)
-@@ -79050,52 +79301,7 @@
+@@ -79787,52 +80038,7 @@
@@ -432,10 +432,21 @@
save_old_LDFLAGS=$LDFLAGS
-@@ -79241,38 +79447,6 @@
-
-
-
+@@ -79967,38 +80173,6 @@
+ c|c_r|pthread*) ;;
+ *)
+ LIBS="-ltcl $LIBS"
+- ;;
+- esac
+-
+-
+- fi
+- ;;
+- esac
+-
+-
+-
+-
-else
- echo "$ac_t""no" 1>&6
-
@@ -457,29 +468,6 @@
- c|c_r|pthread*) ;;
- *)
- LIBS="-lsybtcl $LIBS"
-- ;;
-- esac
--
--
-- fi
-- ;;
-- esac
--
--
--
--
- fi
-
-
-@@ -93087,10 +93261,7 @@
- CXXFLAGS="$CXXFLAGS $standard_libtool_flag"
-
- all_targets='$(OVERALL_TARGET) $(PHP_MODULES) $(PHP_CLI_TARGET)'
--install_targets="install-sapi install-modules $install_pear install-build install-headers install-programs"
--if test "$PHP_SAPI" != "cgi"; then
-- install_targets="$PHP_INSTALL_CLI_TARGET $install_targets"
--fi
-+install_targets="install-sapi $PHP_INSTALL_CLI_TARGET install-modules $install_pear install-build install-headers install-programs"
-
+ ;;
+ esac
- PHP_VAR_SUBST="$PHP_VAR_SUBST all_targets"
diff --git a/lang/php4/files/patch-ext::gd::libgd::gdft.c b/lang/php4/files/patch-ext::gd::libgd::gdft.c
deleted file mode 100644
index 31e16dc71e8b..000000000000
--- a/lang/php4/files/patch-ext::gd::libgd::gdft.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- ext/gd/libgd/gdft.c.orig Thu Mar 18 16:41:43 2004
-+++ ext/gd/libgd/gdft.c Thu Mar 18 16:49:39 2004
-@@ -60,8 +60,9 @@
- #else
-
- #include "gdcache.h"
--#include "freetype/freetype.h"
--#include "freetype/ftglyph.h"
-+#include <ft2build.h>
-+#include FT_FREETYPE_H
-+#include FT_GLYPH_H
-
- /* number of fonts cached before least recently used is replaced */
- #define FONTCACHESIZE 6
diff --git a/lang/php4/files/patch-scripts::Makefile.frag b/lang/php4/files/patch-scripts::Makefile.frag
deleted file mode 100644
index 0d522f07c4a6..000000000000
--- a/lang/php4/files/patch-scripts::Makefile.frag
+++ /dev/null
@@ -1,11 +0,0 @@
---- scripts/Makefile.frag.orig Fri Sep 19 07:35:21 2003
-+++ scripts/Makefile.frag Sat Nov 22 15:32:41 2003
-@@ -32,6 +32,8 @@
- ext/xml/expat \
- main \
- ext/mbstring \
-+ ext/mbstring/libmbfl \
-+ ext/mbstring/libmbfl/mbfl \
- ext/pgsql \
- regex
-
diff --git a/lang/php4/pkg-plist b/lang/php4/pkg-plist
index fb05a71b4961..c4c7abef9c8c 100644
--- a/lang/php4/pkg-plist
+++ b/lang/php4/pkg-plist
@@ -62,7 +62,6 @@ include/php/ext/mbstring/mbstring.h
include/php/ext/mbstring/php_mbregex.h
include/php/ext/mbstring/php_unicode.h
include/php/ext/mbstring/unicode_data.h
-include/php/ext/mbstring/libmbfl/config.h
include/php/ext/mbstring/libmbfl/mbfl/mbfilter.h
include/php/ext/mbstring/libmbfl/mbfl/mbfilter_8bit.h
include/php/ext/mbstring/libmbfl/mbfl/mbfilter_pass.h
@@ -193,7 +192,6 @@ include/php/regex/regex.h
include/php/regex/regex2.h
include/php/regex/regex_extra.h
include/php/regex/utils.h
-lib/php/%%EXT_DIR%%/.keepme
lib/php/build/Makefile.global
lib/php/build/acinclude.m4
lib/php/build/mkdep.awk
@@ -223,6 +221,8 @@ lib/php/build/shtool
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Common.php
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Config.php
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Dependency.php
+%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Downloader.php
+%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/ErrorStack.php
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Installer.php
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Packager.php
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Registry.php
@@ -242,7 +242,6 @@ lib/php/build/shtool
@dirrm include/php/main
@dirrm include/php/regex
@dirrm include/php/
-@unexec rmdir %D/lib/php/%%EXT_DIR%% 2> /dev/null || true
@dirrm lib/php/build
@unexec rmdir %D/lib/php 2> /dev/null || true
%%CLI%%%%PEAR%%@dirrm share/pear/bootstrap/Archive