aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2010-08-16 18:31:59 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2010-08-16 18:31:59 +0000
commit4e7c0c5a6909f570a100f4c750f70537a05d3a6b (patch)
tree3a4b1dbb40fb3d10bdcef832f944fe924c83c7fc /lang
parent5934330fd0af2d41c7a8aa5055a68d9dc734132d (diff)
downloadports-4e7c0c5a6909f570a100f4c750f70537a05d3a6b.tar.gz
ports-4e7c0c5a6909f570a100f4c750f70537a05d3a6b.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/fpc-rexx/Makefile23
-rw-r--r--lang/fpc-rexx/pkg-plist9
3 files changed, 33 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index ac747a18232a..df6d31581de1 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -75,6 +75,7 @@
SUBDIR += fpc-base
SUBDIR += fpc-docs
SUBDIR += fpc-lua
+ SUBDIR += fpc-rexx
SUBDIR += fpc-tcl
SUBDIR += fpc-units
SUBDIR += fpc-utils
diff --git a/lang/fpc-rexx/Makefile b/lang/fpc-rexx/Makefile
new file mode 100644
index 000000000000..688929c7432f
--- /dev/null
+++ b/lang/fpc-rexx/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: fpc-rexx
+# Date created: 2010-04-22
+# Whom: Christopher Key <cjk32@cam.ac.uk>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= lang
+PKGNAMESUFFIX= -rexx
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Free Pascal interface to the rexx-regina library
+
+USE_FPC= yes
+
+MASTERDIR= ${.CURDIR}/../../lang/fpc
+WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
+EXTRACTUNITDIR+= ${WRKUNITDIR}
+
+OPTIONS= REXX_REGINA "Install rexx-regina library" on
+
+.include "${MASTERDIR}/Makefile"
diff --git a/lang/fpc-rexx/pkg-plist b/lang/fpc-rexx/pkg-plist
new file mode 100644
index 000000000000..dbdbf567659f
--- /dev/null
+++ b/lang/fpc-rexx/pkg-plist
@@ -0,0 +1,9 @@
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/rexx/Package.fpc
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/rexx/rexxsaa.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/rexx/rexxsaa.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/rexx/libprexxsaa.a
+@dirrm lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/rexx
+@dirrmtry lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%
+@dirrmtry lib/fpc/%%PORTVERSION%%/units
+@dirrmtry lib/fpc/%%PORTVERSION%%
+@dirrmtry lib/fpc