aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-09-04 20:01:05 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2013-09-04 20:01:05 +0000
commit9f7e7e1326e79bd8e12c1f04deb511f02f41b2f2 (patch)
tree293dcbc9c7e5b5460095f0f0b868e1ead9528ded /lang
parent4b842875ea2948eda84bd8103594cb2a73c6993d (diff)
downloadports-9f7e7e1326e79bd8e12c1f04deb511f02f41b2f2.tar.gz
ports-9f7e7e1326e79bd8e12c1f04deb511f02f41b2f2.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/gawk/Makefile3
-rw-r--r--lang/gcc-aux/Makefile2
-rw-r--r--lang/gcc/Makefile2
-rw-r--r--lang/gcc34/Makefile2
-rw-r--r--lang/gcc42/Makefile2
-rw-r--r--lang/gcc44/Makefile2
-rw-r--r--lang/gcc46/Makefile2
-rw-r--r--lang/gcc47/Makefile2
-rw-r--r--lang/gcc48/Makefile2
-rw-r--r--lang/gcc49/Makefile2
-rw-r--r--lang/gnat-aux/Makefile2
-rw-r--r--lang/gnat/Makefile2
-rw-r--r--lang/gnatdroid-armv5/Makefile2
-rw-r--r--lang/gnatdroid-armv7/Makefile2
14 files changed, 15 insertions, 14 deletions
diff --git a/lang/gawk/Makefile b/lang/gawk/Makefile
index a01d1ec07ac4..66f27a3b7373 100644
--- a/lang/gawk/Makefile
+++ b/lang/gawk/Makefile
@@ -18,7 +18,8 @@ INFO= gawk gawkinet
USE_XZ= true
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} \
+USES= iconv
+CONFIGURE_ARGS= ${ICONV_CONFIGURE_ARG} \
--with-libintl-prefix=${LOCALBASE} \
AWK=${AWK}
diff --git a/lang/gcc-aux/Makefile b/lang/gcc-aux/Makefile
index 39ac24f969c8..465dba79e8e1 100644
--- a/lang/gcc-aux/Makefile
+++ b/lang/gcc-aux/Makefile
@@ -197,7 +197,7 @@ ADA_CONFIG_ARGS+= --with-system-zlib
ADA_CONFIG_ARGS+= --with-gmp=${PREFIX}
ADA_CONFIG_ARGS+= --with-mpfr=${PREFIX}
ADA_CONFIG_ARGS+= --with-mpc=${PREFIX}
-ADA_CONFIG_ARGS+= --with-libiconv-prefix=${PREFIX}
+ADA_CONFIG_ARGS+= ${ICONV_CONFIGURE_ARG}
ADA_CONFIG_ARGS+= --enable-shared
ADA_CONFIG_ARGS+= --enable-threads=posix
ADA_CONFIG_ARGS+= --disable-bootstrap
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index f86a6e6513cf..67e1d866a8c9 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -71,7 +71,7 @@ CONFIGURE_ARGS+=--disable-nls \
--with-gmp=${LOCALBASE} \
--with-gxx-include-dir=${TARGLIB}/include/c++/ \
--with-ld=${LOCALBASE}/bin/ld \
- --with-libiconv-prefix=${LOCALBASE} \
+ ${ICONV_CONFIGURE_ARG} \
--with-pkgversion="FreeBSD Ports Collection" \
--with-system-zlib
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
diff --git a/lang/gcc34/Makefile b/lang/gcc34/Makefile
index ec6f6ae83cc1..64faa44d86c8 100644
--- a/lang/gcc34/Makefile
+++ b/lang/gcc34/Makefile
@@ -46,7 +46,7 @@ TARGLIB= ${PREFIX}/lib/gcc/${CONFIGURE_TARGET}/${PORTVERSION}
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --disable-nls \
--with-system-zlib \
- --with-libiconv-prefix=${LOCALBASE} \
+ ${ICONV_CONFIGURE_ARG} \
--program-suffix=${SUFFIX} \
--libdir=${TARGLIB} \
--with-gxx-include-dir=${TARGLIB}/include/c++/
diff --git a/lang/gcc42/Makefile b/lang/gcc42/Makefile
index 6e50c2af75d6..6fd6d1f8d414 100644
--- a/lang/gcc42/Makefile
+++ b/lang/gcc42/Makefile
@@ -54,7 +54,7 @@ CONFIGURE_ARGS+=--disable-bootstrap \
--with-gmp=${LOCALBASE} \
--with-gxx-include-dir=${TARGLIB}/include/c++/ \
--with-ld=/usr/bin/ld \
- --with-libiconv-prefix=${LOCALBASE} \
+ ${ICONV_CONFIGURE_ARG} \
--with-pkgversion="FreeBSD Ports Collection" \
--with-system-zlib
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
diff --git a/lang/gcc44/Makefile b/lang/gcc44/Makefile
index 85228e9159b0..7c701064e7a8 100644
--- a/lang/gcc44/Makefile
+++ b/lang/gcc44/Makefile
@@ -56,7 +56,7 @@ CONFIGURE_ARGS+=--disable-bootstrap \
--with-gmp=${LOCALBASE} \
--with-gxx-include-dir=${TARGLIB}/include/c++/ \
--with-ld=${LOCALBASE}/bin/ld \
- --with-libiconv-prefix=${LOCALBASE} \
+ ${ICONV_CONFIGURE_ARG} \
--with-pkgversion="FreeBSD Ports Collection" \
--with-system-zlib
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
diff --git a/lang/gcc46/Makefile b/lang/gcc46/Makefile
index 623bcb92391b..45c0acc325bc 100644
--- a/lang/gcc46/Makefile
+++ b/lang/gcc46/Makefile
@@ -73,7 +73,7 @@ CONFIGURE_ARGS+=--disable-nls \
--with-gmp=${LOCALBASE} \
--with-gxx-include-dir=${TARGLIB}/include/c++/ \
--with-ld=${LOCALBASE}/bin/ld \
- --with-libiconv-prefix=${LOCALBASE} \
+ ${ICONV_CONFIGURE_ARG} \
--with-pkgversion="FreeBSD Ports Collection" \
--with-system-zlib
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index 4b5852bfb834..0db23c296bdb 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -77,7 +77,7 @@ CONFIGURE_ARGS+=--disable-nls \
--with-gmp=${LOCALBASE} \
--with-gxx-include-dir=${TARGLIB}/include/c++/ \
--with-ld=${LOCALBASE}/bin/ld \
- --with-libiconv-prefix=${LOCALBASE} \
+ ${ICONV_CONFIGURE_ARG} \
--with-pkgversion="FreeBSD Ports Collection" \
--with-system-zlib
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index 64c497bac842..4a7327aa8ceb 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -77,7 +77,7 @@ CONFIGURE_ARGS+=--disable-nls \
--with-gmp=${LOCALBASE} \
--with-gxx-include-dir=${TARGLIB}/include/c++/ \
--with-ld=${LOCALBASE}/bin/ld \
- --with-libiconv-prefix=${LOCALBASE} \
+ ${ICONV_CONFIGURE_ARG} \
--with-pkgversion="FreeBSD Ports Collection" \
--with-system-zlib
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
diff --git a/lang/gcc49/Makefile b/lang/gcc49/Makefile
index 17bd1e6d4a35..314253f06a17 100644
--- a/lang/gcc49/Makefile
+++ b/lang/gcc49/Makefile
@@ -77,7 +77,7 @@ CONFIGURE_ARGS+=--disable-nls \
--with-gmp=${LOCALBASE} \
--with-gxx-include-dir=${TARGLIB}/include/c++/ \
--with-ld=${LOCALBASE}/bin/ld \
- --with-libiconv-prefix=${LOCALBASE} \
+ ${ICONV_CONFIGURE_ARG} \
--with-pkgversion="FreeBSD Ports Collection" \
--with-system-zlib
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
diff --git a/lang/gnat-aux/Makefile b/lang/gnat-aux/Makefile
index 80136a37356a..a30042f0efbf 100644
--- a/lang/gnat-aux/Makefile
+++ b/lang/gnat-aux/Makefile
@@ -170,7 +170,7 @@ CONFIGURE_ARGS+= --with-system-zlib
CONFIGURE_ARGS+= --with-gmp=${PKG_PREFIX}
CONFIGURE_ARGS+= --with-mpfr=${PKG_PREFIX}
CONFIGURE_ARGS+= --with-mpc=${PKG_PREFIX}
-CONFIGURE_ARGS+= --with-libiconv-prefix=${PKG_PREFIX}
+CONFIGURE_ARGS+= ${ICONV_CONFIGURE_ARG}
CONFIGURE_ARGS+= --enable-shared
CONFIGURE_ARGS+= --enable-threads=posix
CONFIGURE_ARGS+= --disable-bootstrap
diff --git a/lang/gnat/Makefile b/lang/gnat/Makefile
index e2429122eb22..27822a77abcd 100644
--- a/lang/gnat/Makefile
+++ b/lang/gnat/Makefile
@@ -54,7 +54,7 @@ CONFIGURE_ARGS= --enable-languages="c,ada" \
--program-prefix=gnat \
--disable-nls \
--with-system-zlib \
- --with-libiconv-prefix=${LOCALBASE} \
+ ${ICONV_CONFIGURE_ARG} \
--libdir=${targlib} \
--libexecdir=${targlibexec} \
--disable-libada
diff --git a/lang/gnatdroid-armv5/Makefile b/lang/gnatdroid-armv5/Makefile
index 87b22c34127a..a5b473b8b982 100644
--- a/lang/gnatdroid-armv5/Makefile
+++ b/lang/gnatdroid-armv5/Makefile
@@ -109,7 +109,7 @@ CONFIGURE_ARGS+= --with-system-zlib
CONFIGURE_ARGS+= --with-gmp=${LOCALBASE}
CONFIGURE_ARGS+= --with-mpfr=${LOCALBASE}
CONFIGURE_ARGS+= --with-mpc=${LOCALBASE}
-CONFIGURE_ARGS+= --with-libiconv-prefix=${LOCALBASE}
+CONFIGURE_ARGS+= ${ICONV_CONFIGURE_ARG}
CONFIGURE_ARGS+= --with-sysroot=${SRPREFIX}
CONFIGURE_ARGS+= --with-float=soft
CONFIGURE_ARGS+= --with-fpu=${FPU}
diff --git a/lang/gnatdroid-armv7/Makefile b/lang/gnatdroid-armv7/Makefile
index 8fc4db2bf6da..133905ff62e7 100644
--- a/lang/gnatdroid-armv7/Makefile
+++ b/lang/gnatdroid-armv7/Makefile
@@ -109,7 +109,7 @@ CONFIGURE_ARGS+= --with-system-zlib
CONFIGURE_ARGS+= --with-gmp=${LOCALBASE}
CONFIGURE_ARGS+= --with-mpfr=${LOCALBASE}
CONFIGURE_ARGS+= --with-mpc=${LOCALBASE}
-CONFIGURE_ARGS+= --with-libiconv-prefix=${LOCALBASE}
+CONFIGURE_ARGS+= ${ICONV_CONFIGURE_ARG}
CONFIGURE_ARGS+= --with-sysroot=${SRPREFIX}
CONFIGURE_ARGS+= --with-float=soft
CONFIGURE_ARGS+= --with-fpu=${FPU}