aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2010-09-07 13:57:07 +0000
committerRenato Botelho <garga@FreeBSD.org>2010-09-07 13:57:07 +0000
commiteb6b6a7d155e64e16cd7a0a1323db82d2f504dd6 (patch)
tree149463a095619175123de9f8183f4981e43c03a2 /lang
parentae520c4e867046aebaf34167faacb1b3c2ad1342 (diff)
downloadports-eb6b6a7d155e64e16cd7a0a1323db82d2f504dd6.tar.gz
ports-eb6b6a7d155e64e16cd7a0a1323db82d2f504dd6.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile2
-rw-r--r--lang/ficl-devel/Makefile59
-rw-r--r--lang/ficl-devel/distinfo3
-rw-r--r--lang/ficl-devel/files/patch-Makefile59
-rw-r--r--lang/ficl-devel/files/patch-ficl.h11
-rw-r--r--lang/ficl-devel/pkg-descr10
-rw-r--r--lang/ficl-devel/pkg-plist44
7 files changed, 1 insertions, 187 deletions
diff --git a/lang/Makefile b/lang/Makefile
index f43972be6f2a..f256e6b0c2c6 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -70,7 +70,7 @@
SUBDIR += fasm
SUBDIR += fbbi
SUBDIR += ferite
- SUBDIR += ficl-devel
+ SUBDIR += ficl
SUBDIR += fpc
SUBDIR += fpc-base
SUBDIR += fpc-docs
diff --git a/lang/ficl-devel/Makefile b/lang/ficl-devel/Makefile
deleted file mode 100644
index 860c1e64d968..000000000000
--- a/lang/ficl-devel/Makefile
+++ /dev/null
@@ -1,59 +0,0 @@
-# New ports collection makefile for: ficl
-# Date created: 23 August 2002
-# Whom: Bruce M Simpson
-#
-# $FreeBSD$
-#
-
-PORTNAME= ficl
-PORTVERSION= 4.0.31
-PORTREVISION= 1
-CATEGORIES= lang devel
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-all/${PORTNAME}${PORTVERSION}
-DISTNAME= ${PORTNAME}${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Forth Inspired Command Language
-
-NO_WRKSUBDIR= defined
-NOMAN= defined
-
-ONLY_FOR_ARCHS= i386
-
-USE_GMAKE= yes
-
-ALL_TARGET= everything
-
-DOCS= releases.html parsesteps.html oop.html locals.html links.html \
- license.html index.html api.html ficl.html favicon.ico dpans.html \
- debugger.html upgrading.html
-
-DOCS_ARTICLES= sigplan9906.doc oo_in_c.html jwsforml.pdf ficlddj.pdf
-DOCS_GRAPHICS= sourceforge.jpg ficl_top.jpg ficl_oop.jpg ficl.4.96.jpg \
- ficl.4.64.jpg ficl.4.128.jpg 4ring.gif
-DOCS_SOURCE= upgrading.ht releases.ht parsesteps.ht oop.ht locals.ht \
- links.ht license.ht index.ht generate.py ficl.ht dpans.ht \
- debugger.ht api.ht
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/ficl ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/libficl.so.4 ${PREFIX}/lib
- ${INSTALL_DATA} ${WRKSRC}/libficl.a ${PREFIX}/lib
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${MKDIR} ${DOCSDIR}/source ${DOCSDIR}/articles ${DOCSDIR}/graphics
-.for doc in ${DOCS}
- ${INSTALL_MAN} ${WRKSRC}/doc/${doc} ${DOCSDIR}
-.endfor
-.for doc in ${DOCS_ARTICLES}
- ${INSTALL_MAN} ${WRKSRC}/doc/articles/${doc} ${DOCSDIR}/articles
-.endfor
-.for doc in ${DOCS_GRAPHICS}
- ${INSTALL_MAN} ${WRKSRC}/doc/graphics/${doc} ${DOCSDIR}/graphics
-.endfor
-.for doc in ${DOCS_SOURCE}
- ${INSTALL_MAN} ${WRKSRC}/doc/source/${doc} ${DOCSDIR}/source
-.endfor
-.endif
-
-.include <bsd.port.mk>
diff --git a/lang/ficl-devel/distinfo b/lang/ficl-devel/distinfo
deleted file mode 100644
index 5ace408c1c2c..000000000000
--- a/lang/ficl-devel/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (ficl4.0.31.tar.gz) = 7f9ca6093730554f5f66beaa46a652d4
-SHA256 (ficl4.0.31.tar.gz) = 386f642e5a945ddccc02997a59d0519055d6b9d6dbb8a6a2484884774dab3487
-SIZE (ficl4.0.31.tar.gz) = 571596
diff --git a/lang/ficl-devel/files/patch-Makefile b/lang/ficl-devel/files/patch-Makefile
deleted file mode 100644
index 3a5919282b9a..000000000000
--- a/lang/ficl-devel/files/patch-Makefile
+++ /dev/null
@@ -1,59 +0,0 @@
---- Makefile.orig Mon Dec 8 18:32:26 2003
-+++ Makefile Mon Dec 8 18:46:08 2003
-@@ -0,0 +1,56 @@
-+OBJECTS= dictionary.o system.o fileaccess.o float.o double.o prefix.o search.o softcore.o stack.o tools.o vm.o primitives.o bit.o lzuncompress.o unix.o utility.o hash.o callback.o word.o extras.o
-+HEADERS= ficl.h ficlplatform/unix.h
-+#
-+# Flags for shared library
-+TARGET= -DFREEBSD
-+SHFLAGS = -fPIC
-+CFLAGS= -O -c $(SHFLAGS) $(TARGET)
-+CC=gcc
-+LIB = ar cr
-+RANLIB = ranlib
-+
-+MAJOR = 4
-+
-+everything: ficl lib
-+
-+ficl: main.o $(HEADERS) libficl.a
-+ $(CC) main.o -o ficl -L. -lficl -lm
-+
-+lib: libficl.so.$(MAJOR)
-+
-+# static library build
-+libficl.a: $(OBJECTS)
-+ $(LIB) libficl.a $(OBJECTS)
-+ $(RANLIB) libficl.a
-+
-+# shared library build
-+libficl.so.$(MAJOR): $(OBJECTS)
-+ $(CC) -shared -Wl,-soname,libficl.so.$(MAJOR) \
-+ -o libficl.so.$(MAJOR) $(OBJECTS)
-+ ln -sf libficl.so.$(MAJOR) libficl.so
-+
-+main: main.o ficl.h sysdep.h libficl.so.$(MAJOR).$(MINOR)
-+ $(CC) main.o -o main -L. -lficl -lm
-+ ln -sf libficl.so.$(MAJOR) libficl.so
-+
-+unix.o: ficlplatform/unix.c $(HEADERS)
-+ $(CC) $(CFLAGS) -c ficlplatform/unix.c
-+
-+#
-+# generic object code
-+#
-+.SUFFIXES: .cxx .cc .c .o
-+
-+.c.o:
-+ $(CC) $(CFLAGS) -c $*.c
-+
-+.cxx.o:
-+ $(CPP) $(CPFLAGS) -c $*.cxx
-+
-+.cc.o:
-+ $(CPP) $(CPFLAGS) -c $*.cc
-+#
-+# generic cleanup code
-+#
-+clean:
-+ rm -f *.o *.a libficl.*
diff --git a/lang/ficl-devel/files/patch-ficl.h b/lang/ficl-devel/files/patch-ficl.h
deleted file mode 100644
index 556f0ae5bf42..000000000000
--- a/lang/ficl-devel/files/patch-ficl.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ficl.h.orig Mon Dec 8 18:33:42 2003
-+++ ficl.h Mon Dec 8 18:33:58 2003
-@@ -163,6 +163,8 @@
- #include "ficlplatform/ansi.h"
- #elif defined(_WIN32)
- #include "ficlplatform/win32.h"
-+#elif defined (FREEBSD)
-+ #include "ficlplatform/unix.h"
- #elif defined (FREEBSD_ALPHA)
- #include "ficlplatform/alpha.h"
- #elif defined(linux)
diff --git a/lang/ficl-devel/pkg-descr b/lang/ficl-devel/pkg-descr
deleted file mode 100644
index 8f806fd1ebee..000000000000
--- a/lang/ficl-devel/pkg-descr
+++ /dev/null
@@ -1,10 +0,0 @@
-FICL is an extremely lightweight, fast, portable implementation of FORTH
-which can be bound to C functions or even embedded within C/assembler
-programs. This is a port for the current version of FICL. Older versions
-can typically be found in /usr/src/sys/boot/ficl on FreeBSD with the
-bindings needed by the OS loader.
-
-WWW: http://ficl.sourceforge.net/
-
-Bruce
-bms@spc.org
diff --git a/lang/ficl-devel/pkg-plist b/lang/ficl-devel/pkg-plist
deleted file mode 100644
index 63fe3d4fbae4..000000000000
--- a/lang/ficl-devel/pkg-plist
+++ /dev/null
@@ -1,44 +0,0 @@
-lib/libficl.a
-lib/libficl.so.4
-bin/ficl
-%%PORTDOCS%%%%DOCSDIR%%/upgrading.html
-%%PORTDOCS%%%%DOCSDIR%%/source/upgrading.ht
-%%PORTDOCS%%%%DOCSDIR%%/source/releases.ht
-%%PORTDOCS%%%%DOCSDIR%%/source/parsesteps.ht
-%%PORTDOCS%%%%DOCSDIR%%/source/oop.ht
-%%PORTDOCS%%%%DOCSDIR%%/source/locals.ht
-%%PORTDOCS%%%%DOCSDIR%%/source/links.ht
-%%PORTDOCS%%%%DOCSDIR%%/source/license.ht
-%%PORTDOCS%%%%DOCSDIR%%/source/index.ht
-%%PORTDOCS%%%%DOCSDIR%%/source/generate.py
-%%PORTDOCS%%%%DOCSDIR%%/source/ficl.ht
-%%PORTDOCS%%%%DOCSDIR%%/source/dpans.ht
-%%PORTDOCS%%%%DOCSDIR%%/source/debugger.ht
-%%PORTDOCS%%%%DOCSDIR%%/source/api.ht
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/source
-%%PORTDOCS%%%%DOCSDIR%%/releases.html
-%%PORTDOCS%%%%DOCSDIR%%/parsesteps.html
-%%PORTDOCS%%%%DOCSDIR%%/oop.html
-%%PORTDOCS%%%%DOCSDIR%%/locals.html
-%%PORTDOCS%%%%DOCSDIR%%/links.html
-%%PORTDOCS%%%%DOCSDIR%%/license.html
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/graphics/sourceforge.jpg
-%%PORTDOCS%%%%DOCSDIR%%/graphics/ficl_top.jpg
-%%PORTDOCS%%%%DOCSDIR%%/graphics/ficl_oop.jpg
-%%PORTDOCS%%%%DOCSDIR%%/graphics/ficl.4.96.jpg
-%%PORTDOCS%%%%DOCSDIR%%/graphics/ficl.4.64.jpg
-%%PORTDOCS%%%%DOCSDIR%%/graphics/ficl.4.128.jpg
-%%PORTDOCS%%%%DOCSDIR%%/graphics/4ring.gif
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/graphics
-%%PORTDOCS%%%%DOCSDIR%%/ficl.html
-%%PORTDOCS%%%%DOCSDIR%%/favicon.ico
-%%PORTDOCS%%%%DOCSDIR%%/dpans.html
-%%PORTDOCS%%%%DOCSDIR%%/debugger.html
-%%PORTDOCS%%%%DOCSDIR%%/articles/sigplan9906.doc
-%%PORTDOCS%%%%DOCSDIR%%/articles/oo_in_c.html
-%%PORTDOCS%%%%DOCSDIR%%/articles/jwsforml.pdf
-%%PORTDOCS%%%%DOCSDIR%%/articles/ficlddj.pdf
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/articles
-%%PORTDOCS%%%%DOCSDIR%%/api.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%